Forum: Digitale Signalverarbeitung / DSP / Machine Learning Metronom mit Ne555


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Belinda R. (berudh)


Angehängte Dateien:

Lesenswert?

'moin moin
Ich bitte um euer Urteil.
Der Impuls lässt sich auf eine Sekunde einstellen.
In der 2. Schalterstellung erfolgt ein Impuls etwa alle 3 Sekunden.
Danke

von Christian M. (christian_m280)


Lesenswert?

Naja, das Poți vor dem T bringt Dir überhaupt nichts, wie auch der 100k. 
Ein Kondensator sollte auch noch vor den Lautsprecher!

Gruss Chregu

von Belinda R. (berudh)


Lesenswert?

Christian M. schrieb:
> Naja, das Poți vor dem T bringt Dir überhaupt nichts, wie auch der 100k.
> Ein Kondensator sollte auch noch vor den Lautsprecher!
>
> Gruss Chregu

Das Poți vor dem T , wie auch den 100k habe ich entfernt. So 
funktioniert es.

Wenn ich aber einen C (22µ Elko) vor den Lp setze, dann
tickt es nur noch ein Mal. Danach ist Schluss.
Was kann mein Fehler sein

von Arno R. (arnor)


Lesenswert?

Belinda R. schrieb:
> Wenn ich aber einen C (22µ Elko) vor den Lp setze, dann
> tickt es nur noch ein Mal. Danach ist Schluss.
> Was kann mein Fehler sein

Das ist nicht dein Fehler, sondern der Kondensator ist der Fehler.

Der Transistor schaltet ein und lädt über den Lautsprecher den 
Kondensator auf die 5V auf und der behält die Ladung (die Spannung) auch 
dann wenn der Transistor vom 555 wieder abgeschaltet wird. Beim nächsten 
Einschalten kann in den Kondensator und den Lautsprecher kein 
Umladestrom mehr fließen, es ist dann nichts mehr zu hören.

von Sebastian R. (sebastian_r569)


Lesenswert?

Belinda R. schrieb:
> Wenn ich aber einen C (22µ Elko) vor den Lp setze, dann
> tickt es nur noch ein Mal. Danach ist Schluss.
> Was kann mein Fehler sein

Der Kondensator lädt sich auf und dann war's das, er kann sich im 
Ausschaltzeitraum nicht entladen und lässt dann keinen Strom mehr 
fließen.

Je nach Größe des Lautsprechers kannst du ihn entweder mit Kondensator 
direkt am Ausgang des NE555 anschließen, der hat nämlich eine 
Push-Pull-Ausgangsstufe und entlädt den Kondensator auch wieder oder du 
lässt den Kondensator weg, wenn die Einschaltdauer kurz genug ist.

: Bearbeitet durch User
von Belinda R. (berudh)


Lesenswert?

okay, das funktioniert.
Danke

Ich lasse den C weg. Über den Transistor ist das Klicken etwas lauter.
Der Lp hat 0,5W bei 8 Ohm.

von Enrico E. (pussy_brauser)


Lesenswert?

Belinda R. schrieb:
> Über den Transistor ist das Klicken etwas lauter.

Wird der PNP-Transistor mit positiven oder mit negativen Nadelimpulsen 
angesteuert? Wenn er mit positiven Nadelimpulsen angesteuert wird, dann 
ist er im Ruhezustand voll durchgesteuert und der arme 0,5 Watt 
Lautsprecher zieht einen hohen Ruhestrom von 625mA und muss 3 Watt in 
Wärme umwandeln.

von Arno R. (arnor)


Lesenswert?

Enrico E. schrieb:
> Wird der PNP-Transistor mit positiven oder mit negativen Nadelimpulsen
> angesteuert? ...

Überleg doch selbst. Wie der 555 funktioniert ist doch bekannt.

Der Transistor wird nur kurz eingeschaltet. ABER: der 555 kommt am 
Ausgang nicht bis an die positive Versorgung (~1,5V Abstand) und kann 
deswegen den Transistor nicht sicher abschalten. Die Schaltung sollte 
eigentlich gar nicht funktionieren...

von Belinda R. (berudh)


Lesenswert?

Im Ruhezustand zeigt das Multimeter 0,00mA.
Die Schaltung funktioniert sogar noch bei 2,6V

: Bearbeitet durch User
von Arno R. (arnor)


Angehängte Dateien:

Lesenswert?

Belinda R. schrieb:
> Im Ruhezustand zeigt das Multimeter 0,00mA.

Was ist der Ruhezustand? Abgeklemmte Stromversorgung?

Die typ. High-Ausgangsspannung des 555 ist im Anhang zu sehen. Danach 
wird der PNP nicht (richtig) abgeschaltet.

von Belinda R. (berudh)


Angehängte Dateien:

Lesenswert?

Bei eingeschalteter Versorgungsspannung zeigt das Multimeter 0,00mA 
Stromfluss zwichen Transistor und Lp.

von Arno R. (arnor)


Lesenswert?

Belinda R. schrieb:
> Die Schaltung funktioniert sogar noch bei 2,6V

Belinda R. schrieb:
> Bei eingeschalteter Versorgungsspannung zeigt das Multimeter 0,00mA
> Stromfluss zwichen Transistor und Lp.

Das deutet auf einen CMOS-555 (TLC555, ICM7555, ...) hin, denn der 
bipolare 555 funktioniert nicht mit 2,6V der CMOS-555 aber sehr wohl. 
Und der CMOS-555 schaltet auch den PNP vollständig ab. Wie lautet also 
die exakte Bezeichnung deines "555"?

von Belinda R. (berudh)


Lesenswert?

Der IC ist gekauft vom Chinamann.
Aufgedruckt ist links oben ein unbekanntes Logo
Aufschrift erste Zeile: 12AT68M
Aufschrift zweite Zeile: NE555P

: Bearbeitet durch User
von Arno R. (arnor)


Lesenswert?

Belinda R. schrieb:
> Der IC ist gekauft vom Chinamann.

Was da wirklich drin ist kannst du neben der Messung des 
High-Ausgangspegels (der CMOS555 geht bis ein paar mV an die Versorgung) 
auch über die Ruhestromaufnahme des IC ermitteln. Der bipolare 555 zieht 
einige mA, der CMOS-555 nur <200µA.

von Belinda R. (berudh)


Lesenswert?

Die Gesamtstromaufnahme messse ich mit 1,3 mA.
An PIN 3 messe ich 4,39V gegen GND
und 26mV gegen PLUS.

: Bearbeitet durch User
von Enrico E. (pussy_brauser)


Angehängte Dateien:

Lesenswert?

Belinda R. schrieb:
> An PIN 3 messe ich 4,39V gegen GND

Durch den Einsatz eines 470R parallel zur BE-Strecke vom Transistor 
würde auch eine Nicht-CMOS-Variante des NE555 funktionieren. Aber bleib 
lieber bei der CMOS-Variante die du jetzt auch schon hast!

Belinda R. schrieb:
> Die Gesamtstromaufnahme messse ich mit 1,3 mA.

Bei so wenig Strom kann eine einfache Lautstärkeeinstellung mit einem 
100R Poti realisiert werden. Die Lautstärke lässt sich stufenlos bis auf 
Null runterstellen und jetzt kann sogar wieder problemlos der 22uF Elko 
in Reihe zum LS geschaltet werden.

Du kannst übrigens das offene Ende des 100k Potis mit dem Schleifer 
verbinden. Dann fällt der Sekundentakt nicht komplett aus, falls der 
Schleifkontakt mal verstaubt sein sollte.

: Bearbeitet durch User
von Matthias (matti15898)


Angehängte Dateien:

Lesenswert?

Ich würde die Schaltung so ändern, dass statt des Umschalters ein 
einfacher Schalter genutzt werden kann. Der 560k Widerstand müsste dann 
auf rechnerisch 778k vergrößert werden.

von Belinda R. (berudh)


Lesenswert?

@Enrico
Also da habe ich für 5 Cent einen CMOS mit der Aufschrift NE555 gekauft, 
auch gut.
Mit dem 100 Ohm Poti klappt gut.
Mit dem Elko geht es wieder aus. Aber brauche ich auch nicht. Das muss 
der LS verkraften.


@Matthias
Ich habe den Elko gemessen. Er hat über 2,4µ.
Auf dem Steckbrett kann ich damit genau eine Sekunde einstellen.
Ich hoffe, dass es zusammengelötet auch funktioniert.
Das mit dem Schalter sollte so sein.

von Enrico E. (pussy_brauser)


Angehängte Dateien:

Lesenswert?

Matthias schrieb:
> Ich würde die Schaltung so ändern, dass statt des Umschalters ein
> einfacher Schalter genutzt werden kann. Der 560k Widerstand müsste dann
> auf rechnerisch 778k vergrößert werden.

Das halte ich auch für eine gute Maßnahme. Der 778k könnte aus 510k und 
270k zusammengesetzt werden.

Belinda R. schrieb:
> Mit dem Elko geht es wieder aus.

Der 22uF Elko darf natürlich nicht in Serie mit dem 100R Poti geschaltet 
werden, sondern soll direkt in Serie vor dem Lautsprecher eingebaut 
werden!

von Belinda R. (berudh)


Lesenswert?

Enrico E. schrieb:
> Der 22uF Elko darf natürlich nicht in Serie mit dem 100R Poti geschaltet
> werden, sondern soll direkt in Serie vor dem Lautsprecher eingebaut
> werden!

Genau so angebaut höre ich nur noch ganz leise 2 bis 3 Klicks, dann ist 
Ruhe.

von Enrico E. (pussy_brauser)


Angehängte Dateien:

Lesenswert?

Belinda R. schrieb:
> Genau so angebaut höre ich nur noch ganz leise 2 bis 3 Klicks, dann ist
> Ruhe.

Dann hast du wahrscheinlich vergessen den dritten Anschluss vom 100R 
Poti mit GND zu verbinden!

Durch den vergessenen Anschluss an GND, kannst du die Lautstärke auch 
nicht ganz bis auf Null runterdrehen!

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Angehängte Dateien:

Lesenswert?

Eine Variante:
https://www.555-timer-circuits.com/metronome.html

Scheint diese Variante zu sein:
https://electronicsarea.com/metronome-circuit-555-timer/

Das Bild wäre die Variante mit mehr Lautstärke.

: Bearbeitet durch User
von Enrico E. (pussy_brauser)


Angehängte Dateien:

Lesenswert?

Dieter D. schrieb:
> Das Bild wäre die Variante mit mehr Lautstärke.

Und am besten noch mit einstellbarer Lautstärke.

von Belinda R. (berudh)


Lesenswert?

Enrico E. schrieb:
> Dann hast du wahrscheinlich vergessen den dritten Anschluss vom 100R
> Poti mit GND zu verbinden!

Tatsächlich, so ist es.
Leider ist das Knacken jetzt zu leise.
Vielen Dank für deine Geduld mit mir.

Jetzt werde ich mich mit der anderen Schaltung mit Verstärkung befassen.
Das war auch mein Plan.

von Belinda R. (berudh)


Lesenswert?

@Dieter D
@Enrico E

Eure Schaltung funktioniert sehr gut.
Der Ton scheint sauberer.

Und jetzt das Negative:
Ich habe nur 5V.
Das heißt, es mangelt an Lautstärke.

von Dieter D. (Firma: Hobbytheoretiker) (dieter_1234)


Lesenswert?

Belinda R. schrieb:
> Das heißt, es mangelt an Lautstärke.

Das ist ja auch nur jeweils ein Knacken. Lauter wird es, wenn das kurze 
Pipser im Bereich von 1kHz werden. Dafür benötigt man zwei 555er. Dann 
baut man das noch mit drei weiteren Transistoren zu eine Brückenendstufe 
um. Dann schlägt es den Nachbarn bei jedem Takt aus dem Sessel.

von Belinda R. (berudh)


Lesenswert?

Brückenendstufe klingt wie ein Zauberwort. Was meinst du, ob ich das mit 
ein wenig Hilfe hin bekomme? Wenn man dafür nicht besondere Transistoren 
braucht.
Ich hätte an eine Spannungserhöhung der Versorgungsspannung gedacht.

von Enrico E. (pussy_brauser)


Lesenswert?

Dieter D. schrieb:
> Dann baut man das noch mit drei weiteren Transistoren zu eine
> Brückenendstufe um.

Eine weitere Brückenhälfte in Kollektorschaltung erzeugt nochmal eine 
zusätzliche Dropspannung von 0,7V.

Dieter D. schrieb:
> Dafür benötigt man zwei 555er.

Den zweiten NE555 sollte man dann lieber als Spannungsverdoppler oder 
Step-Up-Wandler einsetzen.

Dieter D. schrieb:
> Lauter wird es, wenn das kurze Pipser im Bereich von 1kHz werden.

Das ist zwar laut, aber dann hört es sich nicht mehr wie ein Metronom 
an.

von Roland F. (rhf)


Lesenswert?

Hallo,
Belinda R. schrieb:
> Und jetzt das Negative:
> Ich habe nur 5V.
> Das heißt, es mangelt an Lautstärke.

Dann pack den Lautsprecher mal in eine Gehäuse.

rhf

von Belinda R. (berudh)


Lesenswert?

An den ICs mit der Aufschrift NE555 soll es nicht liegen. Da habe ich 
genug (Stangenweise sozusagen). Aber ich habe auch einen Lötkolben in 
der Ecke liegen, der sich total langweilt, und endlich zum Einsatz 
kommen möchte.

Ich gebe die 5V jetzt in ein MT3608 DC-DC Step-Up Boost Modul und 
betreibe die Schaltung mit 9V. Das ist laut genug.
Eine ganz bestimmte Frequenz pulsieren zu lassen, ist aber eine gute 
Idee, die ich mir für ein weiteres Projekt vormerke.

Ich danke allen für die nette Hilfe und besonders dafür, das ihr mir 
keine Vorwürfe gemacht habt, dass ich nicht gleich alles verstehen kann 
oder möchte.

von Belinda R. (berudh)


Lesenswert?

Roland F. schrieb:
> Hallo,
> Belinda R. schrieb:
>> Und jetzt das Negative:
>> Ich habe nur 5V.
>> Das heißt, es mangelt an Lautstärke.
>
> Dann pack den Lautsprecher mal in eine Gehäuse.
>
> rhf

hab' ich schon ausprobiert.
Meine beiden alten PC-Boxen 2X4 Ohm in Reihe klingt auch gut.
Aber am besten geht es mit 9 Volt und einem Resonanzkörper. Ersatzweise 
habe ich die Rolle Lötdraht auf den Lautsprecher gelegt. Das schallt 
schon ganz gut, und mir fällt bestimmt noch mehr ein.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.