Forum: PC Hard- und Software HP Elite X2 startet nicht mehr - reparaturversuch


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Holger (loetbadender)


Lesenswert?

Hallo zusammen,

vor etwas über einem Jahr habe ich mir ein gebrauchtes HP Elite x2 1012 
G2 Tablet / Notebook gekauft.

Bis auf gelegentliche Probleme mit dem Akku hat es auch gut 
funktioniert. Jetzt geht es gar nicht mehr an, beim einschalten blinkt 
die orange LED 9x und nichts passiert. Beim Einstecken des USB-C 
Netzteils (Original HP) Blinkt die LED einige Male weiß/orange und 
erlischt für einige Sekunden.

Erstmal im Internet recherchiert und alles harmlose ausprobiert (Power 
Taste für 15 oder 30 Sekunden Drücken um einen Reset durchzuführen, das 
Gerät viele Stunden am Ladegerät lassen, ein anderes Netzteil verwenden) 
leider ohne Erfolg.

Den Akku ausgebaut und überprüft, Spannung der Zellen OK, nichts 
auffälliges.
Dennoch einen neuen Akku bestellt und eingebaut -> Selbes Verhalten.

Mit einem USB Messgerät habe ich herausgefunden das keine höhere 
Spannung als 5V ausgehandelt wird und die Spannung kurz vor dem 
Weiß/Orange geblinke ganz weg ist. Bei 5V werden 200mA aufgenommen was 
auf 100mA sinkt bevor es wieder kurz abschaltet.

Ich vermute ein Problem mit der USB-C Buchse, da sich keine höhere 
Spannung messen lässt, leider ist diese mit dem Mainboard verlötet.

Jetzt die Frage: Was könnte ich noch prüfen? Evtl. 20V an der USB-C 
Buchse anlegen? Irgendwie habe ich da bedenken.

Viele Grüße
Holger

: Bearbeitet durch User
von Holger (loetbadender)


Lesenswert?

UPDATE: Den neuen Akku gemessen -> 0V
Mit dem Labornetzteil 8V bei 200mA Begrenzung angelegt -> Aufnahme 100mA
Akku ist geladen, durch das Anlegen der Spannung wurde der Ausgang 
freigeschaltet. Akku eingebaut -> Läuft

ABER: das Ladegerät wird jetzt komplett ignoriert. Es blinkt oder 
leuchtet nichts beim einstecken.

Da der Akku noch 77% geladen ist, habe ich mal einen USB Stick mit einem 
USB C -> USB A Adapter eingesteckt -> nichts erkannt. Dann ist 
vermutlich die Buchse defekt

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Guck dir mal die Buchse mit einer Lupe an. Meist sieht man da schon, ob 
das noch richtig aussieht oder z.B. Kontakte verbogen oder gebrochen 
sind.

von Holger (loetbadender)


Lesenswert?

Die eine Seite der Buchse sieht schon etwas abgenutzt aus, auf der 
anderen Seite sind die Kontakte noch in Ordnung. Auf den ersten Blick 
würde ich sagen, dass eine Seite auf jeden Fall funktionieren sollte.

Was mich etwas wundert ist, dass seitdem der Akku wieder Spannung 
liefert, kein Strom mehr über USB-C aufgenommen wird, beim Einstecken 
des Kabels passiert nichts, die Stromaufnahme bleibt bei 0mA.

Entfernt man den Akku vom Mainboard werden die 200mA wieder aufgenommen 
und fallen auf 100mA.
Mit Akku gar nichts, das ist schon komisch.

von Holger (loetbadender)


Lesenswert?

Ich habe mich jetzt getraut und 15V an der USB Buchse angelegt. Keine 
Stromaufnahme messbar. Wenn ich jedoch die Powertaste für 15 Sekunden 
Drücke, ist kurzzeitig eine Stromaufnahme von wenigen mA Messbar. Das 
Spricht gegen einen mechanischen Defekt der Buchse :(

von Motopick (motopick)


Lesenswert?

Ganz schlaue haetten den Stecker auch mal um 180 grad gedreht.

Ansonsten:

Viel Erfolg!

von Michael (Firma: HW Entwicklung) (mkn)


Lesenswert?

Wenn der NB trotz 77% Ladezustand nicht auf Akku läuft, hat das alles 
wenig mit dem NT und der Buchse zu tun.

Das Verhalten am NT (Einbruch der Spannung) schaut eher danach aus als 
ob der USB-PD Controller erfolgreich 20V verhandelt und daraufhin den 
Power Pfad einschaltet, was aber sofort zum Kurzschluss führt.
Also wird der Pfad wieder unterbrochen, der PD Controller geht auf 
Fehlermodus und das NT liefert wieder unverhandelte 5V, die es immer 
liefert, wenn einer der CC Pins ein angeschlossenes Gerät meldet.

Der Klassiker währe ein Kurzschluss in einem der DCDC Wandler.
Sind eben die am höchsten belasteten Teile.
Schaltplan besorgen, durchhangeln und hoffen das es etwas ist das Du 
findest, das Du löten kannst und das Du kaufen kannst.
Oder Du besorgst gleich ein Mainboard für knappe 100€ über Ebay.

Holger schrieb:
> ist kurzzeitig eine Stromaufnahme von wenigen mA Messbar
Oszi, also reale mA, oder das was ein träges Multimeter aus einem 
kurzen, hohen Peak macht?

von Holger (loetbadender)


Angehängte Dateien:

Lesenswert?

Motopick schrieb:
> Ganz schlaue haetten den Stecker auch mal um 180 grad gedreht.

Das habe ich natürlich mehrfach gemacht :)

Michael schrieb:
> Wenn der NB trotz 77% Ladezustand nicht auf Akku läuft, hat das alles
> wenig mit dem NT und der Buchse zu tun.

Vielleicht habe ich es etwas schlecht beschrieben. Das Notebook 
funktioniert nur auf Akku (den ich vorher am Labornetzteil geladen 
habe), nicht über das Netzteil. Der Akku lässt sich nur nicht über das 
Notebook laden. Ich denke auch das irgendein Controller oder Mosfet 
defekt ist.
Ich hab mal ein Bild angehängt, da möchte ich nicht unbedingt 
herumlöten.

Michael schrieb:
> Oszi, also reale mA, oder das was ein träges Multimeter aus einem
> kurzen, hohen Peak macht?
Anzeige vom Labornetzteil, also keine realen mA. Habe 15V eingestellt, 
diese sind im Gehäuse vom Notebook

100€ für ein Mainboard ist mir zu teuer, auch weil das Display schon 
einen kleinen Sprung hat. Ich überlege gerade die Zellen auszubauen und 
das Gerät nur über ein 8V Netzteil zu betreiben. Falls die Elektronik 
vom Akku da mitspielt und nicht dicht macht wenn man die Zellen 
entfernt. Evtl. doch mal aufzeichnen was über die Datenleitungen zum 
Akku geht.

Hat zufällig jemand Infos über den Bus, mit dem ein HP Akku mit dem 
Notebook spricht?

von Harald K. (kirnbichler)


Lesenswert?

Holger schrieb:
> Ich hab mal ein Bild angehängt, da möchte ich nicht unbedingt
> herumlöten.

(Warum um alles in der Welt PNG?!)

Das große Bauteil im BGA-Gehäuse ist ein Thunderbolt-Controller. Das ist 
also noch etwas mehr als simples USB.

von Holger (loetbadender)


Lesenswert?

Sorry für das PNG, ich habe ein Screenshot von dem Bild gemacht um die 
Metadaten zu entfernen und den richtigen Ausschnitt zu wählen, das geht 
für mich so am schnellsten, das nächste mal speichere ich es als jpg.

Da das Gerät auch keine USB2 Geräte (mit Adapter) erkennt, ist 
vermutlich der Controller oder etwas an dem Power Management drum herum 
kaputt. Ich überlege gerade ob ich die 15V die am Ende ausgehandelt 
werden sollten, irgendwo direkt anlegen kann.

: Bearbeitet durch User
von Harald K. (kirnbichler)


Lesenswert?

Holger schrieb:
> Da das Gerät auch keine USB2 Geräte (mit Adapter) erkennt, ist
> vermutlich der Controller oder etwas an dem Power Management drum herum
> kaputt.

... oder eben die USB-Buchse bzw. eine der Lötstellen.

von Holger (loetbadender)


Angehängte Dateien:

Lesenswert?

Harald K. schrieb:
> ... oder eben die USB-Buchse bzw. eine der Lötstellen.

Das kann ich mittlerweile ausschließen, ich konnte den Durchgang mit 
einem abgeschnittenen USB Kabel messen

von Daniel F. (df311)


Lesenswert?

Holger schrieb:
> auch weil das Display schon einen kleinen Sprung hat.

Holger schrieb:
> HP Elite x2 1012 G2

gebrauchtes Gerät von Onkel Klaus?

dann weiß ich wahrscheinlich wo es vorher im Einsatz war, hab selber 
zwei gekauft ;-)

Holger schrieb:
> 100€ für ein Mainboard ist mir zu teuer,

ich habe auch zwei gebrauchte hier stehen, die haben jeweils 150 EUR 
gekostet. Da würde es sich (für mich) nicht lohnen was zu tun, besser 
auf die nächste Charge warten ;-)

von Michael (Firma: HW Entwicklung) (mkn)


Lesenswert?

Holger schrieb:
> ich konnte den Durchgang mit
> einem abgeschnittenen USB Kabel messen

HP:
'HINWEIS: Für eine optimale Leistung sollte das HP X2 1012 G2 mit einem 
USB-Power-Delivery-v2-kompatiblen Adapter oder einer Stromquelle geladen 
werden, die 12 V bei 3 A bietet.'

PD verhandelt nicht über die Datenleitungen sondern über den CC.
Teste das Netzteil mal mit einem Handy, ob es mehr als 5V verhandelt.
12V / 3A ist eine moderate Anforderung die noch kein spezielles USB-C 
Kabel erfordert. Du kannst da also alle nehmen und auch mal mit einem 
anderen USB-PD Netzteil testen.

Bevor Du eines kaufst, schau Dir genau an was es liefert.
Steht dort nur eine große Zahl für viele Ports aber nicht das einer 
davon auch explizit 12V bei min 3A kann, Finger weg.
Bekommt man für 25€ beim Jeff, bei morgiger Lieferung.
Z.B. das hier:
https://www.amazon.de/Ladeger%C3%A4t-Adapter-Mehrfach-Schnellladeger%C3%A4t-Netzteil-Wei%C3%9F/dp/B0CM6HRYL9

Und wenn es trotzdem nicht läuft:
Amazon ist sehr kulant bei Rückgaben.

von Harald K. (kirnbichler)


Lesenswert?

Holger schrieb:
> Das kann ich mittlerweile ausschließen, ich konnte den Durchgang mit
> einem abgeschnittenen USB Kabel messen

Eine USB-C-Buchse hat 24 Kontakte. Wenn Du nur die Datenleitungen für 
USB2 ansiehst, weißt Du wenig über die anderen Kontakte.

Gibts auch ein Bild von der Platinenunterseite?

: Bearbeitet durch User
von Michael (Firma: HW Entwicklung) (mkn)


Lesenswert?

Harald K. schrieb:
> Eine USB-C-Buchse hat 24 Kontakte

Und benötigt für Power Delivery 4 davon.
GND, Vusb, und die beiden CC.
Nur einen CC wenns auf NT Seite hart verbunden ist.

von Holger (loetbadender)


Angehängte Dateien:

Lesenswert?

Harald K. schrieb:
> Gibts auch ein Bild von der Platinenunterseite?

Leider nicht, ich habe das Mainboard nicht ausgebaut.
Würde PD funktionieren wenn eine Seite der USB Pins nicht kontaktieren ?

Um auf Nummer sicher zu gehen habe ich nochmal ein BIOS Update 
durchgeführt und versucht die Firmware des Thunderbolt Controllers zu 
aktualisieren, leider ohne Erfolg, das Update Tool von HP kann diesen 
nicht finden.

Mein aktueller Ansatz ist, SMBus Signale vom Akku zum Notebook 
aufzeichenen und versuchen diese zu emulieren. Akku raus und direkt mit 
8V versorgen.

: Bearbeitet durch User
von Harald K. (kirnbichler)


Lesenswert?

Holger schrieb:
> Leider nicht, ich habe das Mainboard nicht ausgebaut.

Mit anderen Worten: Du weißt also auch überhaupt nicht, wie die 
Lötstellen der USB-Buchse aussehen.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Holger schrieb:
> Akku raus und direkt mit
> 8V versorgen.

Lass den Akku doch drin und führe nur die Plus- und Minusleitung 
zusätzlich nach draussen. Die kannst du dann mit dem Ladegerät 
verbinden.

von Holger (loetbadender)


Angehängte Dateien:

Lesenswert?

Harald K. schrieb:
> Mit anderen Worten: Du weißt also auch überhaupt nicht, wie die
> Lötstellen der USB-Buchse aussehen.

Du hast mich überzeugt, ich habe es ausgebaut und alle THs kurz 
nachgelötet, die SMD Pins sind vermutlich unter der Abschirmung.

Matthias S. schrieb:
> Lass den Akku doch drin und führe nur die Plus- und Minusleitung
> zusätzlich nach draussen. Die kannst du dann mit dem Ladegerät
> verbinden.

Du hast recht, ist vermutlich am sinnvollsten, über den SD-Slot könnte 
ich sie auch rausführen ohne das Gehäuse anzubohren :)

von Holger (loetbadender)


Angehängte Dateien:

Lesenswert?

Projekt erstmal funktional abgeschlossen.
Hat evtl. jemand einen Tipp für eine 8V Stromversorgung im Bereich 2-4A?

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.