Forum: Analoge Elektronik und Schaltungstechnik Hilfe bei Reparatur von Federwiegen-Motor


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Chris .. (dechavue)


Angehängte Dateien:

Lesenswert?

Hallo,

ich habe eine Federwiege (Swing2Sleep Maly) zur Reparatur bekommen, 
nachdem ein 19V anstatt eines 9V Netzteils angesteckt wurde. Ich stehe 
aber nun etwas an. Vielleicht hat jemand von euch noch Ideen zur 
Fehlersuche, oder kann mir beim Identifizieren eines Bauteils auf der 
Platine helfen.
Meine Vermutung ist, dass der 24-Pin IC in der Mitte defekt ist, da ich 
bei den Ausgängen zu den Motoren nichts Messe und der Chip auch mit & 
ohne Last sehr heiß wird. Leider ist bei diesem Chip die Beschriftung 
abgefeilt. Die Spannungsversorgung dürfte grundsätzlich noch 
funktionieren, da sowohl die LEDs funktionieren, und sich auch an den 
ICs noch 5V-Signale messen lassen.

Im angehängten PDF sind noch mehr Photos der Platine, mit 
Bauteilbezeichnungen und meinen bisherigen Analysen.

Es wäre toll, wenn mir jemand weiterhelfen könnte. Falls ihr noch 
weitere Photos oder Messungen braucht, bitte bescheid sagen.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Was geht denn noch? Reagiert z.B. die LED Kette mit dem LM3914? Sind die 
5V noch da?

Ich messe als erstes meist den Schaltregler. An der Speicherdrossel 
sollte auf der einen Seite Rechteck anliegen und auf der anderen Seite 
gesiebte, geregelte Gleichspannung.
Vermutlich ist aber schon die Motorendstufe defekt. Vllt. kann ein 
anderer Forenteilnehmer etwas zum Typ sagen.

von Chris .. (dechavue)


Lesenswert?

Die LED-Kette funktioniert noch und an den ICs sind auch noch 5V Signale 
vorhanden. (Z.B. eine PWM am 8-Pin abgefeilten IC, welche sich abhängig 
vom Poti verändert)

An der Drossel werde ich heute Abend gleich nochmal messen.

von Chris .. (dechavue)


Lesenswert?

Matthias S. schrieb:

> Ich messe als erstes meist den Schaltregler. An der Speicherdrossel
> sollte auf der einen Seite Rechteck anliegen und auf der anderen Seite
> gesiebte, geregelte Gleichspannung.

Habe jetzt gerade nachgemessen, an der Drossel messe ich an einer Seite 
eine Rechteck-Spannung an der anderen 5V Gleichspannung.

Ich fürchte auch, dass es die Motorendstufe ist.

Würde mich freuen, wenn noch jemand einen Tipp hätte welcher Typ das 
sein könnte

von Gerald B. (gerald_b)


Lesenswert?

Da "nur" der Motortreiber heimgegangen ist, könnte man irgend ein 
leistungsmäßig passendes Chinaboard an die von dir bereits analysierten 
Steuersignale dranklöppeln.
Sollte sich das Ding wiederbeleben lassen, dann löte parallel zur 
Spannungsversorgung noch eine TVS Diode. Die ist im Schadensfall 
einfacher zu wechseln ;-)

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Chris .. schrieb:
> Würde mich freuen, wenn noch jemand einen Tipp hätte welcher Typ das
> sein könnte

Ich habe mal oberflächlich nach einem 3 Kanal Motortreiber für 
Bürstenmotoren im SO24 Gehäuse gesucht, aber bin nicht so richtig fündig 
geworden.

von H. H. (hhinz)


Lesenswert?

TB6612FNG

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

H. H. schrieb:
> TB6612FNG

Leider nur 2 Motoren. Hier werden 3 benötigt.

von H. H. (hhinz)


Lesenswert?

Matthias S. schrieb:
> H. H. schrieb:
>> TB6612FNG
>
> Leider nur 2 Motoren. Hier werden 3 benötigt.

Du vergisst den noch unbekannten 8-Beiner.

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

H. H. schrieb:
> Du vergisst den noch unbekannten 8-Beiner.

Unterhalb des SO24? Das ist der MC. Keine Verbindung zum 6-pol Molex, an 
dem die Motoren hängen. Am SO24 sind 6 Ausgänge verdrahtet, alle mit 2 
parallel geschalteten Pins - und alle gehen zu dem Motoranschluss.

von H. H. (hhinz)


Lesenswert?

Matthias S. schrieb:
> Unterhalb des SO24? Das ist der MC.

Stimmt, muss er sein.

Mal sehen, wer noch eine Idee zum SSOP24 hat.

von Chris .. (dechavue)


Lesenswert?

Danke schon mal an alle fürs Brainstormen.

Vieleicht ist es ein kompletter Blödsinn, aber was mir als Laie noch 
eingefallen ist, könnte es sein, dass einer der Motoren als Sensor 
missbraucht wird? (Damit es passend zur Federung schwingt?) Dann wären 
es nur 2 Motoren, welche angetrieben werden müssten.

Ich hab es nochmal durchgeklingelt und die beiden mittleren Anschlüsse 
des Motor-Molex gehen tatsächlich nicht auf den 24-Pin IC, sondern der 
rote auf Gnd und der weiße auf den Bereich links oben 
(Durchkontaktierung zwischen R6 & R7)

Wenn an der Vermutung was dran ist, könnte einer für 2 Motoren doch 
passen.
(Könnte es möglicherweise doch der von H.H. vorgeschlagene sein?)

@Gerald B. Das wäre die Fallback-Lösung, wenn ich es wirklich nicht 
rausfinde, dass ich mir die Steuerung selbst zusammenbastle.

: Bearbeitet durch User
von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Chris .. schrieb:
> (Könnte es möglicherweise doch der von H.H. vorgeschlagene sein?)

Vergleiche sein Pinout mit deiner Platine.
https://www.mouser.de/datasheet/2/408/TB6612FNG_datasheet_en_20141001-708260.pdf

von Michael B. (laberkopp)


Lesenswert?

Chris .. schrieb:
> Federwiege (Swing2Sleep Maly) zur Reparatur bekommen

Wegschmeissen ?

Als Baby würde ich mich bei dem Geschaukel übergeben.

Aber diese modernen Eltern haben sicher auch einen Staubsaugerroboter, 
einen ePriam Elektro-Kinderwagen und nutzen zur Druckbetankung des Babys 
einen Nespresso-Automaten.

Damit sie unglaublich viel Freizeit haben - in der sie eigentlich Was 
machen ?

Beitrag #7651985 wurde vom Autor gelöscht.
von Thomas W. (goaty)


Lesenswert?

Matthias S. schrieb:
> Chris .. schrieb:
>> (Könnte es möglicherweise doch der von H.H. vorgeschlagene sein?)
>
> Vergleiche sein Pinout mit deiner Platine.
> https://www.mouser.de/datasheet/2/408/TB6612FNG_datasheet_en_20141001-708260.pdf

Schaut gut aus, evtl ist der "dritte Motor" immer an Dauerplus ?

von Chris .. (dechavue)


Lesenswert?

Der Pinout schaut aus meiner Sicht wirklich plausibel aus.

Ich habe mal einen Bestellt und werde berichten ob es damit wieder 
funktioniert.

Herzlichen Dank schon mal an alle für die kompetente Hilfe 👍

von Matthias S. (Firma: matzetronics) (mschoeldgen)


Lesenswert?

Evtl. ist das auch so ein 'Anschubs' Motor, der die Nummer in Bewegung 
setzt, wenn man die Wiege händisch bewegt. So könnte der Motor dann als 
Sensor fungieren. Entweder, um die Wiege in Resonanz zu bekommen 
(Babyschleuder :-P) oder das Prinzip des elektromagnetischen 'ewigen' 
Pendels nachzubilden.

Michael B. schrieb:
> bla blupp

Nach wie vor ist das hier kein Forum für Lebensberatung, sondern für MC 
und Elektronik.

: Bearbeitet durch User
von Chris .. (dechavue)


Lesenswert?

Hab den Chip heute getauscht und die Federwiege funktionier wieder

DANKE nochmals an alle Helfer 👍

von Roland D. (roland_d284)


Lesenswert?

Moin,

spät, aber....

Chris .. schrieb:
> Vieleicht ist es ein kompletter Blödsinn, aber was mir als Laie noch
> eingefallen ist, könnte es sein, dass einer der Motoren als Sensor
> missbraucht wird?

Ich hatte mal so ein Teil zur Reparatur, da war das genau so gemacht. 
Ein Motor als sozusagen Sensor-Generator.

In meinem Fall war ein Linearregler für die Spannungsversorgung kaputt. 
Hab ihn ersetzt, 2 Wochen Später war das Teil wieder kaputt.

Meine Vermutung damals: Die haben nicht bedacht was passiert, wenn man 
die Versorgungspannung abschaltet und das Baby weiter schwingt und über 
den Sensor-Motor und die beiden Antriebsmotoren weiter lustig Strom 
erzeugt. Deshalb gehen die Geräte auch immer zuverlässig dann kaputt, 
wenn das Baby ein gewisses Gewicht überschreitet.

Gruß, Roland

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.