Forum: Haus & Smart Home Verbindungsproblem VLC --> VPN Wireguard --> Fritzbox --> Reolink IP-Camera


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Peter Z. (hangloose)


Lesenswert?

Würde gerne das Bild einer Reolink IP-Camera über den

VPN Wireguard Tunnel und VLC Media Player (RTSP Stream) Empfangen.

Irgendwie mag der VLC, den Tunnel nicht...

Im Heimnetzwerk funktioniert der RTSP Stream mit VLC ohne Probleme.

Über den Wireguard Tunnel kann ich auch die IP-Camera über den Browser 
ansprechen und der Stream funktioniert im Browser.

Nur mit VLC über den Wireguard Tunnel bleibt das Bild schwarz. Audio 
wird allerdings übertragen.

Hat dazu jemand eine Idee, wo das Problem liegen könnte?

VLC Player verhält sich am PC und am Smartphone gleich.

Hatte nach Internetsuche jemanden mit gleichem Problem gefunden.
Der hatte nur andere Hardware. Bei dem stellte sich dieses Problem
nach einem Update des Telekom Router ein. Seine Lösung war bei der
IP-Camera MTU 1500 auf 1400 einzustellen. Diese Einstellmöglichkeit
hat aber die Reolink Camera nicht.

: Bearbeitet durch User
von J. S. (jojos)


Lesenswert?

Funktioniert bei mir ohne Probleme, rtsp://garten z.B. wenn Garten der 
Kameraname ist, sonst nichts bei rtsp verstellt.
Es dauert nur etwas bis das Bild kommt, Ton ist auch vorher da.

: Bearbeitet durch User
von Peter Z. (hangloose)


Lesenswert?

Hast du auch eine Reolink IP-Camera und Fritzbox als Router?

von J. S. (jojos)


Lesenswert?

Ja, auch mit WireGuard. Verbindet auch automatisch mit dem VPN, sehr 
genial.

von Peter Z. (hangloose)


Lesenswert?

Ja stimmt, Wireguard ist genial und der Rest funktioniert auch super.
Keine Ahnung warum das er beim VLC bei mir so rumzickt.
Alles hat die aktuellen Updates...

von J. S. (jojos)


Angehängte Dateien:

Lesenswert?

hier sind meine Einstellungen, die Menus fand ich etwas zu versteckt. Es 
ist eine RLC-510A, war mal Restposten bei Reichelt und lag hier lange 
rum. Habe ich auch gerade erst seit ein paar Wochen in Betrieb genommen. 
Die hat kein Format was das Smartphone direkt im Browser anzeigen kann, 
das ist blöd. Habe noch eine Dahua, teurer aber wesentlich besser, auch 
was Nachtsicht angeht.

von Peter Z. (hangloose)


Lesenswert?

Die Einstellungen sind bei mir genauso bei meiner Reolink RLC-823A

Wie gesagt im Heimnetz funktionierts ohne Probleme mit dem VLC.
Keine Ahnung wo das Problem liegt.

Eigentlich wäre es mir ja egal, da es ja übern Browser funktioniert.
Wollte mir nur ein kleines VB.NET Programm
schreiben mit VLC Fenster integriert und die PTZ Steuerung über Buttons.
Da gibt es ja eine umfangreiche API von Reolink zum Ansteuern.
https://drive.google.com/drive/folders/1qvKcKswNJP_-G0tTbs_JQOuO67QqujfB

Vielleicht ist auch der Fritz Repeater das Problem an dem die Reolink im 
Mesh der Fritzbox hängt.

: Bearbeitet durch User
von Oliver S. (phetty)


Lesenswert?

Die MTU ist offensichtlich zu groß. In der Kamera geht's nicht.
In wireguard gibt es auch eine Option dafür.

von Christian M. (christian847)


Lesenswert?

Oliver S. schrieb:
> Die MTU ist offensichtlich zu groß. In der Kamera geht's nicht.
> In wireguard gibt es auch eine Option dafür.

Würde auch auf MTU tippen. Lässt sich ja einfach testen. 
https://blog.boll.ch/basic-stuff-mtu-groesse-mit-ping-testen/

Grüße

von Peter Z. (hangloose)


Lesenswert?

@Christian M.
Der Test hat einen Wert von 1360

@Oliver S.
Habe ermittelten Wert bei Wireguard config mit MTU = 1360 angegeben.
Hat leider nichts geholfen.

Auch im VLC Player kann man einen MTU Wert bei den Einstellungen 
angeben.
Funktioniert auch nicht.

von Peter Z. (hangloose)


Lesenswert?

Auf Reddit hatte jemand das gleiche Problem.
Es ist eine Einstellung beim VLC.

Lösung:

"live555 stream transport" should be moved from "HTTP (default)" to "RTP 
over RTSP (TCP)"

von Christian M. (christian847)


Lesenswert?

Hallo,

versuch bitte einmal den ermittelten Wert 1360 - 40 = 1320 einzutragen. 
Ich habe ähnliche Probleme mit OpenVPN gehabt (sicherlich nicht 1:1 
übertragbar), aber die 40 Bytes müssen aufgrund von (VPN-) 
Protokolloverhead abgezogen werden.

lg
Christian

: Bearbeitet durch User
von Peter Z. (hangloose)


Lesenswert?

@Christian M.
Das Problem hat sich erledigt... siehe einen Post ober dir.
MTU war bei mir nicht das Problem

von Hmmm (hmmm)


Lesenswert?

Christian M. schrieb:
> die 40 Bytes müssen aufgrund von (VPN-) Protokolloverhead abgezogen
> werden.

Du verwechselst da etwas.

Das VPN sorgt für eine niedrigere MTU, hier 1360 Bytes statt 1500 
(Ethernet) oder 1492 (PPPoE).

Die 40 Bytes (entspricht IP- und TCP-Header) musst Du von der MTU 
abziehen, um daraus die TCP-MSS zu berechnen, insbesondere für 
MSS-Clamping.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.