Forum: Mikrocontroller und Digitale Elektronik Seltsamer Effekt/Bauteil


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Klaus (cato)


Angehängte Dateien:

Lesenswert?

Servus zusammen,
ich hab zwar kein Controllerproblem, aber ein anderes techn. Problem:
Ich hab mir ein Bremslicht an mein Pedelec gebaut. Schalten wollte ich 
mit einem Reedkontakt. Die bei A. gekauften RRelais waren leider 
Schrott, die habe ich deßhalb nicht verwendet. Zufällig hab ich aber 
gerade einen Kettler Ergometer verschrottet und aus diesem ein Teil 
ausgebaut welches m.E. ein Reedrelais ist (saß an der Schwungscheibe, 
vermtl wg Drehzahlmessung).
Erstmal gemessen mit Ohmmeter und Magnet, hat funktioniert. Dann am 
Fahrrad angebaut, siehe Bild. Hab durch verschieben des Bauteils so 
eingestellt daß die Schaltschwellen sauber mit Ein-Ausschaltreserve 
funktionieren. Ging auch alles super.
Aber: Wenn das Ding länger (paar Stunden) nicht geschaltet wird und ich 
die Spannungsversorgung (12V vom Boschmotor) einschalte, hat das Relais 
Durchgang, d.h. das Bremslicht leuchtet obwohl der Bremshebel in 
Grundstellung ist. Das bleibt so bis ca nach einer halben Stund das 
Relais wieder sauber funktioniert.
Was könnte das für eine Ursache haben?

Grüße Klaus

von Monk (roehrmond)


Lesenswert?

Klaus schrieb:
> Was könnte das für eine Ursache haben?

Vielleicht dringt Wasser ein.

von Niklas G. (erlkoenig) Benutzerseite


Lesenswert?

Der "Bisspunkt" von hydraulischen und auch mechanischen Bremsen 
verschiebt sich ja kontinuierlich, und damit auch die Bremskraft, bei 
der dein Bremslicht auslöst... Die meisten Fahrrad-Bremslichter machen 
das mit einem Accelerometer.

: Bearbeitet durch User
von Klaus (cato)


Lesenswert?

@ Monk: Wasser kann ich ausschliessen, Fahrrad steht trocken.

@ Erlkoenig : Tatsächlich habe ich als Bremslicht eines mit 
Accelerometer verbaut, welches aber nicht vernünftig funktioniert, wie 
alle von den Dingern die ich getestet habe. Die Schalten sogar schon 
wenn man nur aufhört zu treten. Sowas kann ich nicht gebrauchen, da wird 
ja jeder Nachfolgefahrer das Bremslicht nicht mehr ernstnehmen wenn das 
dauernd leuchtet. Genau aus diesem Grund hab ich ja den Schalter 
hingebaut, da kann das Licht erst leuchten wenn ich wirklich den 
Bremshebel betätige, zumindest sollte es so sein.

: Bearbeitet durch User
von Udo S. (urschmitt)


Lesenswert?

Sicher dass das Reed Relais die Ursache ist oder eher ein Bremslicht mit 
integriertem Beschleunigungssensor, das jetzt ständig ein und 
ausgeschaltet wird.

Siehe:

Klaus schrieb:
> Tatsächlich habe ich als Bremslicht eines mit
> Accelerometer verbaut, welches aber nicht vernünftig funktioniert,

Klaus schrieb:
> Genau aus diesem Grund hab ich ja den Schalter
> hingebaut, da kann das Licht erst leuchten wenn ich wirklich den
> Bremshebel betätige

von Klaus (cato)


Lesenswert?

Udo S. schrieb:
> Sicher dass das Reed Relais die Ursache ist oder eher ein Bremslicht mit
> integriertem Beschleunigungssensor, das jetzt ständig ein und
> ausgeschaltet wird.
>
>
Ja, das Bremslicht bekommt ja erst Strom über das Relais, bzw. so sollte 
es sein.
Aber aus irgendeinem Grund verschiebt sich der Einschaltpunkt.

Nochmal zur Erklärung:
Bei ca 80 % Hebelweg, kurz vorm hydraulischen Druckpunkt schaltet das 
Relais ein, Licht geht an. Lasse ich den Hebel los schaltet das Relais 
bei ca 20% Hebelweg wieder aus, dazwischen liegt die Hysterese. Das geht 
alles einwandfrei mit ausreichend Reserve beim Hebelweg. Auch beim 
wiederholten Betätigen alles stabil.
Nur wenn das Rad längere Zeit ausgeschaltet ist, ich dann die 
Stromversorgung einschalte hat das Relais eingeschaltet obwohl der 
Bremshebel in Grundstellung steht. Das bleibt ca 15 min so bis es dann 
wieder sauber funktioniert. Ich hab dafür keine physikalische Erklärung, 
der Magnet ist fest fixiert, ebenso das Relais.
Es sei denn das ist kein normales Reedrelais sondern irgend was anderes. 
Die Anschlüsse haben aber keine Polung, auch beim schalten verhält es 
sich wie ein Reedrelais.

: Bearbeitet durch User
von Niklas G. (erlkoenig) Benutzerseite


Lesenswert?

Klaus schrieb:
> Die Schalten sogar schon
> wenn man nur aufhört zu treten.

Es gibt welche mit einstellbaren Schaltschwellen...

von Klaus (cato)


Lesenswert?

Niklas G. schrieb:
> Klaus schrieb:
>> Die Schalten sogar schon
>> wenn man nur aufhört zu treten.
>
> Es gibt welche mit einstellbaren Schaltschwellen...

Hallo Niklas,

hättest du da einen Link zu einem mit einstellbarer Empfindlichkeit?

Danke, Klaus

: Bearbeitet durch User
von Christian S. (roehrenvorheizer)


Lesenswert?

Klaus schrieb:
> Das bleibt so bis ca nach einer halben Stund das
> Relais wieder sauber funktioniert.

Tja wir wissen nicht, welche Stromstärke da geschaltet werden soll, 
wieviel Stromtragfähigkeit das Reedrelais hat, ob es durch den 
Stromfluss magentisiert wird oder ob sonstwo her ein Magnetfeld kommen 
könnte, z.B. von den Schaltern für den Motor.

Bei Tonbandgeräten nimmt man gelegenlich eine Entmagentisierung der am 
Bandlauf beteiligten Teile vor.

mfg

von Rainer W. (rawi)


Lesenswert?

Klaus schrieb:
> hättest du da einen Link zu einem mit einstellbarer Empfindlichkeit?

Das artet hier doch sehr in Fahrzeugelektronik (und entsprechende 
Bastelei) aus.
Normalerweise setzt sich so ein beschleunigungsabhängiger Schalter aus 
einem Sensor, einem Schwellwertgeber, einem Komparator und einer 
Schaltstufe zusammen.

: Bearbeitet durch User
von Klaus (cato)


Lesenswert?

Das sind nur ein paar Milliampere für das Bremslicht. Und da kann 
eigentlich auch nirgends ein Magnetfeld herkommen, zumindest keines 
welches relevant ist zum Unterschied zu dem Neodymmagneten welchen ich 
im Bremsgriff verklebt habe.
Ausserdem hab ich den seltsamen Effekt ja nachdem alles ausgeschaltet 
war.

von Niklas G. (erlkoenig) Benutzerseite


Lesenswert?

Klaus schrieb:
> hättest du da einen Link zu einem mit einstellbarer Empfindlichkeit?

Lupine Rotlicht

von Stefan M. (derwisch)


Lesenswert?

Was passiert denn, wenn Du testweise mal den Magnet ganz entfernst 
(falls das noch geht).
Ich könnte mir vorstellen, dass der Magnet noch zu dicht am Reedkontakt 
ist.
Wenn das äussere Magnetfeld ganz fehlt, sollte ja nichts passieren.

Der Kontakt muss sich ja offenbar wieder schliessen, währen das Fahrrad 
abgestellt ist.

Ich würde jetzt ein gut hörbaren Durchgangsprüfer an den Reedkontakt 
anschliessen, und warten bis der nach Zeit "X" plötzlich Alarm macht.

Das muss ja (Deiner Beschreibung nach) irgendwann passieren, nachdem das 
Fahrrad abgestellt wurde.

Einen zufälligen thermischen Effekt (Magnetfeld wird bei Abkühlung 
stärker) würde ich auch nicht ausschliessen.

: Bearbeitet durch User
von Klaus (cato)


Lesenswert?

@ Niklas Danke.

@ Stefan:

Zu dicht kann er nicht sein, dann würde das Relais ja nie öffnen.
Ich hab mir jetzt einfach noch einen besseren Reedkontakt bestellt und 
werde den ausprobieren. Vielleicht ist das Ding was ich aus dem 
Ergometer ausgebaut habe irgend was spezielles. Wenn es mit dem neuen 
klappt mach ich es mal auf und werde berichten was ich gefunden habe.

Danke an alle und Grüße

Klaus

von Teo D. (teoderix)


Lesenswert?

Klaus schrieb:
> Neodymmagneten

So ein Reed-Relais ist nur für eine max. Feldstärke geeignet, darüber 
hinaus magnetisieren sich die Zungen -> Relais kaputt.
Schaltet es sich WIRKLICH von selbst ein, oder bleibt es beim Abschalten 
einfach nur hängen?
Reagiert es auf leichtes Klopfen?

von Dietrich L. (dietrichl)


Lesenswert?

Klaus schrieb:
> Vielleicht ist das Ding was ich aus dem
> Ergometer ausgebaut habe irgend was spezielles.

Es gibt auch bistabile Reedrelais. Da muss man das Magnetfeld jeweils 
umpolen, wenn man ein- oder auschalten will:
https://standexelectronics.com/de/produkte/bistabile-reed-schalter/

Vielleicht ist dein Relais so eins. Oder es ist aus anderen Gründen 
etwas vormagnetisiert worden und zum Ausschalten ist das Feld des 
Magneten immer noch zu groß.

von Ludger (ludger_m)


Lesenswert?

Hallo Klaus,

Hast Du mal mit einem Ohmmeter geprüft, ob das Verhalten vom Reed 
Kontakt kommt, oder vom Bremslicht ?

Ludger

von Klaus (cato)


Lesenswert?

Danke Teo,Ludger und Dietrich für eure Antworten.

Ich konnte den Effekt jetzt mal näher beleuchten. Rad stand über Nacht, 
nach Einschalten der Spannungsversorgung war das Licht aus, Relais 
schaltet sich also nicht von selbst ein sondern bleibt hängen, da das 
Licht nach einmaligem Betätigen vom Bremshebel nicht mehr ausging. 
Klopfen auf das Relais half nichts. Hab dann versucht mit einem Magneten 
das Relais wieder zum Ausschalten zu bewegen, ohne Erfolg. Dann fiel mir 
mein Entmagnetisierkästchen ein das ich vor kurzem gekauft habe. Damit 
konnte ich das Relais zum Abfallen bewegen. Hing dann aber gleich wieder 
nach Betätigen der Bremse. Mehrmals probiert, der Effekt scheint kleiner 
zu werden, konnte dann auch durch Klopfen das Relais zum Abfallen 
bewegen. Auf jeden Fall ist es so dass der Effekt bei normalem Gebrauch 
wohl kleiner wird, da beim Fahren keinerlei Schaltfehler auftreten. Nur 
wenn das Rad länger steht tritt der Effekt auf.
Werde das jetzt mal ein paar Tage beobachten, wenn der Effekt nicht 
weggeht bau ich den bestellten Reedschalter ein.

Grüße umnd danke, Klaus

von Kurt A. (hobbyst)


Lesenswert?

Magnetfeld zu stark. Denn ein Reedrelais hat eine Hysterse. Nimm ein 
schwächeres Magnet. Bei zu starkem Magnet werden die Schaltzungen des 
Reedrelais vom Magnetfeld vormagnetisiert. Dadurch wird das Reedrelais 
bistabil. Durch mehrmaliges betätigen des Bremshebels, werden die 
Schaltzungen wieder entmagnetisiert und es funktioniert wieder normal.

von Niklas G. (erlkoenig) Benutzerseite


Lesenswert?

Wie wäre es mit einem TI DRV5023 oder Infineon TLV4964, plus kleiner 
MOSFET?

: Bearbeitet durch User
Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail? Keine Anmeldung erforderlich!
Mit Google-Account einloggen
Noch kein Account? Hier anmelden.