mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Triac Ansteuerung


Autor: Joachim (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich wollte eine Phasenanschnittsteuerung bauen und bin dabei auf 
folgendes Problem gestoßen:

Wenn ich einen Triac direkt über den MC ansteuern will, so habe ich ja 
kein gemeinsames GND auf das sich die Gatespannung beziehen kann.
Die Schaltung im Anhang sollte das Problem veranschaulichen. Natürlich 
ist sie noch nicht vollständig verschalten, wie z.B die 
Controllerversorgung und die Verstärkerstufe vor dem Gate...

Autor: Peter-neu-ulm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achtung!
Hier ist der Kontroller über das Gate mit der Starkstromseite verbunden. 
Auf jeden Fall muss ein Optokoppler zwischen Starkstromseite (Triac) und 
Kleinspannungsseite (Kontroller) geschaltet werden.

Autor: Jürgen Berger (hicom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
schau dir mal das Datenblatt vom MOC3022 an.


Jürgen

Autor: Joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gib es solche Opto Triacs auch für höhere Ströme ?

Autor: Dirk Hofmann (arm-dran)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja man nennt sie IGBTs, Schau mal unter IGBT bei Wikipedia

Autor: Joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kenne IGBTs, jedoch sind diese soweit ich weis nicht optisch 
entkoppelt und nicht geeignet um Wechselstrom zu schalten.

Autor: Dirk Hofmann (arm-dran)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann schau mal Wiki. Warum optisch. reicht isoliert nicht aus ?

Autor: Joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich will ja damit sowohl die positive, als auch die negative Halbwelle 
anschneiden. Außerdem löst ein IGBT das Proiblem auch nicht, dass das 
Steuersignal vom MC eine anderes GND wie die Lastseite des Triacs hat.

Autor: Jürgen Berger (hicom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joachim wrote:
> Gib es solche Opto Triacs auch für höhere Ströme ?

?? der MOC3022 dient nur zur Ansteuerung des Lastttriacs,
wie gesagt siehe Datenblatt (Anwendungsbeispiele)

Jürgen

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joachim wrote:
> Gib es solche Opto Triacs auch für höhere Ströme ?

Dirk Hofmann wrote:
> Ja man nennt sie IGBTs, Schau mal unter IGBT bei Wikipedia

Was soll denn der Schwachsinn ?
Ein IGBT ist nichts anderes als ein Darlingtontransistor mit Mosfet als 
erster Transistor. Der ist nicht galvanisch getrennt und hat komplett 
andere Eigenschaften als ein Triac !

Autor: Peter-neu-ulm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zunächst mal, darf der Laststrom auf keinen Fall über den PE geführt 
werden!!!
Verbindung mit dem Starkstromnetz darf nur innerhalb schutzisolierter 
Geräte bestehen, so ist die Schaltung grob fahrlässig.
Bei Triacs muss man für einen Schaltungsvorschlag schon wissen, ob die 
Last induktiv oder Ohm'sch ist und um welchen Leistungsbereich es sich 
handelt. Sonst erzählt man sowieso nur Nebel.

Autor: cappelone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber sicher gibts sowas für höhere Ströme z.B. von Sharp S202S11F
kann 8A hat optokoppler eingebaut und kein ZeroCrossDetection ist also 
für Phasenanschnitt geeignet und im SIP4 Gehäuse

Autor: Joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bei Triacs muss man für einen Schaltungsvorschlag schon wissen, ob die
  Last induktiv oder Ohm'sch ist und um welchen Leistungsbereich es sich
  handelt.

Ich will damit ein Schaltnetzteil mit 12V Halogenlampen dimmen. Ich weis 
zwar nicht, wie groß die Induktivität in solchen Lampen ist, ich denke 
aber, man kann dabei von einer fast rein ohmschen Last ausgehen. Da der 
Zündimpuls sowieso maximal 100° verspätet gegeben wird und ich auch 
relativ lange Impulse nutze, werde ich hier wohl keine Probleme 
begekommen.


Der MOC3023 ( http://www.ortodoxism.ro/datasheets/QT/MOC3021.pdf )
schafft 3A. Diesen könnte man doch direkt an der Lastseite betreiben ? 
Bei meinem Schaltnetzteil mit 110W würden eh nur effektiv ca. 0,5 A 
fließen.

Autor: Christian Nöding (phoenix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltnetzteil dimmen? Wenn ich nicht falsch informiert bin, takten 
Schaltnetzteile eigene Leistungsschalter, um die Eingangsspannung zu 
reduzieren/erhöhen und schieben dann den Strom durch kleine Drosseln 
(Stichwort: Buck- und Boostkonverter). Wenn du dem Netzteil jetzt ne 
phasenangeschnittene Spannung lieferst, dürfte das Teil nicht mehr 
richtig funktionieren.
Sicher, dass es kein Trafo ist? Die meisten 12V Halogenlampensysteme 
haben nen kleinen Trafo. Allerdings haben die heutzutage auch schon 
meist eine Art Softstartfunktion, sodass das mit der Leistungsregelung 
auf der Primärseite auch nicht so doll ist.

Bau dir deine Anschnittssteuerung lieber auf die sekundäre Seite - ist 
sowieso sicherer, als mit 230V rumzuspielen :)

Autor: Jorge (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltnetzteile sind in dieser Hinsicht "unberechenbar". Angenommen dein 
Schaltnetzteil hat primär einen Brückengleichrichter und ein Siebelko, 
dann könntest du die Phase mikrokontollergesteuert am Schluss 
anschneiden und bis zum Nulldurchgang nutzen. Damit könnte man die 
zugeführte Eingangsspannung regeln. Ich nehme an dein Schaltnetzteil 
spielt ab einer gewissen Spannung nicht mehr mit oder fängt an zu 
flattern, auf jeden Fall ist das "Stress".

Für Halogenlampen gibt es Schaltnetzteile, die dimmbar sind. Entweder 
haben sie die Elektronik zum Dimmen mit drauf oder sie sind 
schaltungstechnisch für externes Dimmen geeignet.

Bei den Schaltnetzteilen für Halogenlampen hat es sich meiner Erfahrung 
nach immer gelohnt einen Fachhandel aufzusuchen. Die Geräte bieten oft 
wesentlich mehr fürs Geld. Beispielsweise bekommt man Extras wie 
Dimmbarkeit ohne Aufpreis. Die Module sind wesentlich kleiner und 
robuster. Der Gegensatz sind Baumärkte, obwohl es da sicher auch 
Ausnahmen gibt.

Aus meiner Sicht ist ein dimmbares Schaltnetzteil für deinen Fall die 
zuverlässigste Lösung.

Autor: Joachim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Halogenlampen sollen in Abhängigkeit von einem Sensorwert gedimmt 
werden. Habe mich leider vertan. Ich rede natürlich von einem el. Trafo, 
der für Phasenanschnittsteuerung geeignet ist.
Ich habe zurzeit eine Dimmung auf der 12 V Seite aufgebaut, allerdings 
funktioniert das nur mit einem konventionellen Trafo und nicht mit einem 
el. geregelten. Dummerweise habe ich es hier mit hohen Strömen zu tun, 
die mit meine Bauteile sehr warm werden lassen.

Was ich eben abschließend noch fragen wollte, ob ich mit dem
MOC3023 ( http://www.ortodoxism.ro/datasheets/QT/MOC3021.pdf ) direkt 
die Netzspannung anschneiden kann. Der schafft eben 3A und bei einem 
100W Trafo fließen maximal 0,5 A.


Autor: cappelone (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moc3023 kann nur einen Dauerstrom von ca 100..200mA Die 3A sind nur 
nicht wiederholend zulässig, also entweder optotriac zb Sharp S202T01F 
oder externen Triac und moc.

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe gerade mit Grauen das Schaltbild und das sagt mir, das du von 
Starkstrom keine Ahnung hast. Lass besser die Finger davon. PE ist die 
Schutzerde und hat IN einer Schaltung überhaupt nichts verloren. Das 
Gate kann man induktiv oder optisch ansteuern, wie hier auch schon 
Vorschläge gemacht wurden.

Autor: Bernd Ickert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Triac-Ansteueurung!!!!
Ich habe das Problem, dass R39 regelmäßig kaputt geht???? Es ist 
äußerlich nichts zu erkennen (nicht schwarz z.B.). Er hat dann statt 100 
Ohm unendlich Ohm, scheint also innerlich zu reißen. Angesteuert wird 
ein Motor in Steinmetzschaltung. Das Richtungsrelais zieht ca. 300ms 
vorher, bevor über den Optokoppler der Triac einschaltet. Am R39 habe 
ich im Moment des Einschaltens für ca. 200 NANO-Sekunden Impulse von 
teilweise bis zu 2500V. Könnte das die Ursache sein? Habe schon extra 
einen Widerstand lt. Datenblatt mit 750V Betriebsspannung benutzt. 
Offenbar noch zu wenig, oder anderer (Denk-) Fehler?
Gibt es denn Widertsände mit hoher Spannungsfestigkeit und trotzdem 
halbwegs kleiner Bauform?
In allen möglichen Beiträgen, Applikationen etc. wird NIE auf eine zu 
beachtende Spannungsfestigkeit des Widerstands hingewiesen.
Kann jemand helfen?
Danke, Bernd

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm lieber R40.

Autor: Bernd Ickert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tipp mir R40. Wo ist denn mein Schaltungsdetail (hier ist 
R39 eingezeichnet)?

Autor: Bernd Ickert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So nun noch einmal den Versuch, die Schaltung hochzuladen.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

wie hast du die Impulse gemessen. 200ns kann ich mir an der Stelle nicht 
erklären, schon garnicht bei 2,5 KV.

Die Spannungsfestigkeit eines Widerstandes ist für den Entwickler ganz 
sicher ein Kriterium. Er sollte wissen welche Spannung wo anliegt und 
entsprechend dimensionieren.


Was bedeutet bei dir regelmäßig. Alle paar Wochen, jeder 2te 
Schaltvorgang?

Ist die Last groß genug für den Haltestrom des Triacs?

Autor: gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd Ickert schrieb:
> Angesteuert wird
> ein Motor in Steinmetzschaltung.

Welche Leistung?


Bernd Ickert schrieb:
> Am R39 habe
> ich im Moment des Einschaltens für ca. 200 NANO-Sekunden Impulse von
> teilweise bis zu 2500V. Könnte das die Ursache sein?

Ironie an
Ne, bestimmt nicht... das wäre völlig abwägig!
Ironie aus


- gerd

Autor: gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernd Ickert schrieb:
> Gibt es denn Widertsände mit hoher Spannungsfestigkeit und trotzdem
> halbwegs kleiner Bauform?

Gibts:
http://de.farnell.com/jsp/search/browse.jsp?N=1000...

- gerd

Autor: Bernd Ickert (Firma: Ickert-Elektronik) (bernd2201)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die vielen Hinweise.
Hatte vergessen bei meiner Frage, ob es Hochspannungswiderstände gibt, 
hinzuzufügen: Bezahlbar. War schon bei farnell, na Danke. Gehe aber 
gleich noch mal dem Link von Gerd nach - Danke!

Habe die 200ns natürlich mit dem Osszi gemessen.
Es ist ein 750W Drehstrommotor, also eigentlich lächerlich.
Bei mir auf dem Labortisch fällt "natürlich" gar nichts aus, aber von 
den ca. 200 Geräten "draußen" gehen alle ca. 5-20 Tage mal einer kaputt, 
eben dieser Widerstand. Bin echt ratlos!

Messung mit Ossi: Betrieb des Gerätes mit Trenntrafo, GND Osszi an 
unteres Ende von R39 (siehe Schaltbild).

Autor: gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte mir vorstellen, dass dir eine Induktionsspannung im 
Ausschaltmoment den Widerstand durchhaut.

- gerd

Autor: Bernd Ickert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Könnte mir vorstellen, dass dir eine Induktionsspannung im
Ausschaltmoment den Widerstand durchhaut.

So was könnte es sein, allerdings treten diese Impulse NUR im 
Einschaltmoment auf.
Ich habe mal jetzt ganz mutig eine Überspannungsschutzdiode parallel zu 
R39 geschaltet (P6KE 6,8A). Das scheint der Funktion nicht zu stören.
Anbei mal 2 Osszillogramme, einmal vorher, einmal nachher (Ohne_, 
Mit_Diode). Deutliche Unterschiede.
Die Impulse sind mal negativ, mal positiv. Hier z.B. bei "Ohne_Diode" 
negativ und knapp 2000V groß (Messkopf 1:10).
Schade, dass niemand den absoluten "AHA-Effekt" hat. Das Problem ist 
nämlich, ich kann nicht ewig probieren, bis die nächsten Geräte 
ausfallen, dann wieder was neues probieren...

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

was da schwingt weiß ich auch nicht. Könnte es sein, das dein Scope den 
Teiler erkennt und richtig anzeigt? 200V gibt mit 100R 2A, könnte der 
Zündstrom sein.

Autor: Bernd Ickert (Firma: Ickert-Elektronik) (bernd2201)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist mir eigentlich auch alles klar, kenne auch das ohmsche Gesetz, hilft 
mir aber alles nicht wirklich weiter. An Fehler beim Messen habe ich 
auch schon gedacht, bleibt aber trotzdem die Frage, warum geht der 
Widerstand kaputt??? Die hohen Impulse (wenn der Osszi nicht lügt) wären 
wenigstens eine Erklärung. Muss es wohl nun mit den Dioden probieren.
Vielen Dank allen Anteilnehmern!

Autor: Egal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C20 mal kleiner versucht? Bei dessen Auf- und Entladung bei Zündung 
fließt ja auch einiges über den Widerstand.

Autor: Bernd Ickert (Firma: Ickert-Elektronik) (bernd2201)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Egal schrieb:
> C20 mal kleiner versucht? Bei dessen Auf- und Entladung bei Zündung
> fließt ja auch einiges über den Widerstand.

Sorry,sorry, sorry...
Es sind keine 2500V sondern nur 250V.
Zu meiner verteidigung: ich arbeite zwar schon länger als 10 jahre mit 
einem digitalen Speicherosszi, aber soooooo selten, dass ich mal hohe 
Spannungen messe. meistens interessieren mich nur 5V-Impulse und dann 
nur dessen zeiten (bin "Digitalelektroniker"). Der Osszi berücksichtigt 
bereits den teiler 1:10, d.h. wenn dort der Spannungsbereich 50V 
eingestellt ist, dann sind es auch 50V ( und nicht 500V, wie ich eben 
noch dachte).
Aber um so mehr ist immer noch die Frage: Widerstand kaputt???
Guter Tipp mit C20, probiere gleich mal...

Autor: Bernd Ickert (Firma: Ickert-Elektronik) (bernd2201)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt C20 von 100n auf 10n "verjüngt" und für R39 2 parallel 
genommen (also nur noch 50 Ohm). Funktioniert ebenso wunderbar und die 
Impulse sind WESENTLICH kleiner (20-50V max). Ich kann nur hoffen...

FRAGE an die, die sich damit auskennen:
Bei den bisherigen Steuerungen habe ich den Optokoppler MOC3021 benutzt. 
Der hat KEINE Zero-Cross-Schaltung. Für die nächste Serie habe ich schon 
den MOC3061 MIT Zero-Cross im Haus. Ist das besser? Könnte sich das 
vielleicht auch noch positiv auf die Lebensdauer des R39 auswirken?

Ist schon fast feierabend, sitzt noch jemand am Rechner? Aber morgen ist 
auch noch ein tag.
Einen schönen Abend noch allen!

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ZeroCross schaltet bei kleiner Spannung und sollte damit dein Problem 
lösen. Was mich aber noch interessieren würde: Warum überhaupt der 
Triac? K1 schalten "Zu". K4 schalten "Auf"

Autor: Bernd Ickert (Firma: Ickert-Elektronik) (bernd2201)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
karadur schrieb:
> Hallo
>
> ZeroCross schaltet bei kleiner Spannung und sollte damit dein Problem
> lösen. Was mich aber noch interessieren würde: Warum überhaupt der
> Triac? K1 schalten "Zu". K4 schalten "Auf"

Danke!
Der Triac schaltet leicht verzögert (ca. 300ms) nach den Relais bzw. 
beim Abschalten vor den Relais. Damit wollen wir 
Funkenbildung/Funken-Störungen/Kontaktbrand verhindern (funktioniert 
auch sehr gut).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.