mikrocontroller.net

Forum: Compiler & IDEs Eclipse und MSPGCC


Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Damit dieses Board mal wieder durch einen lächerlichen Beitrag 
bereichert wird:
Ich würde gerne mein AVR Repertoire durch MSP430 Kenntnisse ergänzen, 
bekomm es aber einfach nicht auf die Reihe Eclipse mit dem MSPGCC 
Compiler zum laufen zu bekommen. Ich installiere den Compiler(20070216) 
und entpacke das Eclipse SDK(3.3) zu meinen Programmen... Wie komme ich 
nun dazu, ein MSP Projekt starten zu können??? Brauch ich noch ein 
spezielles Plugin? Oder gibt es vielleicht Probleme im Zusammenhang mit 
WinAVR? CDT funktioniert übrigens! Hatte jemand schon das gleiche 
Problem? Ich hab schon allerhand probiert aber alles ohne Erfolg! Würde 
mich über konstruktive Ratschläge sehr freuen!

MfG Hans

Autor: Plugin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
PÜlugin

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und die "Anleitung" http://homepage.hispeed.ch/py430/mspgcc/
Naja, man muss es halt auf die aktuelle Eclipse Version umsetzen.
Achja, den msp430-gdbproxy kann man übrigens schick bei external Tools 
in Eclipse einbinden.

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun ja, da liegt wohl mein Problem, wo bekomm ich die aktuelle Version 
her?
Ich meine auch mal gelesen zu haben, dass das Plugin in der neuesten 
Eclipse Version bereits enthalten ist. Wenn dem so ist, umso komischer 
dass es nicht funktioniert...

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist da betimmt nicht enthalten. Es gibt auch kein aktuelleres PlugIn 
als diese 0.0.0.2 da. Klappt aber. Ist ja ganz einfach gestrickt.

Die aktuelle Eclipse + CDT 4.0 gibts doch jetzt im Paket bei Eclipse (ca 
70MB).

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok hätte mich auch leicht gewundert dass das Plugin schon enthalten wär. 
Aber trotzdem ich hab das Zeug da reingepackt und es tut einfach nicht. 
Egal was ich mach... Gibts da echt keine Tricks? Bestimmte Reihenfolge 
der Installation einhalten? Weil sonst versuch ich n anderes SDK. Ich 
hätte halt gern Eclipse verwendet.

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans, zähl mal die Teile auf, die du verwendest. Ich versuche das mal 
nachzustellen.

Das ist leider die Krankheit an OpenSource. Jeder stellt ein wenig zur 
Verfügung, zusammenbasteln muss es der User selber. Gibt es eigentlich 
eine Einschränkung, Eclipse und die Plugins in einem Paket zu 
vertreiben? Machen tut es bisher keiner. Stattdessen kursieren im 
Internet Dutzende unbrauchbarer Anleitungen (auch hier), die sich in der 
Summe aber ergänzen.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Es tut einfach nicht" Ist doch keine sinnvolle Aussage. Was geht denn 
nicht?

Wahrscheinlich muss ich mal eine Anleitung zusammenstellen.

Die Schritte sind:

1. Eclipse mit CDT runterladen und entpacken.
2. MSPGCC Toolchain runterladen und installieren (ALS ADMIN!!!)
3. MSPGCC Plugin runterladen und in den Eclipse Ordner entpacken.

4. Eclipe starten, einen Workbench auswählen.

5. Ein neues Projekt anlegen. Managed Make-Projekt, MSPGCC Executeable 
(ELF)

6. Projektoptionen (Properties) aufrufen. Alles einstellen, entwprechend 
der Anleitung von Chris Liechti.

7. Debug Umgebung erstellen. Ist fast genauso wie in der ANleitung, 
lediglich muss man den GDB-Server Debugger wählen. Connection auf 
TCP/IP, localhost, 3333

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 1. Eclipse mit CDT runterladen und entpacken.

Ich habe mal das gemacht, jedoch ist das 4.0 nicht dabei gewesen. Glaub, 
irgendeine 3.x Version war dabei. Das Paket war 62 MB groß + 37 MB für 
CDT.

5. Ein neues Projekt anlegen. Managed Make-Projekt, MSPGCC Executeable
(ELF)

Das konnte man nicht mehr auswählen. Aber immerhin sowas ähnliches. Das 
ging aber in der alten Version.

Hier heißt es "New C-Projekt" und dort mspgcc ELF (Gnu) auswählen.

Und diese Warnung hält sich hartnäckig:
Error launching external scanner info generator (gcc -E -P -v -dD 
Eclipse/new/.metadata/.plugins/org.eclipse.cdt.make.core/specs.c)

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo, der Scanner Info Generator is bissl komisch, hat aber nix mit mspgcc 
zu tun. Das geht nur mit dem richtigen gcc. Kann man ignorieren, oder 
eben ausschalten, dass der das automatisch macht.

Achso, du brauchst das aktuelle Eclipse Europa: Eclipse IDE for C/C++ 
Developers - Windows (62 MB)

ich bin gerade dabei eine bebilderte Anleitung zu machen.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooo...Anleitung in Bildern: http://supachris.homeip.net/Eclipse.rar

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> oder eben ausschalten, dass der das automatisch macht.

Wo kann man das ausschalten?

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Sooo...Anleitung in Bildern: http://supachris.homeip.net/Eclipse.rar

Ich habe den letzten Punkt auslagern müssen, da ich ein Hex-File zum 
Flashen benötige. Ich verwende mspfet dafür.

$ msp430-objcopy -O ihex ${project_name}.elf  ${project_name}.hex

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In das PostBuild kann man auch eine Batch Dateie reingeben. mache ich 
auch oft, weil ich noch die RAM-Auslastung direkt wissen will und auch 
ab und zu ein TI-txt File brauche.

Auf Bild 005 ist die Einstellung für den Scanner Info Generator.

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Auf Bild 005 ist die Einstellung für den Scanner Info Generator.

Sicher? Ich bekomme die Meldung immer noch. Wo ist übrigens diese 
Einstellung in 3.2 versteckt?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah, jetzt wo du´s sagst...es gibt glaub noch eine globale Einstellung 
irgendwo bei Windows->Preferences. Wo genau, weiß ich nimmer...musste 
dich ma durchklickern.

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt habe ich dort mal gesucht und habe die Option gefunden, die du 
meinst. Sie ist unter C/C++->Make->New Make Projekt Tab Discovery 
Options. Vermutlich wirkt diese aber nur auf neue Projekte. Mal testen.

Das netzt ist voll mit diesem Problem. Aber nur wenige Lösungen. Selbst 
vom Eclipse-Team scheint das niemanden zu interessieren. Tja, 
OpenSoucre. You get what you pay for. Service ist da leider nicht im 
Paket.

Ich werde vielleicht mal einen anderen Editor raussuchen, der nicht so 
sperrig ist.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, Problem ist das ja nun nicht wirklich. Ist halt eine Warnung, die 
man ignorieren kann.
Und die Einstellung wirkt auch, wenn man ein Clear macht.

Editor? Eclipse ist doch viel mehr als das.

Autor: Plugin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich werde die Warnung auch ignorieren. Ist nur schade, dass man sie 
nicht wegbekommt.

> Editor? Eclipse ist doch viel mehr als das.

Ja, schon. Aber eigentlich braucht man doch nur einen Editor. Ist aber 
schön, dass man mit Eclipse leicht Projekte erstellen kann und sich 
nicht um die lästige Makefileeditierung kümmern muss.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...und Debuggen geht auch ganz gut. Und SVN und und und....mittlerweile 
kann ich die Modulartität ganz gut verstehen...

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sooo da bin ich mal wieder, nach einer langen Pause hab ich mich wieder 
dran gemacht eclipse zum laufen zu bekommen...
Mein (neues) Problem ist, dass der Debug- Ordner der anscheinend 
automatisch erstellt werden sollte, nicht erscheint in dem Projekt- 
Directory...
Ich weis nicht weiter... vielleicht jemand von euch

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird er denn erstellt? Wie lang ist der Pfad vor dem Ordner? Leerzeichen 
oder sonstige komische Zeichen drin?

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Der Ordner wird nicht erstellt
2. der workspace Ordner befindet sich in Eigene Dateien, Pfadlänge 63 
Zeichen, Projektordner ist 5. Unterordner (falls es das ist was du 
wissen wolltest)
3. Leerzeichen sind drin, ja (macht das etwa was aus?)

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, leider macht das was aus. Wieso genau, weiß ich auch nicht. Mach mal 
den Workspace in einen Ordner ohne Leerzeichen und sonstigen Schrabbel. 
Auch im Projektnamen dürfen keine Leerzeichen enthalten sein.

Der Kompiler gibt dann aber Meldungen aus, vielleicht solltest du die 
mal lesen.

Erst wenn das elf File wirklich erstellt wurde kommt: "Build complete 
for project ..."

Wenn alles nix hilft, mal den internen Builder verwenden. Achja, hast du 
managed make projekt gemacht?

Autor: Nils (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Ich habe auch das Problem, das bei mir die Ordner Debug und Binaries 
nicht erstellt werden, wenn ich ein Projekt angelegt habe und ne *.c 
geschrieben habe. Das sollte doch eigentlich automatisch gehen, oder?
Ich habe auch keine langen Ordnernamen oder so was. Arbeitsverzeichnis 
ist c:\work und Eclipse ist in d:\Programme\eclipse\
Ich verwende Eclipse 3.3.1 und CDT 4.0.1 und habe eigentlich alles wie 
in der Anleitung, die hier steht, gemacht.
Aber bei mir kommt nur die Warnung Error launching external scanner info 
generator (gcc -E -P -v -dD
Eclipse/new/.metadata/.plugins/org.eclipse.cdt.make.core/specs.c)

und dann wars das und es wird garnichts erzeugt. In der Console steht 
sonst auch nichts was einem weiterhelfen würde
(nur:
**** Rebuild of configuration Debug for project Test ****

**** Internal Builder is used for build               ****
Nothing to build for Test)

Ich weiß nicht mehr weiter. Wäre nett wenn mir einer nen Tipp geben 
könnte.
Muss ich noch irgendwas zusätzlich installieren?
MSPGCC Toolchain und MSPGCC Plugin habe ich drauf.
Braucht man noch Cygwin oder irgendwas anderes???

Ach ja managed make projekt habe ich nicht genommen, das kann man ja in 
der neuen Version garnicht mehr auswählen, ich habe einfach C-Projekt 
ausgewählt wie in der Anleitung!

Bitte helft mir ich verzweifel jetzt schon seit 2 Tagen an dem Problem!
Schonmal vielen Dan für Antworten!
Gruss, Nils

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du deine C-Datei über die Eclipse-Oberfläche hinzugefügt?

Autor: Nils (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja hab ich!
Hab da selber eine erstellt und dann gespeichert und dann passierte 
nichts weiter. Also es wurden nicht die Ordner Debug und Binaries 
erstellt. Das sollte doch beim Speichern eigentlich automatisch gemacht 
werden, oder?
Ich habe jetzt an der rechten Seite im Fenster make ein Made Target 
namens all eingefügt und damit werden jetzt wenn ich drauf drücke die 
Ordner und Dateien erstellt. Keine Ahnung warum das so auf einmal geht. 
Hab nochmal alles neu installiert und danach konnte ich das so wie oben 
beschreiben machen. Hatte ich vorher auch mal probiert, da ging das noch 
nicht.
Ist das denn dann so richtig oder sollte das nicht beim Speichern 
eigentlich schon gehen?
Naja, jetzt bin ich schonmal was weiter und werde mich dann mal mit dem 
debuggen auseinander setzten.

Achja, kann mir mal jemand genau erklären, wo man diese Warung "Error 
launching.." abstellen kann? Ich finde nichts wo ich die mit wegbekommen 
würde. Aber das ist ja auch nicht so wichtig!

Autor: Christian R. (supachris)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also mit der neuen Eclipse ist das Build bei speichern standardmäßig 
aus, kann man bei den Build-Options im Projekt einstellen. Musst halt 
dann oben auf den kleinen Hammer drücken. Make würde ich nicht anfassen, 
macht Eclipse alles alleine, nicht, dass da was durcheinander kommt.

Die Warnung bekommst du weg, indem du  die Discovery Option ausmachst, 
siehe Bild.

Autor: Nils (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke! Das hat mir schon mal weitergeholfen!
Jetzt habe ich aber das nächste Problem!
Ich arbeite mit dem msp430x2013
Laut Liste sollte es den ja eigentlich geben. Aber irgendwie läuft das 
mit dem Debuggen nicht richtig. Dann kommt der Error "cannot represent 
maschine ´msp:200´"
Wenn ich den msp430x149 nehme bekomme ich keine Fehlermeldungen, aber 
dann läuft das debuggen ja nicht.
Ich nutze noch die mspgcc20060502, da ich gelesen habe das die neueren 
Versionen nicht sauber mit Eclipse laufen, oder hat schon jemand 
positive Erfahrungen mit den neueren Versionen gemacht?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Warnung bekommst du weg, indem du  die Discovery Option ausmachst,
>siehe Bild.

bei mir bleibt die warnung leider noch

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann ignorier sie.

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal eine andere Frage. Wenn ich im Debugging Modus den Jtag Adapter 
freigeben will, um die Pins, die das JTAG nutz, zu nutzen. Welche 
Einstellung muss ich dann wo machen. Ich habe den GDBproxy als external 
tool laufen.

Wär Klasse wenn mir da jemand helfen kann da ich weiss das, das in IAR 
funzt.

Mfg

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist bissl kniffelig. Du musst zuerst mal den Debugger im 
Verbose-Modus starten, kann man bei Eclipse einstellen. Dann stellt der 
dir dort, wo die Ausgabekonsole ist, unten im Debug-Fenster auch die 
Möglichkeit zur Eingabe von Kommandos an den Debugger zur Verfügung.
Da musst du dann folgendes eingeben:

monitor jtag release

Anleitung für die Spezial-Kommandos gibts hier: 
http://mspgcc.sourceforge.net/manual/c1531.html

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mmmh das klingt ja schon mal gut nur finde ich den Verbose Mode nicht. 
Weisst du wo man das findet?

mfg

Autor: Christian R. (supachris)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Na beim Debugger. Siehe Bild.

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe mal versucht das neue Eclipse zum laufen zu bekommen da 
ich immer noch mit 3.1 arbeite. Es gibt aber Probleme damit. Ich habe es 
genau nach deiner Anleitung gemacht nur kann er nicht in den DebugMode 
wecheln. Ich habe auch den ParallelAdapter und nicht den USB so wie du.
Na ja muss ich dann wohl ohne auskommen.

mfg

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm einfach den älteren MSPGCC, der vom Mai 2006 funktioniert, die 
neueren wollen irgendwie nicht mit Eclipse zusammen. Schon komisch.

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe jetzt den vom Mai06 installiert und immer noch das selbe 
Problem. Als Fehler erscheint>

"Exception occurred during launch

Reason:
Failed to set program arguments, environment or working directory"

Kann damit aber auch nicht viel anfangen.
Hoffe  ihr wisst mehr!

mfg
Stephan

Autor: Stephan Plaschke (steph0815)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So um den Thread hier mal abzuschließen:
Um die Fehlermeldung:
Error launching external scanner info generator (gcc -E -P -v -dD
Eclipse/new/.metadata/.plugins/org.eclipse.cdt.make.core/specs.c)
zu beheben muss man in die "properties/discovery options" gehen. Dort 
sollte unten rechts der Eintrag "Enable external info scanner generator" 
sein. Dort steht dann im Fenster "gcc", da wir hier aber ja den 
"msp430-gcc" verwenden ist dies auch einzutragen. Damit läuft das dann 
alles ohne Probleme.
Und der Fehler den ich hatte:
"Exception occurred during launch

Reason:
Failed to set program arguments, environment or working directory"

den bekommt man wenn man im Pfad ein Leerzeichen oder sonstiges 
Sonderzeichen verwendet. Da mein Directory unter "eigene Dokumente" lag, 
konnte er es nicht bearbeiten...


Greetz
Stephan

Autor: Tomasz N. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe Probleme beim Debuggen...
Mit Eclipse 3.1 tut allerdings alles, da ich auch die Debugger-Optionen 
konfigurieren kann.

Bei Eclipse 3.3.1 ist das allerdings nicht mehr moeglich.

was koennte ich nun tun. Welche Version ist das in der Anleitung 
Eclipse.rar gewesen?

Danke!
Tomasz N.

Autor: Tomasz N. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK - Ich habe den Fehler gefunden:
ich habe nicht den gdbserver Debugger ausgewaehlt, das habe ich 
uebersehen, da der mspgcc Debugger mit Eclipse 3.1 funktioniert hat.

Tomasz N.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.