mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 HighVoltage problem


Autor: christian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
moin

ich will meine versauten atmega8 u tiny2313 wieder reseten

VTARDET = gejumpert
RESET   = extern mit 12V (PORTE/AUX)nicht gejumpert
XTAL1   = gejumpert
OSCSEL  = 2,3 gejumpert ext. Quarz
BESEL pin1  =  zu PC2 verbunden
DATA  zu PORTB
CTRL  zu PORTD

ATMEGA8 hat auch 5V, RESET 12V

folgendes Problem auslesen geht aber VERIFY u. Program kommt siehe 
anhang diese meldung.
muss ich noch irgendwelche spannung anstöpseln oder so kann mir jemand 
weiter helfen???

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst Du bitte keine Word-Dokumente anhaengen sondern lesbare Formate? 
Danke.

Autor: christian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hoffe kannst es sehen

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast Du da jetzt gemacht? Screenshots speichert man a) als PNG und 
zweitens verzerrt man nicht das Seitenverhaeltnis, dass man nichts mehr 
lesen kann... oh Christian.

Autor: christian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich möchte meine chips für 4mhz ausstatten weil die in der schaltung 
programmiere über isp so nur habe ich mir bei meinen testboard die chips 
ein wenig verriegelt so das über isp nicht mehr ran komme da dacht i mir 
denn reste in HVS mit stk500 so nur irgendwie will das STK500 nicht wie 
ich es mir gedacht habe, habe alles so aufgebaut wie es im manuall steht 
u dann kommt immer diese meldung beim programmieren oder verify

Autor: Thilo M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für ein Netzteil benutzt du denn? Kann es sein dass die Spannung 
beim Programmieren zu stark einbricht?

Autor: christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mein selbstgebautes mit 2200µF am ausgang

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: christian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so jetzt prob. ich ganz

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
christian wrote:

> RESET   = extern mit 12V (PORTE/AUX)nicht gejumpert

Flasch.

STK500-Anleitungsheft, Seite 3-11:

``Mount jumpers VTARGET and RESET.''
                        ^^^^^^^^^

Wenn du dir die HV-Beschreibung im AVR-Datenblatt durchliest wirst
du feststellen, dass die +12 V dort nicht die ganze Zeit anliegen.

> OSCSEL  = 2,3 gejumpert ext. Quarz

Auch falsch.

``Mount jumper OSCSEL on pins 1 and 2 to select software-controlled
clock.''

Das Takten im HV-Modus erfolgt in einzelnen Taktimpulsen, nicht
als kontinuierlicher Rechteck.  Daher muss diese Impulse der
ATmega8535 liefern.

> BESEL pin1  =  zu PC2 verbunden

Hoffentlich nur beim ATmega8.  Der braucht außerdem noch die beiden
PJUMP-Jumper.

Autor: christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
png will irgenwie net na egal auf jedenfall sagt die soft. mir

A problem occured wehen executing the command. See the coomand output 
for more info.

tip: check taht the target voltage specified on the 'BOARD' page is 
within the required range for high-voltage programming, i.e. between 
4.5V and 5.5V. If this is does not help check your connenctions.

der letzte satz sagt aus schau ins troubleshooting aber ist leider auch 
nichts zu finden

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
christian wrote:

> png will irgenwie net

Wieso, das ist doch gut lesbar?

Autor: christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habs grade ausprobiert funktioniert ok beim programmieren nur RESET=5V 
aber beim schreiben von FUSEBITS auch 5V??? aber für was brauch man denn 
die 12V?? seite 3-17 steht auch im ich kann am header für ext RESET 
nutzen

Autor: christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na gut bei nen HVS aus dem netz waren die 12V unabdingbar war 
wahrscheinlich zu stark auf diese schiene fixiert auf jeden fall 
funktioniert das denn bleibt nur noch das der master im protokoll dies 
möglich macht

danke für die hilfe euch allen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.