mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Grafik-Display an AVR - Probleme


Autor: Adalbert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein Grafik-Display von Electronic-Assembly (EA DIP122-5NLW) an 
einem Atmel ATMEGA16 hängen und verzweifle bei der Ansteuerung:
Die Datenleitungen sind an Port C angeschlossen, A0, R/W, E1, E2 und RES 
habe ich an Pins von Port D angeschlossen. Kontrastspannung habe ich 
über einen ICL7660 mit -4V versorgt, man sieht auch einzelne Pixel.

Wenn ich das Datenblatt des SED1520 richtig verstehe, muß ich am 
Reset-Pin einen kurzen Puls erzeugen, um das Display entweder in den 
68-MPU oder 80-MPU Modus zu schalten - ich hab auch schon beide 
Varianten durch, beide gleich erfolglos.

Ich versuche vorerst nur, ein Streifenmuster auf das Display zu bringen 
- aber das einzige, was ich schaffe, ist ein kurzes Flackern, wenn ich 
das Reset-Signal ausgebe. Sonst tut sich gar nichts, es sind immer alle 
Punkte weiß.

Hat jemand eine Idee, was ich da falsch mache?

Vielen Dank!
Adalbert

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Der entsprechende Pegel muss ständig an RES anliegen. Ein Impuls reicht 
nicht.

MfG Spess

Autor: Adalbert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hatte ich eigentlich schon mal versucht, aber ich habs grad nochmals 
probiert - es ändert sich weder etwas, wenn ich den Reset-Pin fix auf 
GND hänge, noch wenn er an 5V hängt (über 4.7kOhm). Wenn er in der Luft 
hängt, dann benimmt es sich ein wenig komisch (die einzige Regung, die 
ich bis dato erzielen konnte ...), aber wenn er dran hängt (egal ob am 
Atmel oder an GND), dann ist die Anzeige ruhig (nur eben kein 
Streifenmuster).

Adalbert

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JTAG Interface in den Fuses disabled?

Autor: Adalbert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja! Jetzt! Das wars - herzlichen Dank!

Adalbert, der zwar hundert mal die Verkabelung ausgetestet und das 
Programm geändert hat, aber nicht einmal auf die Idee gekommen ist, ob 
der Atmel auch wirklich die Signale ausgibt, die da sein sollten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.