mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DCF77 Empfänger von Reichelt Frage


Autor: Christian Dresel (chris00)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hi

hab von reichelt den dcf77 Empfänger:
http://www.reichelt.de/?;ACTION=3;LA=4;GROUP=X2;GR...

Ich versteh das doch richtig das der PON Eingang mit GND des uC 
verbunden werden muss richtig? Weil ich einfach kein vernünfitges Signal 
herbekomme. Das Bauteil gibt so wie ich das mit den uC sehe nur 0V aus 
(Evtl. mal ganz kurze spitzen von 5V ist aber ohne Oszi schwer zu 
sagen.)

Ich häng einfach mal mein fertiges Programm an vllt. findet da auch wer 
nen Fehler.

mfg

Chris

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich frage mich warum soviele Leute Probleme mit DCF Empfängern haben. 
Mir sterben am laufenden Band die Conrad empfänger ab (oder sind bereits 
kaputt aus der nicht esd-gerechten Tüte gekommen)...

Der Reichelt empfänger funktionierte bei mir auch nie 100%... naja, wenn 
du ihn gut abblockst (wohl dimensioniertes RC Glied für die 
Spannungsversorgung) und weit von deiner Schaltung weg packst dann 
funktioniert er schon.

Ob PON mit GND verbunden ist oder nicht ist wurscht (würde ich aber 
trotzdem machen).

Autor: Christian Dresel (chris00)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

was verstehst du unter einen "wohl dimensioniertes RC Glied für die
Spannungsversorgung" würde das evtl. dann mal probieren und wenn das 
nicht klappt wo bekomm ich einen Empänger her der was taugt (nein ich 
hab keine alte Funkuhr rumfliegen) er darf ruhig größer sein als das 
reichelt ding aber er sollte halt funktionieren.

mfg

Chris

Autor: Alexander D. (alexander_d)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Christian,

mit dem DCF-Empfänger von Reichelt hatte ich auch Probleme. Bei mir war 
es so, dass das Signal mal sauber empfangen wurde und mal gar nicht.

Durch Zufall bin ich darauf gekommen, dass der Empfänger mit einer 
Versorgungsspannung von 5V nicht zuverlässig funktioniniert, mit einer 
geringeren dagegen einwandfrei. Also habe ich den Anschluss UB+ über 
eine 1N4148 an die 5V-Versorgung angeschlossen und UB+ mit 100nF gegen 
Masse abgeblockt. Mit der leicht reduzierten Spannung läuft der 
Empfänger ohne Probleme.

Im Datenblatt steht: "Der Empfänger ist eingeschaltet, wenn PON mit GND 
verbunden wird (Standard). Ist PON offen oder mit +Ub verbunden so ist 
der Empfänger aus (Bitte nachfragen!)." Also sicherheitshalber PON mit 
GND verbinden.

Gruß,
Alexander

Autor: Christian Dresel (chris00)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

hatte grad noch ne 5N4007 (wenn ich es richtig entziffern konnte) 
rumfliegen und nen 100nF Kerko und habs mal probiert Spannung war dann 
nur noch 4,57V also etwas tiefer aber danach hat der uC total gesponnen 
und sich ständig neu resetet (so alle 1-7sekunden). Als ich bei den 
ständigen resets die Zuleitung zum dcf77 Empfänger einfach abgeschnitten 
hab lief der uC sofort wieder perfekt. also liegt das wohl am Empfänger 
schrott halt schade

mfg

chris

Autor: AVRFan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für einen Test würde ich vom Ausgang des Moduls einfach nur eine rote 
LED über einen Transistor schalten lassen.  Als Stromversorgung zwei 
AA-Batterien (zusammen 3 V).  Wenn Du damit dann auf Wanderung gehst 
(Nähe TV, Nähe PC, Nähe µC, tagsüber, nachts etc.) und schaust, wann die 
LED sauber im Sekundentakt vor sich hin blitzt bzw. wann Störungen 
auftreten, weißt Du, welche Bedingungen das Modul für einen 
zuverlässigen Empfang benötigt (bzw. ob es überhaupt funktionstüchtig 
ist).

So würd ich den Fall angehen. Viel Erfolg :-)

Autor: Christian Dresel (chris00)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

nachdem ich nun stundenlang heut an den programm saß und nix ging brauch 
ich erstmal wieder nen tag meine ruhe und werd es frühestens morgen ehr 
aber erst Donenrstag wieder probieren ;)

aber danke für den Tipp werd das mal probieren

mfg

chris

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich mir das Modul demnächst auch zulegen wollte, würde ich doch gerne 
mal wissen, wie man das Teil abblocken soll.

Außerdem würden mich eure Einschätzung bezüglich gemultiplexter 
LED-Matrix in der Nähe des Empfängers interessieren.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

kann AVRFan nur zustimmen...

Transistor mit LED habe ich generell dran (wenn ein Auskoppeltransistor 
auf dem Modul ist, reicht eine LED mit 1k Vorwiderstand gegen +Ub).

Sicherstellen, daß stabiler Empfang möglich ist, Empfänger erstmal über 
1-2m Zuleitung anschließen, ich nehme da gern 2-adrig geschirmt, Schirm 
als GND, eine Ader +Ub, eine Signal.

Betriebsspannung zum Modul über Widerstand (ca. 470 Ohm) und Kondensator 
(ca. 10µ) direkt am Modul entkoppeln (LED vor dem Widerstand 
anschließen).

Die Dinger sind recht empfindliche 77,5kHz Empfänger, die durch alles 
mögliche zu stören sind!

An der LED sieht man sehr gut, ob der Empfang stabil ist, 1s-Impulse, 
keine fehlenden Impulse (außer dem 59.), keine zusätzlichen Impulse usw.

Sonst sind Experimente mit der Software nur stochern im Nebel...

Gruß aus Berlin
Michael

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Muß mal auch meinen Senf dazugeben, obwohl ich nichts zu dem Reichelt 
DCF-Modul sagen kann, sondern zu dem vom Conrad.

Ich habe damit 5 Uhren gebaut, Empfänger in einem Kunststoffgehäuse, 2 
Seiten hatte Alubleche.

Die Dinger funktionieren tadellos, außer der Fernseher unter der Uhr 
oder im Zimmer nebenan (Trockenbauwand) ist an. Dann sind's nur noch 
Empfangsfehler (LED blitzt wie blöd) oder irgendwann empfängt er gar nix 
mehr.

Eine von meinen Uhren ist sogar bei einem Bekannten auf Ibiza und selbst 
dort funktioniert das Modul astrein. Also denke ich mal, so schlecht 
kann das Teil nicht sein.

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter: ich mach hier irgendwas falsch. Erst lief das Modul ja auch super 
(Spannungsversorgung von 5 Volt Regler über eine überdimensionierte 
100µH Spule und einen 47µF Kondensator).

Irgendwann hab ich die Schaltung mal mit einem anderen Netzteil in 
Betrieb genommen (höhere Eingangsspannung für den 5 Volt Regler von ~9 
Volt) und dann ist mir das Modul gestorben (weiss nicht ob es deswegen 
passiert ist).

Nun hab ich mir noch eins bei conrad gekauft (im Laden) und das teil 
ohne LC angeschlossen - da schwingt gar nix, am quarz lässt sich kein 
schwingen nachmessen. Die 5 Volt stehen am eingang. An der Zenerdiode 
sind irgendwas um 4,3 Volt. Die Conrad module sind ja eigentlich auf 
eine weite spannungsversorgung ausgelegt, kann mir kaum vorstellen, dass 
ich das Modul durch irgendwelche Sauereien an der Spannungsversorgung 
zerschossen habe.

Autor: Dennis U. (atmegadennis)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe ebenfalls den Empfänger vom reichelt zich male verbaut und kann 
auch nur postives berichten.

Ich kontrolliere das Empfangssignal und wenn das was ich empfange 
schrott ist, zähle ich intern weiter.

die Module sind teilweise direkt auf der Platine.

Gruß

Dennis

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mich würde speziell der Punkt interessieren, wer von euch 
Multiplex-Anzeigen benutzt und wer nicht ;)

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als das Conrad modul noch lief hatte ich eine Multiplexanzeige und einen 
Schaltregler auf meiner Platine. Direkt auf die Platine montiert lief es 
nicht... erst als ich den Schaltregler ausgeschaltet habe.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
>da schwingt gar nix, am quarz lässt sich kein schwingen nachmessen.
Der schwingt auch nicht(jedenfalls nicht messbar), er filtert nur und 
das Signal ist auch in der 1mV-Stellung mit Oszi nicht messbar.
Das grösste Übel sind aber diese verkrüppelten Antennen, wenn da das 
Signal bischen schwach ist kommt nur noch Mist raus. Die Güte des 
Antennenschwinkreises ist durch schlechte C's auch nicht gerade sehr 
hoch und die Bandbreite steigt unnötig an.(und damit auch die Störungen)
Was deutlich geholfen hat, ist Ferritstab aus altem Radio mit 
Mittelwellenspule und guten C's auf 77,5KHz trimmen und statt dem 
Krüppel anklemmen.

Viel Erfolg, Uwe

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An den Empfängern ist eigentlich nix auszusetzen. Sie sind sehr 
empfindlich gegen Störungen und oft wird übersehen, wie sie zu 
beschalten sind.
Der einfachste Test wurde schon erwähnt: Batterie und LED dran und 
irgendwo hingelegt. Die Bewegung selbst kann schon zu Störungen führen. 
Dabei Abstand zu Bildschirmen und Multiplexanzeigen halten. Gib der 
Antenne ca. 30 Sek. zum Einschwingen, dann müssen die Impulse klar und 
ohne Flackern zu sehen sein. Sonst Standort wechseln und Vorgang 
wiederholen. Bei mir hat der Empfänger 3m Abstand zu meiner AVR-DCF77 
Uhr.

Autor: Wolfgang-G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kleiner Hinweis: von der Ansicht ähnelt sich der Reichelt-Empfänger dem 
im Funkwecker ERC130D von MEBUS eingebautem Empfangsteil. Der gesamte 
Wecker kostete vor wenigen Tagen nur 5 € bei real, statt 13 € (nur 
Empfangsteil) bei Reichelt.
Da stellt sich natürlich die Frage, warum nicht gleich einen Wecker 
kaufen –fertig!
Die Antwort: Jeder Elektronikbastler muss einmal eine Quarz- bzw Funkuhr 
gebaut haben. Meine Uhr läuft nun schon ca 30 Jahre mit einem 
Geradeausempfänger in diskreter Bauweise und wurde in gewissen Abständen 
immer mal umgebaut. Zuletzt auf „LED Großsichtanzeige“, um die Anzeige 
meinen Sehverhältnissen anzupassen.
Nun will ich versuchen, dem kleinen Funkwecker an Stelle der kleinen 
Flüssigkristall-Anzeige eine „LED Großsichtanzeige“ zu verpassen. Damit 
bin ich dann vermutlich wieder auf dem neuesten Stand.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.