mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AD-Wandler rauscht


Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir ein Controllerboard gebastelt, mit dem ich die 
Ausgangssignale einiger Sensoren messen möchte (Druck, Beschleunigung, 
...). Der AD-Wandler auf dem Board ist ein 5-kanaliger MAX1202 mit 12 
Bit. Mein Problem ist nun folgendes:

Die Messwerte des Beschleunigungssensors rauschen um etwa 60mV 
(entspricht etwa 60/1000 g, ist schon nicht unerheblich). Schließe ich 
allerdings den Drucksensor an den selben(!) Eingang an ist das Ergebnis 
einwandfrei, ein minimales Rauschen von 1mV (super!). Es scheint also 
nicht am Boarddesign zu liegen. Irgendwas merkwürdiges passiert, wenn 
ich den Beschleunigungssensor anklemme, ich weiß nur nicht was :-/!

Hat vielleicht hier jemand eine Ahnung woran es liegen könnte bzw. 
welches Phänomen dazu führen könnte, dass die Messwerte bei dem einen 
Sensor rauschen und bei dem anderen nicht??? Ich wäre für jede Hilfe 
dankbar!


Viele Grüße
Thorsten

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du es schon mit einem Tiefpass versucht?
Ist der Beschleunigungssensor einer aus der ADXL-Reihe?

Schöne Grüße,
Alex

Autor: THM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hat sich denn da für ein 'Herman' eingeschlichen?
Der müllt hier alles mit SPAM zu!


BITTE SPERRT DEN !!!


@ Thorsten:
Mache einen anti-aliasing-Filter vor den Eingang (wie oben geschrieben: 
Tiefpass), z.B den MAX275. Oder aus OPs (für diese Aufgabe nur gute wie 
den AD712 oder OPA2604 nehmen) diskret aufbauen.
Vielleicht hast du auch ein Masseproblem am Sensor (Brummschleife?). 
Miss doch mal mit dem Oszi mit Tastkopf und Potentialtrennung.

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast mal versucht den sensor mit deinem DVM aus zu messen? also macht 
der Sensor ohne angeschlossenen AD auch das Rauschen?

Vielleicht erzeugt der Drucksensor ein Gegenrauschen, welches das 
Rauschen des AD-Wandlers aufhebt... ;-)

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antworten, die Tipps waren sehr hilfreich :)! Mit 
dem Oszi ließ sich tatsächlich ein Schwingen des Signals um bis zu 100mV 
feststellen -> Also nen TP davor und weg ist es! Klappt jetzt wunderbar, 
das Signal ist so gut wie rauschfrei!

Thx und viele Grüße
Thorsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.