mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit L298


Autor: Thomas Kronschläger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo !

Da der Motorcontroller L298 vor kurzem in diesem Forum in
Diskussion war, möchte ich eine Frage dazu anbringen.

Ich habe die Schaltung, die auf dem Datenblatt (S.6) unter
"bidirectional DC Motor Control" (H - Brücke) aufscheint,
versuchsweise aufgebaut, worauf sie auch funktioniert hat.
Mein einziges Problem dabei ist, dass Motorspannung ein-
bricht, sobald der Motor unter Belastung steht und höheren
Strom ziehen möchte. Die Spannung fällt dabei an jenem
Transistor, der auf Masse durchschaltet, fast zur Gänze ab.

Momentan kann ich daher den angesteuerten Motor nur im Leerlauf
betreiben, was die Schaltung relativ sinnlos macht.

Das einzige, was an meiner Schaltung anders ist als an der
im Datenblatt, sind die verwendeten Dioden. Ich benütze zum
Probeaufbau keine "fast recovery diodes", sondern nur gewöhnliche
Dioden vom Typ 1N4007. Jedoch dürfte dies meiner Meinung nach
nicht den Fehler, der bei meiner Schaltung auftritt, verursachen.
Weiters verwende ich für die Logikteil der Schaltung und für den
Leistungsteil die selbe Masse, was aber meines Erachtens richtig ist.

Ich wäre dankbar, wenn mir jemand einen Tipp geben könnte, wo
ich am besten nach dem Fehler suche !

Datenblatt im Anhang !

Mfg, Thomas

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja, wichtiger als das Datenblatt wäre deine Schaltung.
Wahrscheinlich  hast du zuwenig Versorgungsspannung (bei Vollast fallen
je ca. 3V am unteren und am oberen Transistor ab, bei 9V
Betriebsspannung hast du schlechte Karten)

Autor: Thomas Kronschläger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Schaltung exakt nach der Schaltung auf Seite 6
im Datenblatt nachgebaut.
Die Betriebsspannung habe ich schon variiert, bin aber nie
wirklich über 12 V hinaus. Es stimmt schon, dass bei Vollast
einiges an den Transistoren abfällt, nur kann ich einen 9V
Motor nicht mit beispielsweise 15V im Leerlauf betreiben, damit
er bei Vollast noch seine 9V hat. Es müsste trotz allem ein dem-
entsprechender Strom fließen, wenn an den Transistoren mehr
Spannung abfällt. Der Strom kommt aber nie über 50-100 mA hinaus,
wo doch der L298 2 Ampere treiben könnte.

Trotzdem danke für den Tipp !

Autor: thkaiser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hast Du Pin 15 (Current Sensing, Pin 1 für die andere Hälfte des
L298) beschaltet? Hast Du einen Widerstand gegen Masse oder eine
direkte Brücke?

Autor: Thomas Kronschläger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen Widerstand (47 Ohm, 2 Watt) gegen Masse geschaltet,
an dem ich dann mittels meines µC den Strom über den A/D Wandler
messen kann.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Strombegrenzung scheint ja gut zu funktionieren.

Nimm doch 'mal einen Widerstand 0,47 Ohm. Dann bekommst Du auch einen
'brauchbaren' Motorstrom.

Autor: thkaiser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jep, also bei 47 Ohm wundert mich auch nichts mehr. Genau da geht Deine
Motorspannung verschütt'. Mess mal nach, wirst sehen, daß die Spannung
nicht am L298, sondern an diesem Widerstand abfällt.

Autor: Thomas Kronschläger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab grad den Widerstand durch eine Drahtbrücke ersetzt und die
Sache hat auf Anhieb funktioniert !
Ich hab wohl 0R47 mit 47R verwechselt !

Tausend Dank, Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.