mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Timerbaustein 555 im Auto


Autor: Nookie Nook (nook)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich hab mir eine PWM mit einem SA555 Timerbaustein gebaut (gleich wie 
NE555 bloß größerer Temperaturbereich).

Nun ist das Problem beim Lampemdimmen im Auto das alles super 
funktioniert solange der Motor aus ist. Sobald der Motor an ist spinnt 
sporadisch der Dimmer. Ich vermute die Zündanlage oder die Lichtmaschine 
des Autos.

Wie könnte ich das Problem lösen???

gruß Nook

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es denn wenn du den Schaltplan mal posten würdest.

Gruss Helmi

Autor: Roland T. (rolandt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute, dass Dein NE555 nicht ausreichend gegegen Störungen bzw. 
Spannungsschwankungen auf der Spannungsversorgung geschützt ist.

Mache mal einen Kondensator an den Spannungseingang der Schaltung (220µF 
sollte reichen).

Dann schaue darauf, dass Du alle Pins mit den richtigen Widerstanswerten 
beschaltet hast. Bei zu hohen Widerständen, gerade bei Spannungsteilern 
können Störsignale von außen einkoppeln, da das Potential zwischen den 
Widerständen durch den geringen Stromfluß nicht so stabil ist.

Blockkondensator (100nF) direkt an den Spannungsversorgungseingängen 
nicht vergessen.

Was auch immer nicht schlecht ist, ist ein Spannungsregler für die 
Schaltung einzusetzen.

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Standard - 555 funktioniert grundsätzlich nur auf dem "Basteltisch" 
so, wie er es soll. Speziell im KFZ funktioniert er ohne grösseren 
Aufwand fast nie richtig.

Gruss Otto

Autor: Nookie Nook (nook)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Roland T.

ich hab 410K und 130K Ohm widerstände bei einem 10nF kondensator. Ich 
habe auch von PIN 5 zu GND 10nf. Ich versuch mal heute vordem ganzen nen 
C zu verbauen.

so is tdie schaltung bis auf poti und diode 
http://www.i-trixx.com/de/ezine/img/061004_08.jpg

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch die 2 Abblockkondensator C2 und C3 verbaut? Auch ganz nah 
an den (Versorgungs-)Pins?

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kenne jetzt die Ausgangsstufe vom 555 nicht, aber vielleicht holt 
sich auch der bs170 irgendwo zufällilg Unfug ans Gate.
Das vielleicht mal mit 10k oder so nach gnd legen?

Autor: Christian J. (elektroniker1968)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

als alter Automotive-Entwickler eines Lima Bauers sage ich Dir: Ohne ein 
Filternetzwerk funktioniert im Auto gar nischt gescheit ausser den 
Relais. Setz ein LCR Filter davor und es wird funtionieren. Widerstände 
> 100k sind verboten im Auto und Hochohmige Pins sowieso immer schön 
abschliessen.

Christian

Autor: C. Schirp (cees)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Nook,

guck Dir mal die Seiten an:

http://www.atx-netzteil.de/pwm_mit_tl494.htm (Grundlagen)

http://www.schirp.eu/sitzheizung (Statt Sitzheizung lässt sich auch eine 
Lampe bis ca. 50W ohne Änderungen anschließen)

Mit nem TL494 lässt sich eine auch im Auto robust laufende Dimmung bauen 
- wennn man die Blockkondensatoren nah am IC positioniert, die 
Verpolschutzdiode nicht vergisst,.... siehe Christians Posting.

Gruß,
Christian

Autor: Nookie Nook (nook)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab beim C2 10nF und den C3 hab ich nicht.
ich werd heute mal nen C3 anschließen mit 100uF.

Wenn das nicht klappt schau ich mal wegen den hohen widerständen. ich 
hab das alles per SMD aufegbaut und daher nicht hab nicht gerade alle 
bauteile da.

die letzte hoffnnung wird dann noch alufolie zum schirmen sein.


der Tl494 ist aber auch interessant.
was meinst du mit Verpolschutzdiode???

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
den C3 solltest du bei 100nF belassen und noch einen Kondensator (C4) 
mit 220µF(abhängig von der Last) parallel zum C3 anschließen.

Autor: Tilo L. (katagia)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe vor einigen Jahren den Tip bekommen, für primitive
Schaltungen einen billigen uC, z.B. einen ATTinyXX, zu verwenden.
Der kam nachher in Summe deutlich billiger und ist weniger Störanfällig.
Betrieben wird das IC hinter einem 5V Linearregler und tut seit ca.
3Jahren seinen Dienst.

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pack noch eine Induktivität /Entstördrossel in Reihe zur +UB, noch vor 
die Kondensatoren. Irgendwo in der Bastelkiste oder auf einer alten 
Leiterkarte wirst du bestimmt was passendes finden. So Teile mit Kern 
und vielleicht 20-100 Windungen. Ab 50 uH aufwärts.

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Kleiner Tip. Wenn du ein altes Autoradio rumliegen hast: Das (meist) 
schwarze Plastikteil an der Rückseite (mit den Steckverbindern und der 
Sicherung) enthält enthält einen wirksamen Stör- und 
Überspannungsschutz.

MfG Spess

Autor: C. Schirp (cees)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Nookie,

in die Versorgungsleitung solltest Du noch eine Diode (z.B. 1N4007) 
zwischen Bordnetz und Deiner Schaltung einbauen, ansonsten puffert der 
kleine C3 nicht nur Deine Schaltung, sondern auch das Bordnetz - und das 
ist natürlich vergebliche Liebesmüh. Abgesehen davon, dass Dich die 
Diode vor "alles neu machen" bewahrt, wenn Du die Schaltung verpolst. 
Soll nicht überheblich sein, sondern ist in Auto-Steuergeräten auch so.

Elektronik im Auto ist allgemein ein nicht ganz so triviales Thema, wie 
Du an den Kommentaren merkst. Wenn Du mal ein schlechtes Gefühl haben 
willst... hier gibt es einen kleinen Eindruck davon, was eine 
professionelle Schaltung elektrisch im Auto aushalten muss:

http://www.ifr.ing.tu-bs.de/lehre/downloads/skript...

Klingt alles übertrieben, aber glaub mir: ist es nicht. Wenn Du z.B. mal 
Starthilfe gibst oder bekommst, dann siehst Du schon einen Teil der 
fiesen Störpulse in Deinem Auto...


Gruß,
Christian

Autor: Nookie Nook (nook)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich versuch mal eure tipps.
danke erstmal.

ich hab mir was mit nem Atemga8 gebaut das läuft auch noch bis heute 
ohne störung. ich dachte beim Ne555 sei das genauso hmm.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.