mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR soll Pumpe Steuern Relais geht an und aus?


Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo :)

Ich habe ein Steuerung gebaut die eine Pumpe beim erreichen eines 
bestimmten Wasserpegel für ca. 90 Sekunden aktiviert.

Das Problem ist das es funktioniert hat als ich es mit einer normalen 
Glühlampe als Last getestet hab.

Hab ich aber die Pumpe als Last an der Schaltung, dann zieht das Relais 
an für eine Sekunde und lässt wieder los...

Ich häng mal die Schaltungspläne mit dran. Vielleicht sieht jemand einen 
Fehler denn ich nicht sehe.

MfG Andy

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und das Layout

Autor: GAST (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hört sich nach nem Reset deines Controllers an.
Das kann beim Schalten von induktiven Lasten passieren.
Ich denke ein Snubber bzw. andere Entstörmaßnahmen könnten helfen!

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jop...du hast den Gleichrichter falsch angeschlossen.
Du musst wie Wechselspannung an ~ und ~ , dann erhälst du zwische + und 
- eine pulsierende Gleichspannung. du hasts an ~ und -  angeschlossen.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>Dateianhang: schema.jpg (67,2 KB, 0 Downloads)

Bildformate, PNG ist das Mittel der Wahl.

>Das Problem ist das es funktioniert hat als ich es mit einer normalen
>Glühlampe als Last getestet hab.

Wirklich? Dein Gleichrichter ist falsch angeklemmt.
Und bist du eine wenig wahnsinnig? Die Isolationsabstände zwischen 230V 
und der Sekundärseite sind viel zu klein. Ein Massepolygon hat dort 
nichts zu suchen!

An den Relasikontakten fehlt ein Snubber. Siehe auch [[Relais mit 
Logik ansteuern]].

MFG
Falk

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry ja zum dem gleichrichter... der ist nur im schaltplan falsch :) 
den ich verwende habe ich nicht als bauteil gefunden... also daran 
liegts nicht... sonst würde ja garnix gehen...

OK... also die Massefläche weglassen? und dieses RC-Glied parallel zum 
Relais sollte helfen?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>liegts nicht... sonst würde ja garnix gehen...

Bist du dir da sicher? Schau dir mal die Spannung mit dem Oszi an. Aber 
pass auf die 230V auf!

>OK... also die Massefläche weglassen?

Auf jeden Fall.

> und dieses RC-Glied parallel zum Relais sollte helfen?

Ja.

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja bin mir ziemlich sicher.. ich hab das wirklich mit absicht gemacht :)

ich werd es nochmal neu machen und wenn ich es fertig hab stell ichs 
hier nochmal rein.

danke erstmal für die schnelle hilfe :)

ps: hab leider kein oszi :(

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H.:

Du solltest mit Rect oder Polygon  auf Layer 41 oder 42
Flächen zeichnen, die dann nicht mit den Layern 1 oder 16
ausgelegt werden.

So ist die Platine ja lebensgefährlich und vor allen Dingen
in der Verbindung mit Wasser (wovon Du etwas erzählt hast)
Ausserdem fehlt auch eine Sicherung auf der Platine.

Gruß Sven

Autor: rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi ich würde aber hinter den 7805 noch einen Elko setzen und eine Diode 
über den 7805. Damit hat der µC noch ein bischen mehr reserve, wenn es 
einen Spannungsausfall durch die Induktion gibt.

Rene

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ rene (Gast)

>Hi ich würde aber hinter den 7805 noch einen Elko setzen

Kann man machen, ist aber nicht zwingend.

> und eine Diode über den 7805.

Wozu? Der Eingang kann nie kurzgeschlossen werden.

> Damit hat der µC noch ein bischen mehr reserve, wenn es
>einen Spannungsausfall durch die Induktion gibt.

????
Welche Induktion? Warum soll da Spannungsbafall entstehen?

MFG
Falk

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich vermisse die 100n an der Betriebsspannung des AVR. Die gehören 
prinzipiell dicht am IC da hin.
Ich vermisse den 100n am Eingang des 7805.

AREF gehört prinzipiell nicht an Ubb, entweder frei, wenn keine 
AD-Wandler benutzt werden oder über 100n an GND (mache ich prinzipiell 
so, erhöht vermutlich auch die Störsicherheit).

Der Rest wurde ja schon gesagt. Ich würde den Trafo drehen, das Relais 
neben den Trafo, so daß die 230V-Seite rechts landet und ein sicherer 
Abstand zur Niederspannungsseite rechts machbar ist.

Gruß aus Berlin
Michael

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Michael U. (amiga)

>ich vermisse die 100n an der Betriebsspannung des AVR. Die gehören
>prinzipiell dicht am IC da hin.

C1.

>Ich vermisse den 100n am Eingang des 7805.

Der ist ein Legende, ist aber auch vorhanden. C2.

MFG
Falk

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H.

>sorry ja zum dem gleichrichter... der ist nur im schaltplan falsch :)
>den ich verwende habe ich nicht als bauteil gefunden... also daran
>liegts nicht... sonst würde ja garnix gehen...

Der Gleichrichter ist sowohl im Schaltplan sowie auch im Layout falsch
angeschlossen.

>OK... also die Massefläche weglassen? und dieses RC-Glied parallel zum
>Relais sollte helfen?

Die Massefläche nur weglassen wo 220V-Leitungen verlegt sind.
Ich würde das Board so designen das wie bei einem aufgeschlagenen Buch
auf der rechten Seite ein Hochvoltbereich und auf der linken Seite
der Niedervoltbereich entsteht.Zwischen diesen Bereichen VIEL Platz
lassen (Beim Trafo und Relais praktisch schon vorgegeben).
Trafo HV(Prim.) NV(sek.)
Relais HV(Kontakte) NV(spule)

Ich bin etwas iritiert über den Widerstand und dem Kondensator am Chip.
Der Reset des Controllers scheint mir auch noch nicht so richtig 
bedient.
Dieser ist ein Aktiv-Low Input.(Reset wenn Spg.kurz auf 0).
Ich vermute das der Kondensator mit dem einen Pin an den Reset des
Controllers angeschlossen werden muß damit ein anständiger Reset
erzeugt wird und der Prozessor kontrolliert startet.
So könnte ein aufgelegter Störimpuls von der Relaisspule ständig einen
Reset des Controllers auslösen.

Die Leitung die am Transistor nach außen vorbeigeht und vermutlich
von einen Schwimmerschalter bedient werden soll,sollte zum Schutz des
Chip mit einem Optokoppler versehen werden,ist aber nicht zwingend.

Ein Snubber bringt hier wahrscheinlich nichts.Wenn doch,fängt`s du dir 
Störungen über das Netz ein.Das halte ich aber für unwahrscheinlich.

Wenn du mit Eagle-light arbeitest kannst du deinen Schaltplan und 
Boardlayout im Dateianhang zum Download bereitstellen.
Dann kann ich dir eine Redesign erstellen,unverbindlich,aber wohl besser
zum lernen,welches du auch nutzen kannst,ganz egal.

Gruß Martin

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich bin mir bei der Demensionierung des RC-Gliedes nicht sicher...

unter Snubber steht ja 1 Ohm pro Volt und 0,1µF pro Ampere

Also wäre ein Widerstand von 230 Ohm(wie viel Watt?) und ein Kondensator 
von 0,3µF (400V Spannungsfestigkeit?) nötig?
bei ner Pumpenleistung von 500Watt.

Ich hab schonmal bei Reichelt geguckt aber ich weiß nicht was ich da 
genau nehmen soll.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so wie der C5 im Layout verlegt ist, kannst du den auch (fast) 
weglassen.

Wie wäre es mit einer sinnvollen Leiterbahnführung?

Stütz- und Blockkondensatoren schließt man nicht über Stichleitungen an, 
schon garnicht über lange..!

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>Also wäre ein Widerstand von 230 Ohm(wie viel Watt?)

0,5W reichen.

> und ein Kondensator von 0,3µF (400V Spannungsfestigkeit?)

Sollte auch reichen.

>Ich hab schonmal bei Reichelt geguckt aber ich weiß nicht was ich da
>genau nehmen soll.

WIMA

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@pcbfreak

Danke für dein Angebot :)

> Der Gleichrichter ist sowohl im Schaltplan sowie auch im Layout falsch
> angeschlossen.

ja das stimmt schon, aber die Belegung des von mir verwendeten 
Gleichrichters ist anders als die in den Plänen.
Das funktioniert wirklich :)

Habs aber schon geändert... ich hab einen gefunden der passen sollte.
Ich weiß das man das nich macht :(  sorry

> Ich bin etwas iritiert über den Widerstand und dem Kondensator am Chip.
> Der Reset des Controllers scheint mir auch noch nicht so richtig
> bedient.
> Dieser ist ein Aktiv-Low Input.(Reset wenn Spg.kurz auf 0).
> Ich vermute das der Kondensator mit dem einen Pin an den Reset des
> Controllers angeschlossen werden muß damit ein anständiger Reset
> erzeugt wird und der Prozessor kontrolliert startet.
> So könnte ein aufgelegter Störimpuls von der Relaisspule ständig einen
> Reset des Controllers auslösen.

Das komische ist aber das es mit einer Lampe funktioniert...
Wenn ich Kontakt schließe dann Leuchtet sie ca. 90sec
Relais arbeitet dann einwandfrei... nur nich wenn die Pumpe dranhängt.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Matthias Lipinsky (lippy)

>so wie der C5 im Layout verlegt ist, kannst du den auch (fast)
>weglassen.

Käse. Das ist der grosse Elko zum Glätten nach dem Gleichrichter.

>Wie wäre es mit einer sinnvollen Leiterbahnführung?

Das haben schon hundert Leute vor dir bemängelt.

>Stütz- und Blockkondensatoren schließt man nicht über Stichleitungen an,
>schon garnicht über lange..!

Das spielt bei C5 keine Rolle. Dort gehts nur um 50/100Hz. Da könnte man 
selbst 10m Kabel dazwischenschalten ohne dass die Funktion 
beeinträchtigt wird.

MFG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>Das komische ist aber das es mit einer Lampe funktioniert...
>Wenn ich Kontakt schließe dann Leuchtet sie ca. 90sec
>Relais arbeitet dann einwandfrei... nur nich wenn die Pumpe dranhängt.

JA eben! Weil die Lampe harmlos ein und ausschaltet, die Pumpe bei 
schalten aber safige Spannungsspitzen erzeugt, die dank fehlendem 
Snubber und miesem layout wunderbar in deinen uC reinhauen. Ach ja, 
100nF von Reset nach Masse sind hier auch nicht verkehrt.

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Falk

Ok. Ich werd mich heut Abend nochmal ans Layout setzen.
Muss erstmal bissel raus bei dem Wetter :)

Ich bin halt noch am lernen... Aber finde das Forum echt toll.

Danke und schönen Sonntag noch

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

>Das komische ist aber das es mit einer Lampe funktioniert...
>Wenn ich Kontakt schließe dann Leuchtet sie ca. 90sec
>Relais arbeitet dann einwandfrei... nur nich wenn die Pumpe dranhängt.


>JA eben! Weil die Lampe harmlos ein und ausschaltet, die Pumpe bei
>schalten aber safige Spannungsspitzen erzeugt, die dank fehlendem
>Snubber und miesem layout wunderbar in deinen uC reinhauen. Ach ja,
>100nF von Reset nach Masse sind hier auch nicht verkehrt.

Eine Lampe wirkt wie eine ohmsche Last.
Ein Motor hat dagegen eine induktive-ohmsche Last.
Beim Einschalten produziert der Motor (auch auch die Lampe) erstmal 
einen hohen Anlaufstrom oder Einschaltstrom,bedingt(nur Motor)durch die 
Massen der bewegten Teile.Beim Abschalten produziert die Wicklung eine 
Gegenspannung auch EMK genannt und irgend wo hin muß.Im Normalfall 
dorthin zurück woher die Antriebsenergie stammt.Bei der Lampe gibt`s 
keine EMK,daher auch keine Störimpulse.
Bei Wechselstrom ist der Effekt gering,bei Gleichstrom dagegen stärker 
(=Motor wird zum Generator).
Dabei entsteht beim Abschalten am Kontakt gewöhnlich ein Lichtbogen der
den Störimpuls erzeugt.Außerdem prellen Kontakte manchmal ein wenig.
Der Snubber soll diesen Störquelle dämpfen.
270 Ohm 1Watt, 470nF/400V müßten hinkommen.

Ich würde aber mal R1 im Versuch überbrücken,nachdem der Prozessor 
läuft.
Wenn die Störung immer noch auftritt ist es definitiv nicht der Reset
sondern irgendwo  ist noch ein offener Eingang am Chip oder
du mußt einen Entstörfilter vor den Trafo schalten.

Gruß Martin

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mal den Snubber so eingezeichnet wie ichs verstanden hab. Ist es 
denn so richtig? Ich hab mal die Reichelt Artikelnummer mit dazu 
geschrieben.

Den 100nF von Reset nach Masse hab ich auch reingemacht.

Dieses mal als PNG ;)

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Falk Brunner wrote:
> @ Michael U. (amiga)
>
>>ich vermisse die 100n an der Betriebsspannung des AVR. Die gehören
>>prinzipiell dicht am IC da hin.
>
> C1.
Stimmt, hatte ich wohl Tomaten auf den Augen...

>
>>Ich vermisse den 100n am Eingang des 7805.
>
> Der ist ein Legende, ist aber auch vorhanden. C2.

Hab ich wohl im Layout vermisst.

Naja, die Legende stammt aber von den Herstellern der 78xx-Regler.
Meist wird sogar 0,33µF angegeben.
Mir waren die 2x 100n direkt! am Regler bisher nicht zu teuer, bei 
meinen privaten Einzelstücken haben sie auch noch nie geschadet.
Irgendwie ist mir die Variante, erstmal alles wegzulassen, was man 
gerade nicht parat hat, evtl. stundenlang mit Problemen zu kämpfen, die 
man anders garnicht erst hätte, zu nervend. ;)

>
> MFG
> Falk

Gruß aus Berlin
Michael

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Andy H. (higedigdag)

>Ich hab mal den Snubber so eingezeichnet wie ichs verstanden hab. Ist es

Passt.

@ Michael U. (amiga)

>Naja, die Legende stammt aber von den Herstellern der 78xx-Regler.
>Meist wird sogar 0,33µF angegeben.

Dass man einen C am Eingang braucht ist klar, aber dort sind doch schon 
hunderte uF mit dem Elko. Das reicht. Das ist kein Digital-IC, der mit 
Hunderten von MHz arbeitet.

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK danke.

Ich werde das Layout auch noch hochladen wenn ichs fertig hab.

Autor: Roland Praml (pram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermisse noch einen 100nF am Reseteingang, sowie ein RC Gleid an X3.
Hier ist vermutlich der Füllstandschalter angeschlossen. 220 Ohm/100nF 
sind hier bestimmt auch nicht verkehrt.

Gruß
Roland

Autor: Nitram L. (nitram)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:
> @  Andy H. (higedigdag)
>
>>Ich hab mal den Snubber so eingezeichnet wie ichs verstanden hab. Ist es
>
> Passt.

Wenn ich mich richtig errinnere, stand in der VDE-0565-1 zwingend der 
Typ X2! MKS-4-630 ist ein 0815 Folienkondensator....

X2 Typen sind selbstheilend, und somit in der Lage, Schäden durch 
Stannungsspitzen ohne "Hausbrand" zu überstehen!
Bitte informiere dich etwas mehr, und glaube nicht blind jedem 
Vorschlag... (kann teuer werden oder Menschenleben kosten)
Rei*** hat glaube auch X2 Typen...

nitraM

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Roland Praml (pram)


>Ich vermisse noch einen 100nF am Reseteingang,>>sowie ein RC Gleid an X3.
>Hier ist vermutlich der Füllstandschalter angeschlossen. 220 Ohm/100nF
>sind hier bestimmt auch nicht verkehrt.

DAs mit dem 100nF hatte ich schon gepostet und ist in der Schaltung von 
bereits 21.01Uhr berücksichtigt.

>>X3?
man KANN an die xtal-Anschlüße des Chips eine RC-Glied,einen Quarz oder
Quarzoszilator oder eine von einem anderen Chip erzeugten Takt 
anschließen oder man programmiert das interne RC-Glied (lt.Atmel 
Datenblatt)
was hier aber leider nicht ersichtlich ist da Andy keine Software 
dokumentiert hat.Ich gehe davon aus,das das interne RC-Glied den
Controller taktet (Wahrscheinlich auch Herstellerseits voreingestellt).
Dann dürfte es erstmal kein Thema sein.

>>Hier ist vermutlich der Füllstandschalter angeschlossen.
Hatte ich auch schon angesprochen was aber für das Störproblem wohl 
nicht ursächlich ist.Einen Snubber ist hier überflüssig da ein Schalter 
keine Störquelle darstellt.(hier können andere Störfaktoren eine Rolle 
spielen)

An Pin 18 würde ich sofern nicht Spannung aus dem Eingang kommt,einen
Pullup-Widerstand (nach +5V)von 1-10kOhm einplanen.Sonst könnte das der
offene Eingang sein wenn der Füllstandsschalter offen ist.
Geschlossen hat diese dann Masse-potenzial.

Bin gespannt ob die Vorschläge etwas bringen.

gruß Martin.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen 230V Varistor parallel zur Last wuerde auch nicht schaden.
GND deiner Schaltung ueberein paar nF auf PE zu legen koennte auch noch 
helfen.

Gruss Helmi

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
habs nochmal geändert und einen X2 Kondensator verwendet.

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und hier das Layout.
Ist es denn so besser getrennt?

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh ich seh gerade das der Transistor im C5 hängt...

Keine bösen Worte ;) ich änder das noch.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>oh ich seh gerade das der Transistor im C5 hängt...

Gabs keinen grösseren? BC337 tuts hier locker. R2 ist vielleicht ein 
wenig gross. 1K ist günstiger. Wieviel Strom braucht das Relais?
Ausserdem solltest du einen SERIENwiderstand für deinen Schalttransistor 
verwenden, den Pull-Up kannst du dir sparen. Dazu kann man die internen 
nutzen.

Sonst sieht das ganze schon WESENTLICH besser aus.

MfG
Falk

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andy:

Zum Layout, ich würde zB. noch Pin 1 und 2 im Schaltplan vom Relais
tauschen, dann kannst Du im Layout die Führung unterm Relais vergessen.

Ebenso bei der Last-Klemme Pin 1 und 2 tauschen.
Dann kann die Leiterbahnen noch weiter von einander verlegen.

Just my 2 cents.

Gruß Sven

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und hier das Layout.
Ist es denn so besser getrennt?
Sehr gut,die Leitungen kann man an der Relaisspule noch tauschen.
(muß man aber nicht).Freilaufdiode dann um 180Grad drehen.
Die Leitungsführung sieht dann besser aus.
Auf jedem Fall ist das Ganze dann Sicherer und wenn man Messungen 
durchführt kann man die netzgefürten Anschlüss leicht abdecken,damit man 
keine Schlag bekommt wenn man diese versehentlich berührt.

>oh ich seh gerade das der Transistor im C5 hängt...

Den solltest du mindestens 5mm oder mehr vom Elko plazieren.
Laut Datenblatt des Typ`s BC140 ist das Gehäuse mit dem Kollektor
verbunden.Manche Elkos haben einen Schrumpfschlauch über dem Becher
aber dieser könnte auch fehlen oder beschädigt sein und hat dann 
Massepotenzial.Wenn sich beide Bauteile berühren fließt der Relaisstrom
über den Elkobecher und der Transistor wäre nutzlos.


>>BC337 tuts hier locker.
Man kann nur das nehmen was man hat.Für eine spätere Verbessung
ist dieser Tip nicht verkehrt.
>>1K ist günstiger.
Über Kosten kann man sich später Gedanken machen.
>Wieviel Strom braucht das Relais?
Da würde mich interessieren ob der Chipausgang genug Strom für den BC140 
liefert? Aber mit einer Lampe geht`s doch,also was soll`s.
>Ausserdem solltest du einen SERIENwiderstand für deinen Schalttransistor
>verwenden.
Wozu das denn und welchen Wert?
>>Dazu kann man die Internen nutzen.
Wenn das sicher ist,warum nicht.
>den Pull-Up kannst du dir sparen.
Wichtig wäre erstmal die Schaltung Störungsfrei zum Laufen zu bekommen.
Den Pullup würde ich nicht gleich weglassen solange nicht geklärt ist
ob im Chip ein interner Widerstand wirksam ist.Man müßte an den offenen
Kontakten eine Spannung messen können.Ist der Kontakt des 
Füllstandsschalters geschlossen,wäre der Pegel dann Null.


Gruß Martin

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ pcbfreak (Gast)

>>>1K ist günstiger.
>Über Kosten kann man sich später Gedanken machen.

???
Es geht dabei nicht um Kosten sondern sicheres Durchsteuern das 
Transistors.

>>Wieviel Strom braucht das Relais?
>Da würde mich interessieren ob der Chipausgang genug Strom für den BC140
>liefert? Aber mit einer Lampe geht`s doch,also was soll`s.

???
Der AVR steuert über den Transistor ein Relais!

>>Ausserdem solltest du einen SERIENwiderstand für deinen Schalttransistor
>>verwenden.
>Wozu das denn und welchen Wert?

Ahhhh, ich meinte den Schalteingang.

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habs nochmal geändert.

@Falk

Ich verstehe nicht was du mit dem SERIENwiderstand meinst? Der PIN wird 
doch über den Schwimmerschalter nur auf LOW gezogen. Wozu braucht man da 
noch einen Widerstand?

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
den großen Transistor verwende ich weil ich ihn schon da habe.
Wollte nicht noch extra andere Teile bestellen...

MfG Andy

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Andy H. (higedigdag)

>Ich verstehe nicht was du mit dem SERIENwiderstand meinst? Der PIN wird
>doch über den Schwimmerschalter nur auf LOW gezogen. Wozu braucht man da
>noch einen Widerstand?

Schon klar, aber Leitungen von aussen fangen sich mal fix ESD ein, 
Hochspannung durch statische Aufladung. Und irgendwann killt es mal den 
AVR. Ein Serienwiderstand von 1..5K kann da viel schützen.

MFG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so, mal was ganz Grundsätzliches. Was macht eigentlich der AVR? Sag 
bitte nicht, dass der nur den Puls vom Schalter weiterleitet . . .

MfG
Falk

Autor: Josef (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für den Anfang nicht schlecht, wenn du absoluter Einsteiger bist. Aber 
lasse bitte am Anfang die Hände von 230 Volt. Es sind nach wie vor viele 
Fehler vorhanden, die gefährlich werden können.
Benutze besser gute Steckernetzteile. Snubber sind der letzte Ausweg.
Hat schon jemals wer Snubber bei einer Profi-Steuerung gesehen ?
Diese kommen wohl eher bei Dimmern und Haushaltsgeräten vor.

Also ich möchte nicht, daß meine Siemens SPS Snubber drinnen hätte ;-)


Grüße Josef

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Falk

> Ach so, mal was ganz Grundsätzliches. Was macht eigentlich der AVR? Sag
> bitte nicht, dass der nur den Puls vom Schalter weiterleitet . . .

Der AVR schaltet für ca. 90sec den Basisstrom zum Transistor. Das kann 
man sicher auch ohne AVR lösen... wollte ich aber nicht weil ichs so 
einfacher verstellen kann.

MfG Andy

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andy H. (higedigdag)

>Der AVR schaltet für ca. 90sec den Basisstrom zum Transistor. Das kann
>man sicher auch ohne AVR lösen... wollte ich aber nicht weil ichs so
>einfacher verstellen kann.

???
Ein popeliges Monoflop tuts locker. Und das wesentlich einfacher und 
robuster.

MfG
Falk

Autor: Alfred Q. (higedigdag)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Falk

> ???
> Ein popeliges Monoflop tuts locker. Und das wesentlich einfacher und
> robuster.

Ich hab halt noch viele von den AVRs da. Wollte die mal bissel 
verbrauchen.


Ich hab noch einen Widerstand in Reihe zum Schalter gemacht. Meintest du 
es so?

MfG Andy

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja

Autor: Gerhard. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich moechte auch noch meinen Senf dazu beitragen;-) Man sollte auch noch 
einen extra Pull-Up Widerstand am Eingang des Fuellstandsensors 
anbringen da Schalter oft einen gewissen Minimumstrom brauchen um mit 
der Zeit nicht unzuverlaessig zu werden. Der Pull-Up Strom vom AVR ist 
meiner Meinung nach dafuer ungenuegend. Sollte der Fuellstandsensor 
allerdings einen elektronischen Ausgang haben, dann ist es unnoetig. Der 
Pull-up sollte aber vor dem Laengswiderstand der vorgeschlagen worden 
ist, eingebaut werden.

Ich weiss es ist nur eine Kleinigkeit, aber solche Sachen treten meist 
nach langer Zeit (Jahren) auf und dann rauft man sich die Haare aus weil 
es aus mystischen Gruenden so unzuverlaessig geworden ist.

Gruss,
Gerhard

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo Andy,
Manche Tips hier lassen wirklich sehr zu Wünschen übrig.

Abgesehen von den etwas mehr Abstand der Leiterbahnen (Netzspannung)
an den Schrauben(z.B. durch 45 Grad Leitungen)) würde ich das Layout
so lassen.Es wird immer jemanden geben der das noch besser kann.
Ich würde mich erstmal hier nicht um so ungelegte Eier wie
ESD,(auch EMV) und sonst was,kümmern.Sicherheit muß sein,aber alles 
andere
kann man berücksichtigen wenn ein deratiges Problem akut wird.
Mach erst mal einen Prototyp und dann sieh ob die Schaltung
mit dem Motor läuft,sonst wird das eine Lebensaufgabe.
Erweiterungen,Verbesserungen usw.kann man auch auf eine weitere Platine
Huckepack aufbauen wenn das unvermeidbar ist.

Gruß Martin

Autor: Sven Stefan (stepp64) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit den Schrauben wollte ich auch noch anmerken. Nicht das eine 
U-Scheibe auf der Leiterbahn aufliegt und dadurch einen Schluss zum 
Gehäuse herstellt.

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke erstmal an alle die etwas beigetragen haben.
Ich werde in den nächsten Wochen testen und euch dann mein Ergebnis 
mitteilen.

MfG Andy

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So...

Heut hab ich die Schaltung nochmal getestet. Läuft einwandfrei ;) und da 
hab ich noch nichtmal den Snubber drin.... Hab die Platine zwar dafür 
vorgesehen aber hab die Teile noch nicht.

Habs vorher auch nochmal mit dem Oszi gemessen... es kommen durch das 
schalten keine Störungen zum AVR.

Vielen Dank für die Hilfe!

MfG Andy

Autor: HannsW (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich will DIch ja nicht verunsichern.
Ich hab mal was gelesen, daß man FlüssigkeitsFühler besser mit 
Wechselspannungen ausführt, da bei Gleichspannungen gern Korrision 
etnsteht.

Leider finde ich den Link nicht mehr, aber such mal nach dem Stichworten
"Schließen eines Dachfensters"

Hanns

Autor: pcbfreak (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gern geschehen.

Gruß
martin

Autor: Gerald Schwarz (geralds)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo andy,

schau mal bitte auf die epcos-seite:
http://www.epcos.com/inf/20/20/ds/X2_B32921_926CD.pdf
hier auf dem web findest du auch einige formeln, wenn es um leistungen
oder power-faktoren geht.
ps: der condi mit 400V DC (spitze!!) ist, denke ich, zu wenig.
nach norm sollte der condi mind. 265VAC spannungsfest sein
(230 plus mind. 10%).
mancher orts kommt tag/nachts mehr als 230VAC-eff vor, je nach 
haushaltsverbrauch.
das ergibt u-spitze mehr als 400V mit dem berücksichtigten 
condi-powerfaktor. bei 25Grad-C umgebungstemp.
bei höherer umgebungs-arbeits-temperatur ist entsprechend anders zu 
rechnen.
ein condi mit max 400V wäre zeitlich und thermisch vielleicht hier
überfordert. bitte den condi- ESR (bauteil-serienwiderstand) 
berücksichtigen.

anderseits verwende ich zum ansteuern eines motors grundsätzlich
einen passenden schütz, und ab je nach motorleistung einen passenden 
motorschutz, direkt auf den schütz montierbar.
der hat einen doppelkontakt, so dass das ein/ausschalten sicherer wird.
damit gibt es einen grösseren kontaktabstand auf gleicher ebene, 
doppelt, da "zwei" kontakte elektrisch in serie sind. x___----___x
damit ist die unsichere lösung mit der funkenlöschung parallel zum 
rel-kontakt eher nicht notwendig.
der rel-kontakt "schleift, bzw. reibt" auf und zu, was mit dem zündeln
einens streichholzes vergleichbar wäre, und damit einen funken beim 
öffnen "ziehen" kann.
im schlechtesten fall kann ein "feuern" des kontaktes entstehen,
der den relaiskontakt zusammenschweisst.
die 2 kontakte parallel im schaltplan bieten eher keinen vorteil,
ausser mehr stromfluß möglichkeit.
im gegenteil, würde ich nicht tun, da die rel-schaltzungen zeitlich 
unterschiedlich schalten können, was ein grösseres kontaktprellen
verursachen kann, ein aufschaukeln der spannungsspitzen verursachen kann
 und damit u.U. die funkenlöschung verschlechtern (r-c zeitglied, > 
energiespeicherung usw.) bzw. ganz deaktivieren kann.
ist dabei in dieser, r-c-zeitglied, rechnung der powerfaktor des 
pumpenmotors berücksichtigt?
arbeits-umgebungs-temperatur und klima nicht vergessen.

die schützspulen gibt es mit verschiedenen gleichspannungen.
besser verwende aber einen wechselstromschütz, damit nicht eine
dauermagnetisierung der spule(ankerkleben) auftreten kann.
diese gibt es auch in versch. spannungen.
zum ansteuern verwende hier einen triac, der vom transi gesteuert wird. 
hier kannst nach dem trafo, damit galv. von 230VAC getrennt, den schütz 
(zB 24VAC) steuern. er benötigt relativ wenig spulenstrom.
die schutzdiode parallel zur spule, lebenswichtig für den transi, mit 
1n4148 kann zu klein sein.
verwende eine 1N4004 oder vielleicht billiger eine 1N4007.
der basisvorwid. mit 3k9 ist, denke ich ok, verwende noch einen 
pull-down
basis-gnd mit mind 5k6 bis 10k. damit schaltet der transi sicher aus,
bei "loslassen" vom aktiv high, d.h. low-setzen durch den controller.
es verhindert ein "aufschweben, schwimmen" der Basis, was den transi
unkontrolliert einschalten kann. zudem hilft es den transi schneller zu
entladen.
insbesonders beim einschalten des gerätes während der init-phase
nach dem reset.

hier ist noch eine webseite:
http://www.moeller.at/de/service/download_kataloge.html
da findest einen katalog mit den verdrahtungplänen von 
motoransteuerungen
und schützsteuerungen. ist ein grösseres pdf file.

ps: all dieses hängt natürlich u.a. von der gewünschten
(motor)arbeitsleistung, umgebungs-arbeits-temperatur, klima,
bzw. preis, usw. ab. kann sein, dass hier manches übertrieben erscheint,
ist leider, weil ich nicht genau alle umstände kenne.
hoffe, ich konnte hier einiges helfen.

gruß
gerald

Autor: HannsW (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ANdy,
ich habs gefunden.
http://www.elektronik-kompendium.de/forum/board_en...

Hanns

Autor: Alfred Q. (higedigdag)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo HannsW

Danke für den Link. Aber ich habe keinen metallischen Sensor. Meiner ist 
ein Reed-Relais mit einem Magneten. Da kann also nix korrodieren.

MfG Andy

Autor: juppi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo leute

Habe alles durchgelesen.
Denn Störungen sind kritisch.

Eine alte Methode ist Controller mit Akku betreiben.
Damit wird selektiert.
Netzstörungen oder Eingangsstörungen.
Was seltener vorkommt.
Kapazitive Einkopplung über die Prim/Sek-Wicklungen.

Hatte schon öfters geholfen.

MfG

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.