mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega8; HyperTerminal und UART


Autor: auch AVR Einsteiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe die gleichen Probleme wie im Forumeintrag mit folgendem Link:
Beitrag "Buch_ AVR Mikrocontroller von H. Trampert"

Hab das Tutorial durchgearbeitet, das Atmel Manual und meine
Daten, die mein Atmega8 sendet erscheinen nicht im Hyperterminal!
Was kann ich tun? Gibt es deutsche Anleitungen für Anfänger, quasi
so SChritt für Schritt "TO DO Listen"!
Schon mal danke für Eure Hilfe, ich denke in diesem Thema sind einige
Spezialisten und können einem Einsteiger wie mir Helfen!
Hab hier im Forum und im Internet schon rumgesucht, aber leider läuft es 
immer noch nicht!
Vielen Dank schon mal!

Autor: Dussel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was heißt Anleitung? Hier im Tutorial ist alles genau beschrieben.
Aber da ich auch (mal) Anfänger war/bin:
-MAX232 an die richtigen Pins angeschlossen?
-Kondensatoren am MAX alle mit der passenden Kapazität richtigrum 
angeschlossen?
-MAX mit Strom versorgt?
-RS232 Buchse richtig angeschlossen?
-Passendes Kabel?
-Im Hyperterminal richtigen Port gewählt?
-Passende Übertragungseinstellungen? (sollte eigentlich, wenn du den 
Screenshot übernommen hast)
-Und am Schluss noch: Arbeitet der ATMega überhaupt?
Sind jetzt die Punkte, die mir gerade so eingefallen sind.

Wenn gar nichts klappt kannst du auch mal MIDI ausprobieren, das kommt 
ohne Pegelwandler aus. Damit würde dann eine Fehlerquelle wegfallen. 
Aber bevor du das versuchst, erst mal informieren, sonst zerschießt du 
dir deinen Empfänger

Autor: auch AVR Einsteiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für den Eintrag im Forum. Ich habe das STK500 Board. Ich denke da 
ist ja alles schon richtig angeschlossen und konfiguriert. Ich schließe 
einfach das mitgelieferte RS232 Kabel an der Spare Buchse an, die ist ja 
für Kommunikation.
Der Atmega 8 arbeitet einwandfrei, ich setze bei jedem neuen 
Softwarestand einen anderen PORT und lass auf dem STK500 eine LED 
brennen.
Also denke ich, dass ich hardwaretechnisch alle richtig beisammen habe.
Es muss irgendwie an meiner Software liegen. Muss mich da noch irgendwie 
weiter durchbeißen und noch mehr suchen. Hat jemand nen Tipp, wo es ein 
kleines Standartprogramm gibt, dass einfach mal irgendwelche Zeichen 
sendet. Dass kann ich ja dann hernehmen und weiter ausbauen.

Also dann noch nen schönes WE und schon mal danke im Voraus

Autor: auch AVR Einsteiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habs vorher vergessen. Ich hab den Code auf der Seite gelesen! Hat 
vielleich jemand was in C-Code?

Danke frohe Ostern!

Autor: Hubert G. (hubertg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Kabel vom Port auf RXD TXD richtig gesteckt.

Autor: auch AVR-Einsteiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab das ATMEL STK500 Board. Ich denke da ist schon alles fertig.
Hab einfach das mitgelieferte Atmel Kabel an die RS232 Spare Buchse 
angeschlossen. Ansonsten habe ich keine Verbindungen gesteckt auf dem 
Board.

Autor: Thorsten K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da steckt der Teufel im Detail.
Verbinde mit einem zweiadrigen Kabel folgende Pin´s
PD0 mit RXD
PD1 mit TXD und schon sollte es funtzen...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.