mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit LM2575 und LM358 für 700mA Konstantstrom


Autor: Kai E. (kai20)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe den Schaltregler wie im anghängten Bild OHNE den LM358 
aufgebaut, mit einer
1A Schottky, 220uH Speicherspule und 220uF und als Shunt 1.8Ohm - 
einwandfrei, 700mA fliessen
durch die LED und sie Oszilloskopbilder des Spulenstroms sehen wie in 
der Spezifikation aus,
also alles zufriedenstellend, ausser die Verlustleistung des Shunts.

Also habe ich, wie ähnlich wie im Bild dargestellt, den Shunt 
verkleinert und den Spannungsabfall um 3.7 verstärkt,
0.7A*0.47Ohm*3.7 = 1.23V.
Doch leider höre ich dann die Spule fiepen, die Schaltreglerfrequenz 
sinkt nun auf ca. 11kHz ab. In der Spec steht,
dass das Herabsenken von typ 52kHz auf 11kHz durch den LM2575 durch 
einen Kurzschlussschluss oder eine Überlast
verursacht wird.
Ich habe aber schon einige Infos im Netz gelesen, dass diese Schaltung 
eigentlich funktieren sollte.
Andere OP-Typen oder abgeschirrmte Leitungsführung am Pin Feedback 
zeigen keine Verbesserung.
Eigentlich sollte die 1MHz Bandbreite doch reichen und es sind nur 
Kleinsignale, die vertstärkt werden, sollte
demnach auch die Slewerate reichen.

Nun die Frage, hat jemand von euch schon mal ähnliches Problem oder 
Verhalten gehabt und könnt mir
einen Tipp geben, was ich in der Schaltung ändern muß ?

Für eine Hilfe oder einen Tipp wäre ich dankbar,
Kai

Autor: let (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei der Schaltung sind am OpAmp die Pins 2+3 vertauscht.

Autor: Kai E. (kai20)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi let,

danke für die Antwort,
aber habe mich beim Erstellen der Platine
an das National Datenblatt des LM358 gehalten, somit
ist der inv. Eingang in der Rückkopplung.

Hat denn vielleicht noch jemand eine Idee zur Ursache des Verhaltens ?

Kai

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist schlicht und ergreifend das Symbol des LM358 falsch.
Sicher ist der invertierende (-) Eingang in der Gegenkopplung, aber das 
ist nicht der Pin 2 sondern der Pin 3.

Autor: Kai E. (kai20)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Haette ich den inv. und nicht inv. Eingang verwechselt,
wuerde die Schaltung gar nicht funktionieren.
Also, Pin 3, der der inv. Eingang ist in der Gegenkopplung.

Ich wollte eigentlich mehr nach dem Schaltungsverhalten fragen,
wieso der LM2575 in den Fehlermode geht ?

Danke,
Kai

Autor: Arno H. (arno_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pin 3 ist der nicht invertierende Eingang, Pin 2 der invertierende.
Auch bei NatSemi.
Der inv. Eingang liegt (fast) immer neben dem Ausgang, vereinfacht auch 
das Layout
Die Schaltung des OPV mit  + und - ist richtig, die Zahlen sind 
vertauscht.

Arno

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieter Werner wrote:
> Es ist schlicht und ergreifend das Symbol des LM358 falsch.
> Sicher ist der invertierende (-) Eingang in der Gegenkopplung, aber
> das ist nicht der Pin 2 sondern der Pin 3.

Grrrmpf
Extra nochmal drübergeguckt und trotzdem falsch.
Arno H. hat latürnich recht, Pin 2 ist der - input.

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was passiert, wenn Du C2 entfernst ?

Autor: Kai E. (kai20)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd,

ich habe sowohl 2 x 220uF, als auch nur 22uF als C2 angeschlossen - 
leider
keine Besserung.
Ich habe auch mal den TLC272 ausprobiert, weil ich im Netz auch schon 
mal
einen Schaltplan mit dem TLC272 als 'Shuntverstärker' gesehen habe.

Nun denn, ich glaube, ich muss die erhöhte Verlustleistung in Kauf 
nehmen.

Kai

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du nutzt einen Baustein zur Regelung einer Spannung um einen Strom zu 
regeln - das ist nicht leicht.

Der Schaltregler erzeugt mit der Spule (bei nicht-unterbrochenem Betrieb 
der Spule) einen Strom, der immer ansteigt und abfällt. Der Kondensator 
C2 ist eigentlich sinnlos, weil immer die LEDs angeschlossen sind und 
ein Strom fließt.

Ich denke mal, daß Du die Spannung über den Shunt über ein RC-Glied 
etwas mitteln sollst (10k + 1uF) und den Ausgang des OP-Amps auch, so 
daß der 2576 eine Gleichspannung zum Vergleich mit der Referenz erhält.
Sonst ist der Feedback immer stark wechselnd (zu klein/zu hoch).

Autor: Stephan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Kai,
ich arbeite an einer ähnlichen Geschichte und habe es auch mit der 
Gegenkopplung versucht. Ist aber alles nichts richtiges geworden.
Allerdings brauche ich einen Bereich der linear ist. Daher nutze ich 
folgende Schaltung ( ist nur prinzipiell gezeichnet ). Der INA hat eine 
V von ca. 27.
der - Eingang des LM358 wird über ein Digitalpoti mit max. 1,25 V 
versorgt.
Somit kann ich zB. linear bis 0,5A stellen. Anbei mal ein Excelsheet. 
Aufgenommen mit MAX186. Die Blaue Kurve entspricht der Potistellung und 
die rote dem Konstantstrom.
Gruß und vielleicht hilfts ja.

Autor: Stephan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und das sheet

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.