Forum: Digitale Signalverarbeitung / DSP Rasterelektronenmikroskop Zeiss DSM 960


Announcement: there is an English version of this forum on EmbDev.net. Posts you create there will be displayed on Mikrocontroller.net and EmbDev.net.
von Felix D. (tmbinc)


Bewertung
0 lesenswert
nicht lesenswert
Also, ich verzweifel noch am seriellen Port. Ich kann hin und wieder 
Kommandos senden und bekomme eine korrekte Antwort, aber meistens kommt 
entweder gar keine Antwort, oder eine Fehlermeldung ("E0101<ETB>", was 
wohl soviel bedeutet wie "ich muss erst F00 senden" - aber das tue ich 
ja!). Wenn es aber mal funktioniert, dann antwortet das DSM mit 
"F33F20<ETB>" - wohlbemerkt, ich sende immer das gleiche. Auf dem Scope 
sieht's - auch nach der Pegelwandlung - okay aus. Wenn ich dann z.B. 
"Q00<ETB>" sende, bekomme ich auch hin- und wieder eine Antwort, aber 
meist nur "E90" ("falsches Kommando"). Irgendwas ist da kaputt. Wenn ich 
das in einer Schleife laufen lasse, funktioniert es irgendwann garnicht 
mehr - wenn ich dann mit CTRL+BREAK resette, geht es wieder (wie oben - 
meist E1010, aber manchmal korrekt). Das deutet für mich auf ein 
digitales Problem, sonst würde der Reset ja nichts verändern.

Ich habe die Wandlung von RX und CTS überprüft (vor- und hinter der 
Pegelwandlung/Optokoppler gemessen), das funktioniert. Ich habe die 
Baudrate am Z80DART gemessen, das passt auch. Ich habe langsamere 
Baudraten probiert, das ändert nichts. Ich habe den zweiten Port 
probiert, das ändert auch nichts. Baudrate an meinem Seriell-Wandler ist 
auch recht genau.

Mittels CTRL-S "RS232TEST" kommt man in ein Test-Menü, wenn ich dort "6" 
eingebe, wird der Loopback für den ersten externen Port aktiv; aber das 
funktioniert auch, alles was ich ausgebe ("OUTP") wird auch wieder 
eingelesen ("INP"). +5V sind soweit okay.

Nun bin ich ein bisschen ratlos. Hat irgendjemand eine Idee, was ich 
noch nachmessen könnte?

von Sunny S. (sunny_s)


Bewertung
-1 lesenswert
nicht lesenswert
Hallo Felix;

versuch mal das "E0101(ETB)" mit runden Klammern.
vielleicht liegt es daran.

Viele Grüße

Sunny

von Felix D. (tmbinc)


Bewertung
0 lesenswert
nicht lesenswert
ETB wird nicht als Text übertragen, sondern ist hex 17 (siehe 
https://en.wikipedia.org/wiki/End-of-Transmission-Block_character). Also 
"F00<ETB>" in hex wäre dann 46 30 30 17. Ohne das 17 kommt auch gar 
keine Antwort.

von Sunny S. (sunny_s)


Bewertung
0 lesenswert
nicht lesenswert
Ok.

Mit was für einem RS232-Gerät überträgst du die Daten?

Kann dein Ozi auch Protokolle dekodieren?

Vg

von Felix D. (tmbinc)


Bewertung
0 lesenswert
nicht lesenswert
Ich habe einen FTDI-basierten RS232-Wandler. Die Pegel sind nicht +/-12V 
(sondern nur ~+/- 6V, wie bei fast allen USB-Wandlern), so dass ich erst 
dachte, dass es daran lag. Ich habe mir daher die Signale vor- und 
hinter dem Line Receiver (75189 "Quad Line Receiver", auf der -9014) 
angeschaut, aber das passt. Dem Receiver reichen laut Datenblatt schon 
~+/-2V (je nachdem, welcher Typ da nun wirklich verbaut ist). Ich habe 
mir das Signal an J1/J2 abgegriffen (dem Jumper fuer den kurzen 
Loopback-Test).

Protokoll-Decoder - ja schon, aber die Signalform ist ja in Ordnung. Ich 
dachte erst, dass vielleicht die Baudrate daneben liegt oder so, aber 
auch die passt (Pin27 am Z80DART).

von Tim (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Felix D. schrieb:
> Protokoll-Decoder - ja schon, aber die Signalform ist ja in Ordnung. Ich
> dachte erst, dass vielleicht die Baudrate daneben liegt oder so, aber
> auch die passt (Pin27 am Z80DART)
Wenn Du schon zu den Innereien vorgedrungen bist:
Vielleicht kannst Du den EPROM auslesen (wenn es einen gibt) und das 
Hexfile durch den Disassembler schicken. Kurz nach der Stelle, wo auf 
den DART zugegriffen wird, findet sich vermutlich der Protokolldekoder.

von Max (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Felix,

die jeweilige RS232 wird über das CTS Signal aktiviert, PIN 4,da muss 
ein definierter Pegel von +10 bis +15 Volt anliegen. +15Volt kommen am 
PIN 25 raus, aber nicht direkt einspeisen. Vielleicht löst das dein 
Problem, falls du das eventuell noch nicht beachtet hast.
Die Schnittstellenparameter werden über Ctrl S  und der weiteren
Eingabe: SERIAL  zugänglich.
In der Gebrausanleitung für das Systemsteuerinterface ist auch die 
Kommando-struktur genau beschrieben.

ich habe deine PM-Adresse leider nicht gefunden.

viele Grüße Max

von Sunny S. (sunny_s)


Bewertung
2 lesenswert
nicht lesenswert
Hallo
Grüße an das Forum.

Nach langer Zeit mal ein kleines Update.

Nachdem ich ein DSM 962 erworben habe

diente mein 960 nur noch als Ersatzeilspender.

Durch einen Glücklichen Zufall, erwarb ich ein
Hitachi S4200 mit kalter Feldemission.

Dieses Rem hatte noch eine ÖL-Diffusions Pumpe
für das Hauptvakuum. Um Kontamination in der
Hauptkammer zu vermeiden hätte ich immer Flüssigen
Stickstoff als Kontaminationsverhinderung
haben müssen. Das ging natürlich nicht.
Darum habe ich die alte DP rausgebaut und eine
Edward ext250 TP eingebaut.

Dadurch ergaben sich für mich folgende Vorteile
- das Rem läuft jetzt ohne Wasserkühlung
- ich brauche keinen Stickstoff mehr


Die Pneumatik, die die ganzen Kammer.- u. Schleusen Ventile
versorgt hatte auch noch ein Leck.

Das Problem konnte ich lösen, durch ersetzten der alten Pneumatik 
Schläuche und der
Org. Ventilinsel gegen neue Festo Schläuche und einer Festo Ventilinsel.

Nachdem alles umgebaut war konnte ich nach Ausheizen der Säule
das Rem zu ersten mal in Betrieb nehmen.

Die Auflösung ist der Hammer. 100000x ist nun kein Problem mehr.

Als nächstes baute ich das Rem auf Ext. Bildeinzug um.
Ein Point Diss 5 war die erste Wahl. ( Günstig bei Ebay )

Erstmal die alten Monitore raus und auf Flachbildschirm umgebaut.
Dann das Diss5 rein.

Da ich auch ein Leo Wolfram Rem habe benötige ich das DSM 962 nicht 
mehr.

Mein altes DSM 962 ist übrig und steht jetzt zum Verkauf.

Bilder vom Umbau und von Proben sende ich nach.

Viele Grüße

Sunny

von Sunny S. (sunny_s)


Angehängte Dateien:

Bewertung
3 lesenswert
nicht lesenswert
Hier mal das Zeiss Dsm 962
und ein paar Hitachi Pu.Umbau und Proben Bilder.

von stefand (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Sunny,
vor Jahren habe ich auch mal eine S4100 umgezogen und wieder 
hochgefahren, allerdings mit Diffpumpe...
Mir fällt auf, daß deine Extraktionsspannung mit 6,1 kV extrem hoch ist. 
Das deutet darauf hin, dass die CF-kathodenspitze schon zu rund ist. Du 
wirst vermutlich in nächster Zeit einen Tip-Wechsel machen müssen.

Herzliche Grüße,
Stefan

von Sunny S. (sunny_s)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

kann sein.

Ich muss ja vor jeder neuen Benutzung
einmal Flashen und erst nach ca. 30min - 2h
ist der Strahl erst richtig einsatzbereit.

Ich war anfangs ein wenig ungeduldig
und habe einfach, wenn der Strahlstrom
gesunken ist nochmal auf die HV on Taste
gedrückt. Dadurch wurde die Ve erhöht
und ich hatte wieder ein besseres Signal.

Wenn ich aber die Zeit abwarte bis sich alles
nach dem Flashen stabilisiert hat.
Bleibt die Ve bei 4,5kv - 5,5kv.

Wenn ich Flashe erscheint kurz eine Strahstrom
Anzeige, die liegt jetzt bei 56 müA.

Ist das ein Hinweis auf den Abnutzungsgrad der Kathode?

Wo könnte ich eine neue herbekommen?

Viele grüße

von stefand (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Sunny,
bei einer sehr guten Spitze hatte ich um die 4,1 kV Extraktionsspannung. 
Das wird natürlich mehr im Laufe des Tages...
Ich habe zu den Hitachi-FE-REM einige Unterlagen, muss aber erst einmal 
fragen, ob ich sie weitergeben darf.
CFE-Tips gibt es bei DENKA oder YPS, etwa € 3000 das Stück.

Ich selbst bin mit einer TESCAN MIRA3 unterwegs, seit zwei Jahren ;-)
CFE wäre nichts für mnich, da ich oft lange nanoflight-Sequenzen im REM 
(Animationen...) aufnehme, die zwischen 12 und 30 Stunden laufen.

Herzliche Grüße,
Stefan

von Stefan Trapp (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Sunny nach langer Zeit wieder eine Meldung. Wir hatte vor Jahren 
schon konferiert und jetzt ist Deine mail Adresse weg. Mein alter DSM 
950 verabschiedet sich langsam aber gewiss mit lahmenden Platinen.

Bitte melde Dich einfach nochmal.

ST

von SD (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,
wenn du mir die Nummern der Platinen gibst kann ich nachschauen, ob ich 
Ersatz habe. Ich habe zwei DSMs in Ersatzteilen im Keller...

Gruss,
Stefan

von Steven Hohmann (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

die Platinennummer 348338-9010-1001.

Wenn Sie solch eine Platine noch auf Lager hätten, wäre dies SUPER.

Gruß

Steven

von SD (Gast)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Steven,
ich schaue nach, kann aber ein paar Tage dauern, weil eingelagert.
Falls ich drauf vergesse, bitte mahnen... ;-)
Was macht die Platine genau?

Gruss,
Stefan

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
Hallo Sunny,
Nachdem dieser Thread nach längerer Zeit wieder hochgekommen ist,
würde mich mal interessieren, ob Dein REM nach wie vor regelmäßig
von Dir benutzt wird, und was Du da so mit anstellst. Ich hatte
früher beruflich auch viel mit einem (Philips-)REM zu tun, aller-
dings eher wartungsmäßig und weniger messend. Eigentlich ist mir
damals nichts eingefallen, was ich mir unbedingt privat im REM
ansehen wollte. Gemessen habe ich mehr mit einem AFM (Rasterkraft-
Mikroskop), aber auch da kenne ich nichts, was irgendwie privat
ansehenswert gewesen wäre. Interessant fand ich da u.a. die "Rie-
senfelsblöcke" mit ca. 80 Nanometer Durchmesser, die ein Raucher
auch noch eine halbe Stunde nach der letzten Zigarette ausatmet.

von Steven Hohmann (Gast)


Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
SD schrieb:
> Hallo Steven,
> ich schaue nach, kann aber ein paar Tage dauern, weil eingelagert.
> Falls ich drauf vergesse, bitte mahnen... ;-)
> Was macht die Platine genau?
>
> Gruss,
> Stefan

Hallo Stefan,

ja so genau kann ich es nicht sagen.

Zur Hilfestellung lege ich die Bilder der Platine und des Steckplatzes 
bei.

Danke und Gruß

Steven

von SD (Gast)


Bewertung
0 lesenswert
nicht lesenswert
OK.
Hast du mal die Trimmer gewechselt?
Wie sieht der Fehler Scan-seitig aus?

Gruss,
Stefan

von Steven Hohmann (Gast)


Bewertung
0 lesenswert
nicht lesenswert
SD schrieb:
> OK.
> Hast du mal die Trimmer gewechselt?
> Wie sieht der Fehler Scan-seitig aus?
>
> Gruss,
> Stefan

Nein habe ich nicht.

Um es kurz zu beschreiben.
Diese Platine hat ein wenig gequalmt, nachdem diese kurz zuviel Strom 
bekommen hat. (Hoffe das ein Platinen wechsel reicht.)

Nach der Fehlerbehebung war soweit alles i.O.
Bild bekommen.
Scharf stellen (Fokussieren) des Objektes funktioniert nicht mehr, 
bekommen falschen WD angzeigt.
Das Wobble schaltet sich nach Tastendruck nicht ein.

Gruss
Steven

von Gustl B. (-gb-)


Bewertung
0 lesenswert
nicht lesenswert
Es ist an der Zeit das ganze mal in ein FPGA zu stopfen und als OpenREM 
zu veröffentlichen (-:

von Harald W. (wilhelms)


Bewertung
0 lesenswert
nicht lesenswert
Gustl B. schrieb:

> Es ist an der Zeit das ganze mal in ein FPGA zu stopfen und als OpenREM
> zu veröffentlichen (-:

Ein open EM ist nichts besonderes. Das hat man immer,
wenn man die Proben wechselt. :-)

von Steven Hohmann (Gast)


Bewertung
0 lesenswert
nicht lesenswert
SD schrieb:
> OK.
> Hast du mal die Trimmer gewechselt?
> Wie sieht der Fehler Scan-seitig aus?
>
> Gruss,
> Stefan

Hallo Stefan,

hier mal meine E-mail Adresse: sh252117@gmail.com.

Kannst dich ja darüber melden und wir tauschen uns darüber weiter aus.

Gruss
Steven

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.