www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit DMA beim dsPIC33


Autor: Jens Großmann (Firma: fa. Seuffer) (willi-helmchen)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hy Leute,
hab mal wieder Probleme beim Compailieren und komm nicht weiter.
Hab mir gerade versucht ein kleines Programm zu striken welches mir 
Daten direkt aus dem Ram mittels DMA in das PWM Modul schreibt.
Habt dann mal den original Programmiervorschlag des Herstellers 
umsetzten wollen und Pustekuchen das lässt sich nicht builten.
ich bekomme immer die Fehlermeldung "Argument to __builtin_dmaoffset() 
is not the adress of an object in a dma section"

Hab auch schon einiges versucht bekomm die Meldung aber nicht weg.
Kann mir jemand weiterhelfen??

P.S.
Arbeite mit MPLAB IDE v7.6 und Microchip C30 Toolsuite

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.