www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Rätselhafter Reset


Autor: Jonny Obivan (-geo-)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

Ich habe folgendes Problem: Ich steure mit einem ATtiny45 als PWM Quelle 
über einen BUZ11 einen Getriebemotor an. Das klappt auch alles scheinbar 
ganz gut. Wenn ich jedoch den Motor während dem Betrieb kurz abklemme, 
resettet (bzw. der Timer fängt an neu zu zählen) der µC. Auch während 
dem Betrieb steigt der µC ab und zu aus unerklärlichem Grund aus. Wenn 
ich eine kleine Lampe anschließe geht alles gut. Es scheint also mit der 
großen induktiven Last zusammenzuhängen. Ich habe daher eine 
entsprechende Freilaufdiode parallel zum Motor angeschlossen – leider 
ohne rechten Erfolg. Könnte es sein, dass es sich um eine 
elektromagnetische Störung handelt, oder aber der Motor irgendeinen 
Dreck in die Versorgung speist?. Können Störungen auch über das Gate zum 
µC gelangen, oder ist die Störung über die Versorgung wahrscheinlicher? 
Der Spannungsregler wird zusätzlich noch mit einem Kondensator 
gepuffert. Die 12V Quelle ist sehr leistungsstark und bricht nicht 
zusammen.

Gruß
geo

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo sind die Abblockkondensatoren?

Autor: Jonny Obivan (-geo-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

parallel zum Motor befindet sich ein Keramik - C. Muss da was Dickeres 
drann?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dicker C in die Versorgung vom Motor!
Und 100n an uC, an den 7805, etc...

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie groß? Und warum parallel zum Motor? An die Versorgungsanschlüsse vom 
Controller gehört der. Und zwar direkt dran. Über Motor und FET noch 
einen dicken Elko zusätzlich.

Autor: Jonny Obivan (-geo-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
am µc habe ich nur 1n drann. Ich werde mal den 1N vergrößern und 
parallel zum Motor einen 470µF Elko klemmen.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jonny Obivan wrote:
> am µc habe ich nur 1n drann. Ich werde mal den 1N vergrößern und
> parallel zum Motor einen 470µF Elko klemmen.
1nF meinst Du sicherlich, oder? OK, den hättest Du auch ganz weglassen 
können, hätte keinen nennenswerten Unterschied gemacht... 100 nF an die 
Versorgung vom µC (Keramik Vielschicht), an Motor und FET auch nen 
Keramik (bissl größer, z.B. 470 nF) und einen Elko parallel (da Du nicht 
schreibst, wie viel Strom der Motor zieht, kann man nichts Genaues 
sagen, aber 100 µF sollten es da ruhig sein).

Autor: Jonny Obivan (-geo-)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So habe noch mal ausprobiert:

Nachdem ich nun einen 470µF Kondensator parallel zum Motor habe gibt es 
keine Probleme mehr. Den 1nF am µC habe ich auf 100nF erhöht.

Also danke nochmal für die Hilfe :)))

Grüße
geo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.