www.mikrocontroller.net

Forum: PC-Programmierung Excel Makro-2Spalten 2er Dateien vergleichen


Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bräuchte Hilfe bei einem Makro. Die Aufgabe ist folgende:

in Datei "Info" stehen in Spalte E Zahlen
in Datei "Zusatz" stehen in Spalte A Zahlen

stimmen nun die Zahlen einer bestimten Zelle von "Info" mit "Zusatz" 
überein soll in "Info" Spalte L der Text -Nummer i.O.- eingetragen 
werden.

Wenn es einfacher wird kann ich auch eine Datei mit 2 Datenblätter ( 1x 
Info und 1x Zusatz ) daraus machen.

Danke im Vorrauß
Gruß
Mike

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dazu ist noch nicht einmal ein Makro notwendig,
in Zelle L1 trägst Du

=WENN(E1=[Zusatz.xls]Tabelle1!$A$1;"Nummer i.O.";"")

ein und ziehst die Formel dann für die betreffenden Zellen nach unten.

MfG

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Edit:

=WENN(E1=[Zusatz.xls]Tabelle1!A1;"Nummer i.O.";"")

ist natürlich richtig (relativer Zellbezug), und den richtigen Namen des 
betreffenden Tabellenblatts (im Bsp. "Tabelle1") verwenden.

MfG

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.