www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Interrupt wird nicht ausgelöst


Autor: J. K. (rooot)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich möche einen mit einem MEGA16 einen 1sek Interrupt auslösen.

Dazu verwende ich den Timer1 mit Prescale 1024. Betrieben wird er mit 
16MHz.

Ich programmiere mit AVR Studio und GCC plugin.

Eigentlich glaub ich zu wissen wie dieser funtioniert, der Interrupt 
wird aber nicht ausgelöst.

Kann jemand kurz über den Code drüberlesen? Ist sicher blöder 
Anfängerfehler.

mfg
J.K

Autor: J. K. (rooot)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klarer Fall:

// Timer(s)/Counter(s) Interrupt(s) initialization
TIMSK=0x04;

fehlt

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.