www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRStudio: extern Quarz beim Mega16


Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute, habe mich seit heute morgen durch das archiv gequält aber
nicht so richtig was gefunden.
Wo muß ich beim avr studio das häcken setzen, um optimal meinen
externen 8mhz quarz (kein oszi) zum laufen zu bringen beim mega 16?
wie ist das mit den ganze wartezeiten, die da aufgelistet werden, und
was ist mit lowfrequenz-highfrequenz gemeint?

über ein snapshot oder die genaue zeile(n) wäre ich sehr dankbar.

Gruß Manuel

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die folgenden Einstellungen passen für den ATmega8, sollten also für den
ATmega16 auch passen:

http://www.mikrocontroller.net/images/atmega8-nachher.png

Neben der Umschaltung auf externen Quarz wird hier übrigens auch der
Brown-Out-Schutz eingeschaltet und die Startzeit auf das Maximum
gestellt.

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lieb gemeint, kenne ich auch schon.
daher war mein erster versuch ponyprog mit meinem avr  isp (das teil
von   atmel direkt, klein, grau und rechteckig) zum laufen zu bringen -
leider  ohne erfolg

nur das studio läuft - aber da sieht es anders aus und leider ist da
absolut kein rückschluß zu den ponyprog-einstellungen zu erkennen...


Gruß Manuel

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
leute, will mir denn keiner helfen?

und worin liegt der vorteil die startzeit auf ein maximum zu setzen?

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also bei meinem mega16 funktioniert die kombination ponyprog + andreas'
fusebits

Autor: wolli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Datenblatt lesen, da steht alles über die Fuses drin.

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
aber dran denken, wenn irgendwo steht das ein Fuse-Bit
gesetzt ist, bedeutet es, das Bit ist Null.
Das steht zwar auch im Datenblatt, aber man übersieht es leicht.
Gruß,
Arno

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@martin nur leider kann ich mit meinem avr isp ponyprog nicht zum laufen

bringen...

@wolli bitte nicht das forum vollspammen. wenn ich mit einem blick ins
datenblatt mein problem lösen könnte, hätte ich hier nicht geschrieben

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Manuel,
klick im Studio4 mal auf "Help", dann auf "AVR Tools User Guide".
dann erscheinen alle möglichen Tools, suche nach "AVRISP" und
klicke dort auf "User Guide".
Scrolle dort ganz nach unten und klicke auf
"AVR Studio Software Front-end".
Suche darin nach  "Fuses" Settings und lese dir das alles mal
in Ruhe durch.
Dort findest du auch deine gewünschten "snapshots".
Ich hoffe, ich konnte dir etwas helfen.

Gruß,
Arno

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich hab avr 4.04 build 196 und da gibts nichts konkretes, sondern
nur allgemeine bedienung...

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nunja dann eben nicht, noch ein kleiner Tipp,
man kann die neueste Version auf der Atmel Seite kostenlos
herunterladen und da gibt es auch ein Servicepack dazu.
Gruß,
Arno

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.