www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Befehl 'Input' in Bascom


Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich hab mir mit Bascom aus Bascom das kleine Testprogramm 'input.bas'
auf meinen uc geladen.
Der Befehl Print funktioniert einwandfrei. Wenn jedoch der Befehl Input
an die Reihe kommt siehts etwa so aus:

Programmausschnitt:
Input "Eingabe: " , i

Ansicht auf dem Terminal:

Eingabe: Ee: Ee: Ee: usw....


Das programm stürtzt nach einem input Befehl auch ab..
Das proggie hab ich jedoch schon aufm atmega16 udn einem atmega162
probiert-exakt dasselbe Problem. Ich hab auch schon mit zwei compilern
experimentiert bascom 1.11.7.3 und 1.11.7.4
...wieder genau das gleiche. Aber ich habe immerhin herausgefunden von
vo die Ee: kommen. Das sind immer der erste und die drei letzten
zeichen im prompt. bei mir eben Ee: Hat dieses Problem auch schon
jemand gehabt? Ich kann mir das ganze besonders desshalb nicht
erklären, weil print ganz normal funktioniert...

Nik

Autor: stromi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja,
es fehlen schon ein paar infos zum programm: zb. was ist i für eine
variablenart, ist das terminal ein hyperterminal vom pc? usw.
poste mal etwas genaues.
mfg

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Also i ist ein String.
Ich hab schon drei Terminals ausprobiert. Das interne in Bascom,
welches nicht mal print ausgaben anzeigen, dasselbe auch mit
hyperterminal. Doch mit dem dritten, einem kleinen organizer hats
funktioniert.(print jedenfalls, input eben nicht)
 Dort hab ich die EInstellugen:

19200 Baud
handshaking: xon/xoff
Local Echo: off

MFG Nik

P.s. der organuier ist übrigens ein zq-750m von sharp

Autor: stromi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dim I As String * 1


              Input "Eingabe: " , I

              Print I
habe ich mal im bascom-simu laufen lassen, das funzt. die terminal
einstellung : ohne jegliches protokoll im hyperterminal funzt auch,
code in proz mit 9600 baud(getestet mit 8535) geht auch.
haste ev. i nicht extra geprintet?
mfg

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie meinst du exrtra geprinted? muss man dass?
Ich möchte das eingegebene nachher eben über s' netzwerk verschicken.
Empfangen geht und anzeigen auch. Muss man das denn extra nochmals
printen, damit das programm nicht abstürtzt?

Nik

Autor: stromi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
wenn die eingabe, das i, im terminal zu sehen sein soll muss es mit
einem printbefehl wieder raus geschickt werden. ich vermute mal durch
die falsche parameter im terminaleinstellung wird der erste- und der
letzte buchstabe von E..ingab..e dargestellt stell mal baudrate, 8 bit
und kein protokoll ein, auch kein x-off.
im anhang kannst du mein simulatorausdruck als jpg-bild sehen.
mfg

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, ja dargestellt werde nsoll es eigentlich nicht wider.
Ich versuch das mal alles richtig einzustellen...
Ich bin mir jedoch nicht ganz sicher wie, denn ich hab da wirklich
viele optionen auf dem organzier.
Also eigentlich ist alles so wie du geschrieben hast.
Aber da bleiben mir noch die "parity options"
dabei hab ich nun none eingestellt. Aber es gäbe noc eve, odd, high,
low. Soll ich none lassen, oder was anderes nehemen?
Merkwürdig ist, das es bei normalen string befehlen funktioniert. Doch
input ist ja eigentlich genau dasselbe, der controller wartet nachher
einfach noch auf eine Eingabe...

Nik

Autor: stromi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
non würde ich einstellen und gerade parität 8 bit, kein handshake.
mfg

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi!

Danke das du mir versucht hast zu helfen, nur leider geht's immer noch
nicht. Stelle ich die Pärität nämlich auf gerade(even) dann zeigt das
Terminal nur noch wirre zeichen an...
Ich werd mir wohl eine andere Eingabe methode einfallen lassen
müssen..trotzdem vielen Dank.

MFG Nik

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

mit dem Befehl "Echo off" schaltest du das senden der eingabe ab.
Bitte sende mal dein ganzes Prg dann kann man vielleicht den Fehler
finden.


Mfg

Dirk

Autor: Nik Bamert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

ICh hab nun nicht meins gesendet, denn da sind keine kommentare drin
und es wäre desshalb ein bisschen unübersichtlich. Desshalb hab ich
hier mal ein ein bisschen abgeändertes bascom gepostet, bei welchem
genau das selbe problem auftritt...ich weiss echt nicht was da noch
falsch geht.

MFG Nik

Autor: stromi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo nik
hast du das mal mit windows hyperterminal auf einem pc getestet?
ich kann im programm nichts falsches entdecken, ich denke das
terminalprogramm ist falsch eingestell oder die baudrate ist falsch
?????
mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.