www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ethernet an einem Atmega


Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte einen Atmega an Ethernet anschließen. Es gibt ja verschiedene 
Ansätze: WIZ-Module, ENC, RTL8019.

Jetzt mal grob gefragt, welche Lösung ist die einfachste, um am 
schnellsten ans Ziel zu kommen? Was habt/würdet Ihr so favorisieren?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Softwareseitig am einfachsten: WIZ. Ist aber eingeschränkt auf 4 
Sockets. Wenn Strom zählt ist der ENC draussen, denn der RTL braucht 
zwar mehr Platz und mehr Pins aber nur ein Bruchteil an Strom.

Autor: Pete K. (pete77)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RTFF (read the f*ing) forum :-)

Der ENC scheint sehr beliebt zu sein.

Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>> RTFF (read the f*ing) forum :-)

Habe ich, danke für den Hinweis :-)

WIZ: 4 Sockets passen, sollte sowieso nicht multiclientfähig werden.
ENC: Habe noch reichlich Strom in meinen Steckdosen :)
RTL: Stimmt RTL hat wie ich gesehen habe einen ISA Bus.

Ok, danke, werde mir den WIZ anschauen.

Autor: MartinH (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem Wiz gehen auch beliebig viele Sockets..
Socket 0 kann man glaub ich auf RAW MAC schalten.. aber dann muss man 
den restlichen TCP/IP Stack natuerlich wieder  per Software 
implementieren

Autor: Andreas Watterott (andreasw) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt auch noch den CP2200 von Silabs und als WIZnet Alternative den 
XPort von Lantronix.

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Wiznet kann 8 gleichzeitige Verbindungen.
4 gingen nur mit dem alten Modul.

Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Dirk: Hast du SPI Interface benutzt oder das parallele Interface? Wie 
schnell kann ich Daten über SPI übertragen, wenn der Atmega bei 16MHz 
läuft?

Autor: Rik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ATmega32 + RTL8019AS + uIP-0.9 funktioniert ganz hervorragend

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.