www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Connecting STK 500


Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte meinen µC einmal bepacken.
ich hab ein STK500 und drücke im AVR Studio "Connect" und dann öffnet 
sich ein Fenster mit Fuses, etc und wenn ich zw. den karteikarten 
wechsle kommt folgende fehlermeldung unten:
Entering programming mode.. FAILED!
Leaving programming mode.. OK!

Was hab ich falsch gemacht?

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dein STK kann den AVR nicht programmieren, genauer: kann den reset nicht 
ziehen.
ist der isp anschluss vom avr auch mit dem isp des stk verbunden? ist 
der avr richtig rum im richtigen sockel? stimmt die target-spannung? 
usw...
findet sich eigentlich alles in der bedienungsanleitung des STK.

Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab ja keine bedienungsanleitung!

Autor: Christian Erker (DL3CE) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast das AVR-Studio, also hast du auch eine Bedienungsanleitung.
In der Hilfe des AVR-Studio sind die Anleitungen sämtlicher 
Entwicklungstools enthalten.

Gruß,
Christian

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uff wrote:
> Ich hab ja keine bedienungsanleitung!
und ich soll das riechen? gibts btw auf der atmel-hp

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine gedruckte Bedienungsanleitung liegt dem STK500 ebenfalls bei und 
ist in dieser Form auch online zu beziehen.

Autor: Freizeitbastler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Eine gedruckte Bedienungsanleitung liegt dem STK500 ebenfalls bei und
ist in dieser Form auch online zu beziehen."

Mein neues STK500 ist diese Woche geliefert worden. An Dokumentation 
waren nur eine DVD und ein gedrucktes A4-Blatt dabei.

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh mei... naja Doku ist halt das erste woran man sparen will, schade 
eigentlich. Aber ich bin mir sicher dass das Zeug dann mindestens als 
Online-Doku auf der CD ist.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI

>An Dokumentation waren nur eine DVD und ein gedrucktes A4-Blatt dabei.

Also, die gedruckte Version fand ich etwas spärlich. In der 
AVR-Studio-Hilfe->AVR Tools User Guide findest du eigentlich alles. 
Sogar mir Bildern.

MfG Spess

Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also bei mir war nicht einmal das gedruckte DIN A 4 Blatt dabei. Ich hab 
mir nun den User Guide 'getting started' durchgelesen und meine alles 
richtig gemacht zu haben. Hat denn keiner eine Idee was ich noch 
ändern/überprüfen könnte?

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mach doch mal n photo von deinem aufbau in vernünftiger auflösung.

Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sollte ich mal machen. Vorher noch eine ANmerkung, habe mir den 
unteren text nach assemblieren und debuggen mal angeschaut:

C:\Users\Michael\Documents\try.asm(1): Including file 'C:\Program Files 
(x86)\Atmel\AVR Tools\AvrAssembler2\Appnotes\m8515def.inc'

C:\Users\Michael\Documents\try.asm(14): No EEPROM data, deleting 
C:\Users\Michael\Documents\try.eep


Hmm. ist da was falsch?

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
solange du nix mitm eeprom machst: nö, nix falsch

Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK alles klar. Werde dann mal auf den Photo warten und Atmel 
kontaktieren. Danke soweit

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
atmel kontaktieren??? aufs photo warten? ein photo von DEINEM aufbau 
wäre gefragt.
junge, der fehler liegt bei dir... ich lasses gutsein...

Autor: Uff (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
natürlich liegt der fehler bei mir. Da in meinem PC kein kartenleser 
integriert ist werde ich auf meinen Vater warten, der mir dann das Photo 
von meinem Aufbau schickt.

Um die zeit sinnvoll zu nutzen wollte ich auch noch Atmel kontaktieren, 
ob die mir eventuell einen Lösungsansatz bieten können. Ob sie nun 
antworten oder nicht, einen versuch ist's wert.

Was ich mit einem Photo von atmel sollte, wüsste ich jetzt nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.