www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Hilfe!! mein PC erkennt µController nicht


Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich will eine Controller AT90LS4433 über die paralele Schnittstelle
programieren.
Es hat auch schon funktioniert, dann habe ich das Windows XP neu
installiert und jetzt erkennt Jaap den Controller nicht mehr.
Bitte helft mir, denn ich bin neuling(14) auf diesem Gebiet.
MFG Beni

Autor: Frank Linde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Windows XP hast Du keinen direkten Zugriff auf die Schnittstellen
mehr. Es gibt aber spezielle Treiber, die das Betriebssystem
austricksen. Da ich die noch nicht gebraucht habe, kann ich Dir auch
keinen Namen nennen. Vielleicht mal mit "direct port access" oder so
unseren Freund Google bemühen.

Gruß, Frank

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Frank

Ich hatte zuvor auch schon XP installiert,und der Controller wurde
erkannt.

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das nennt sich bei MS dann "mehr Sicherheit" oder so,
bis garnix mehr geht.  :-)

Gruß,
Arno

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Arno
kann es sein das irgend etwas an meiner isp programierschnitstelle oder
Contoller defekt ist. Kann ich das prüfen'?

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Beni,

leider habe ich kein XP, aber hast du mal versucht Jaap
neu zu installieren?

Wenn es schon mal gelaufen ist sollte es auch wieder
hinzubekommen sein.
Die parallel-Schnittstelle ist etwas empfindlich was
Kurzschlüsse anbelangt, wenn da nichts dergleiche war sollte
sie aber noch gehen.
Testen kannst du das ja mit einem Drucker, wenn der funktioniert
ist sie OK.

Gruß,
Arno

Autor: Dennis Brücke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi Beni,

schau doch mal auf Rowald.de da findest du das Programm twinAVR, dort
ist unter anderem auch ein PortIO Driver dabei. Das es bei die vorher
funktioniert hat, kann es auch sein, das irgendein Programm evtl. so
einen Treiber installiert hat. (Aus welchen gründen auch immer)

Aber Ohne eine PortIO Driver geht es definitiv nicht unter WindowsXP,
auser Programme die soetwas gleich mit sich bringen.

Gruß Dennis

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den PortIO TReiber installiert und es funkt immer noch nicht.
giebt es keine andere möglichkeit Den paralelport zu testen???

Autor: Dennis Brücke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm...

Also ich würde jetzt einfach um den LPT zu testn (fallst du befürchtest
das der hin ist) einfach mal nen drucker anschliessen... und den
flashen... aehm meinte drucken ;)

Sollte das gehen, kann es am ISP liegen... muss aber nicht... fern
diagnose ist halt schwer... hast du ein osszi da ??

Wenn nicht sehen die chancen zum testen schon wieder schlecht aus...
bleibt nur noch die manuelle variante... stecker auf machen schauen ob
alle kabel korrekt sind...

Am besten Doppelt schauen...

Gruß Dennis

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Drucker hat einen USB anschluss und einer mit parallel Port ist
nicht reichweite.
Wie gesagt ich bin erst 14 und habe noch keine vollausgerüstete
Elektroniker Werkstatt, deshalb habe ich auch noch kein Oszi.
Ich habe alle verbindungen mehrmal kontroliert.

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Beni,
hast du Jaap mal neu installiet ?

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ,funktioniert aber immer noch nicht

Autor: Dennis Brücke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm...

dann weis ich es auch nicht mehr, es sei den du wohnst in Berlin /
Umgebung...


sorry

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den rechner nach der Installation neu gebootet ?

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja!

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein ich wohn in Bayern lankreis Tirschenreuth (Mähring)

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welchen ISP-Programmer benutzt du?

Autor: Johannes Raschke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst einfach mal eine LED an die Datenleitungen des Parallelports
halten und per Software ein paar Bitmuster ausgeben lassen... Unter DOS
geht das mit dem Programm debug (o 0x378), oder Du programmierst Dir
sonstwie ein Program, was ein Datenbyte augibt...Die Steuerregister
(für die Strobe-Leitung etc.) liegt bei 0x379, wenn ich mich recht
erinnere.

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Programmer aus dem AVR Kurs .

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Beni,

wenn es der Programmer mit dem 74HCT244 ist, kann man wohl
davon ausgehen, dass der Parallelport deines Rechners nicht
kaputt ist.

Schau nochmal nach ob in Jaap alles richtig eingestellt ist.
Eventuell hilft es ja auch wenn du einfach mal einen Druckertreiber
für einen Parallelport-Drucker installierst.
Ich würde dir ja gerne helfen.
Leider kenne ich mich mit Windoof-XP nicht aus und kann dir
daher auch nicht sagen was du machen musst, damit es mit XP
wieder läuft.

Gruß,
Arno

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke
ich habe den Programmer mit dem 74HCT244 .
Ich probier das mit dem Druckertreiber mal aus.
mfg Beni

Autor: Conlost (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der programmer ist doch kompatibel mit Ponyprog.
Versuche es mal mit Ponyprog, vielleicht geht es ja damit.

Gruß,
Arno

Autor: Beni (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pony Prog meldet mir wenn ich Den Controller programieren möchte:Device
missing or unknown Device!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.