www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 2333: UART empfängt nichts?!?


Autor: Matthias Larisch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Wenn ich von meinem PC aus übers UART Daten an den 2333 schicke,
empfängt er nichts... Ich habe das mit mehreren Programmen
ausgetestet.
Senden funktioniert einwandfrei.
Dachte ich, klar, vielleicht ein Draht nicht dran...
Fehlanzeige. Alles genau wie im UART-Tutorial beschrieben.

Ich hab sogar 5V am RX-Pin des AVR's. Leider kein Oszi, also k.A. ob
sich da was tut. Am RX-IN vom MAX232 tut sich jedoch was, laut
Digitalmultimeter im Gleichstrombereich steigt die Spannung bei
Aktivität um ca. 0,05V. (von -11,40 auf -11,35 oder so...).
Ich habe auch schon mehrere Terminalprogramme ausprobiert.

Anfangs hatte ich die Stromversorgung des Max232 vergessen, da hat der
Mikrocontroller auf jedenfall was gehört, denn er hat mir die ganze
Zeit einprogrammierte Fehlermeldungen geschickt. Nur seitdem der MAX
Strom hat, läuft da nichts mehr...
Wisst ihr, was eventuell falsch sein könnte?
danke
cu
Matze

Autor: Matthias Larisch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Das Problem hat sich eben zumindest teilweise gelöst. An ALLEN Rechnern
bis auf an meinem und an dem von meinem Vater (gleiches Motherboard:
ASRock K7VT2) funktioniert das UART ohne Probleme. Nur das bringt mir
nichts, denn es soll eine Lüftersteuerung für meinen PC werden...
Wie kann ich denn trotzdem den µC von meinem PC aus ansteuern? Ich
möchte so wenig wie möglich Softwareaufwand, da mein Programmspeicher
nahezu voll ist.
danke
cu
Matze

Autor: Matthias Larisch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So Problem gelöst ;-)
Ich muss mir wohl mal den Ausgangstreiber aufem Motherboard zerschossen
haben --->> Nun an Pin 15 des GD75232 TTL<->RS232 Converters das TTL-TX
Signal abgegriffen und schon gehts ;-)
bye
Matze

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.