www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LCD Modul Blau 240x64 Hintergrund LED flackert


Autor: Michael S. (mpc2500)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

An alle Freaks im Elektronicbereich.

Ich bin Musiker und habe mir vor ein Paar Wochen ein neues blaues 
Display für meinen Sampler eingebaut (siehe Foto - orig.Display war 
grün)

Der Einbau war problemlos und das Display lief bis dahin ohne Probleme.
Nach 4 Wochen begann das flackern der LEDs

Liegt es evtl an der falschen Spannung der LEDs ?
Hier das Sheet des blauen Displ. mit weißer Hintergrundbeleuchtung

http://www.displaytech.com.hk/pdf/graphic/64240b%2...

Und hier das orig. Displ.

http://www.diamondhmi.co.uk/ModPDFs/WG24064J.PDF

Sind die LEDs nun defekt? oder gibt es ne Möglichkeit mit Hilfe eines 
Widerstandes sie wieder zum Leben zu erwecken?
Und wo wird er eingebaut ?

Kalte Lötstellen wurden schon ausgeschlossen. Alle 22 Kontakte wurden 
korrekt verlötet.

Danke schon vorweg im vorraus

Gruß
Michel

Autor: Chris L. (kingkernel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entsteht das Flackern erst im Display oder schon in der 
Versorgungsspannung zum Display?

Hast du mal versucht, probeweise das alte Display wieder einzulöten?
Die Kalte lötstelle muss nicht an der Verbindung zum Display liegen, 
sondern irgendwo anderst auf den Platinen.

Du könntest auch einen Elko an die Versorgungsspannung der LED's löten, 
der das Flackern dann überbrückt.

Autor: Michael S. (mpc2500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christian L. wrote:
> Entsteht das Flackern erst im Display oder schon in der
> Versorgungsspannung zum Display?
>
> Hast du mal versucht, probeweise das alte Display wieder einzulöten?
> Die Kalte lötstelle muss nicht an der Verbindung zum Display liegen,
> sondern irgendwo anderst auf den Platinen.
>
> Du könntest auch einen Elko an die Versorgungsspannung der LED's löten,
> der das Flackern dann überbrückt.

Hallo

Das Flackern entsteht im Display. Orig. Display ist ok.
Wie geschrieben. 4 Wochen war es ok, erst dann fing es an.

Bitte mal die Sheets überprüfen. Evtl ist das Display überhaupt nich 
geeignet. Oder das Ding hat nen Fabrik.fehler.

Bin in Elektronik ne Null. Deshalb seid Ihr gefragt.
Welchen Elko nehm ich ?

LG

Autor: Chris D. (m8nix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn nur der Hintergrund flackert, die Anzeige dennoch schwach zu 
erkennen ist, dann könnte der Inverter für die Hintergrundbeleuchtung 
defekt sein. Entweder ist dieser seperat verbaut, oder er ist im Display 
integriert. Im letzteren Fall würd ich das Display zurücksenden und auf 
Ersatz pochen.

Gruss Chris

Autor: fubu1000 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
könnte schon sein das die LEDs langsam ihren Geist aufgeben.
Weil laut Datenblatt brauchen die Leds der weissen 
Hintergrungbeleuchtung 3,4 Volt und 40mA.
Die der gelb/grünen aber 4,2 Volt und 600mA.
Also das was die Backlight-Leds begrenzt (vermutlich ein Widerstand) ist 
nicht für dein neues ausgelegt gewesen.

Schade um das schöne Display und Gruß.

Autor: Jochen Müller (taschenbuch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael,

>>könnte schon sein das die LEDs langsam ihren Geist aufgeben.
Flackern ist KEIN TYPISCHES Zeichen für kaputtgehende Leds, das kannst 
Du zu 99% ausschliessen.

>>Wenn nur der Hintergrund flackert, die Anzeige dennoch schwach zu
>>erkennen ist, dann könnte der Inverter für die Hintergrundbeleuchtung
>>defekt sein.
DAS ist der Punkt.
Du hast zwar von Leds gesprochen, dann wäre die o.g. Meinung Quatsch, 
weil Leds KEINEN Inverter benötigen.

ABER:
Das Display wird ENTWEDER mit Leds ODER EL-Backlight geliefert, das geht 
doch DEUTLICH aus dem Datenblatt hervor.
Bist Du also wirklich sicher, dass Du die Version mit Leds hast?
Wenn das Foto von Dir nicht so unglaublich ungeeignet wäre, könnte man 
das sogar vielleicht sehen. Wieso sendest Du ein Bild, auf dem das 
Display (und um das geht es doch wohl) nur winzig ist? Der Rest des 
Bildes (90%) ist zur Beurteilung völlig uninteressant, das kannst Du Dir 
eigentlich auch selbst denken!

ALSO:
Flackern/Flimmern ist ein ABSOLUT TYPISCHES Zeichen für ein defektes 
EL-Backlight. Es ist KEIN TYPISCHES Zeichen für defekte Leds.

Jochen Müller

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Jochen Müller:

Du hast vergessen zu verraten, wie ein EL-Backlight mit seiner 
LED-Spannung des alten Displays zum Leuchten zu bekommen ist...

Was sein Foto angeht: meinst Du, wenn es größer wäre, wäre das Flackern 
besser zu erkennen?

Gruß aus Berlin
Michael

Autor: Michael S. (mpc2500)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
fubu1000 wrote:
> Hallo,
> könnte schon sein das die LEDs langsam ihren Geist aufgeben.
> Weil laut Datenblatt brauchen die Leds der weissen
> Hintergrungbeleuchtung 3,4 Volt und 40mA.
> Die der gelb/grünen aber 4,2 Volt und 600mA.
> Also das was die Backlight-Leds begrenzt (vermutlich ein Widerstand) ist
> nicht für dein neues ausgelegt gewesen.
>
> Schade um das schöne Display und Gruß.

Wow was für eine Anteilnahme.
Danke

Das wirds sein. 3,4V zu 4,2V :-(

Es sind definitiv LEDs eingebaut. Siehe neues besseres, schärferes zu 
90% brauchbareres Bild ;-)
Das Bild wurde vor dem Flackern aufgenommen!

Was passiert, wenn ich ein regelbares Netzteil (3,4V) an den Pins 21 und 
22 halte (Anode-Kathode)?
Nur zum Test der LEDs im ausgebauten Zustand. Evtl sollten sie ohne 
Flackern Leuchten !!??

LG

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was passiert, wenn ich ein regelbares Netzteil (3,4V) an den Pins 21 und
>22 halte (Anode-Kathode)?
>Nur zum Test der LEDs im ausgebauten Zustand. Evtl sollten sie ohne
>Flackern Leuchten !!??

Tu das nicht! Nimm 5V und einen 50 Ohm Vorwiderstand.

Das flackern könnte vom Vorwiderstand für die Beleuchtung
kommen. Statt 0.8V liegen jetzt 1.6V über ihm. Damit steigt
seine Verlustleistung. Wahrscheinlich ist der dabei sich selber
auszulöten. Wenn er das gerade geschafft hat fliesst kein
Strom mehr, die LEDs gehen aus. Dann kühlt er wieder ab
und bekommt wieder Kontakt. Die LEDs gehen wieder an und
das Spielchen wiederholt sich.

Ist nur ne Theorie ;)

Autor: S. Seegel (energizer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte mal einen ähnlichen Fall; Vorwiderstand für ein grünes Display 
dimensionert, und ein blaues Display wurde angeschlossen. Einige Wochen 
ging das gut, dann war Schluss. Also: Neues Display kaufen und Selbiges 
mit passendem Vorwiderstand einbauen (im Datenblatt sollte stehen welche 
Pins die LEDs versorgen).
>Orig. Display ist ok.
Warum wurde es dann ausgetausch ?

Autor: Michael S. (mpc2500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
S. Seegel wrote:
> Hallo,
>
> ich hatte mal einen ähnlichen Fall; Vorwiderstand für ein grünes Display
> dimensionert, und ein blaues Display wurde angeschlossen. Einige Wochen
> ging das gut, dann war Schluss. Also: Neues Display kaufen und Selbiges
> mit passendem Vorwiderstand einbauen (im Datenblatt sollte stehen welche
> Pins die LEDs versorgen).
>>Orig. Display ist ok.
> Warum wurde es dann ausgetausch ?

Das Blaue sieht schöner aus.

Wo baue ich den Vorwiderstand ein ?

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Warum wurde es dann ausgetausch ?
Weil blau "besser" aussieht.

Aber wie schon gesagt wurde, erst mal das Display extern testen.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Netzteil (+5 Volt) --> Widerstand (>40 Ohm) --> Pin 21 (Anode)

Pin 22 (Kathode) --> Netzteil Minus

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo der Widerstand ist ist natürlich egal, hauptsache in Reihe mit dem 
Display. Achte drauf, dass das Netzteil stabilisiert ist (im Leerlauf 
Spannung mit Multimeter messen) und berechne evtl. den Vorwiderstand neu 
wenn das Netzteil mehr als 5 Volt hat.

Autor: Michael S. (mpc2500)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe das Modul wieder rausgelötet und werde es mal checken.
Ne andere Frage:
Um nicht jedesmal neu löten zu müssen, suche ich schon länger die 
passenden Stecker.

Pfostenstecker 24Pol
Leiterplatenverbinder 24Pol
Siehe Foto

Ich habe schon überall im Netz gesucht. Aber als Endverbraucher kommt 
man nicht an die Dinger ran.
Habt Ihr ne Idee ?
Kennt Ihr einen Shop?

Autor: mui (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
guckst du www.zeg-shop.de. die haben so was.

Autor: Klaus R. (klaus2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schrott vom Floppy oder IDE kabel nehmen?!

Klaus.

Autor: Michael S. (mpc2500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mui wrote:
> guckst du www.zeg-shop.de. die haben so was.

Danke
Ich glaube Die haben das was ich suche.
Nur leider ohne Abbildung.

Autor: Michael S. (mpc2500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klaus R. wrote:
> Schrott vom Floppy oder IDE kabel nehmen?!
>
> Klaus.

Kabel hab ich genug. Kein Thema
Es geht mir alleine um die Stecker.

Autor: Michael S. (mpc2500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael S. wrote:
> mui wrote:
>> guckst du www.zeg-shop.de. die haben so was.
>
> Danke
> Ich glaube Die haben das was ich suche.
> Nur leider ohne Abbildung.

Doch nicht ganz.
Pfannenverbinder 25Pol ist ok
Leiterplattenverbinder, das sind nur die Stiftleisten. Hab ich selber
Was ich benötige, ist der kompl Stecker 24Pol zum auflöten auf die 
Platine. Diesen hat der Shop nicht.

Autor: Hebby (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Du hast vergessen zu verraten, wie ein EL-Backlight mit seiner
>>LED-Spannung des alten Displays zum Leuchten zu bekommen ist...
Das kannst Du Dir eigentlich selbst zusammenreimen. Wenn der FL-Inverter 
on-board ist, läuft der bei vielen Displays mit 5V damit er kompatibel 
mit LED-Ausführungen ist. Bei praktisch allen von uns hier verwendeten 
Displays ist das der Fall.

>>Was sein Foto angeht: meinst Du, wenn es größer wäre, wäre das Flackern
>>besser zu erkennen?
Oft kann man an der Lichtverteilung sehr gut erkennen, ob es sich um LED 
oder FL-Beleuchtung handelt. Ein Bild von der Rückseite des Display 
hätte dann endgültig Klarheit geschafft ob es sich um LED oder FL Licht 
handelt.
Das scheint aber ja offenbar mittlerweile geklärt zu sein. Angeblich 
sind es ja nun LEDs. Obwohl das Fehlerbild für defekte FL eigentlich 
100% typisch ist...

Ich halte die bisherigen Tipps dennoch für totalen Quatsch, kein Mensch 
der jemals ernsthaft mit LEDS gearbeitet hat, würde behaupten dass LED 
bei zu hohem Strom flackern oder flimmern. Das ist einfach dämlicher 
Unsinn. Warum ist es Euch so dermassen wichtig, den OP auf den Holzweg 
zu führen, was soll das? Ist das Schikane oder was?

Zu 100% liegt die Ursache woanders, garantiert wird der OP das später 
auch merken. Leider erst NACHDEM er die völlig sinnlosen Ratschläge hier 
aufwändg befolgt hat. Er kann ja dann mal berichten.
Nochmal: KEINE Led flackert bei Überstrom, das ist DUMMSINN!

Herbert

Autor: mui (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
such mal nach "wannenstecker"...da gibt's die dinger...allerdings nur 
26-polig. vllt gehts ja 2 stifte abzuschneiden und nicht einzulöten?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.