www.mikrocontroller.net

Forum: PC Hard- und Software USB Brenner einer VM bereitstellen


Autor: wegdamit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

An alle Linux-Leute:

Ich habe folgenden Befehl eingegeben:
root@juergen-laptop:~/Desktop/vmware-server-distrib# lsusb

und folgendes kam raus:

Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 005: ID 0403:6001 Future Technology Devices 
International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 004: ID 046d:c50e Logitech, Inc. MX-1000 Cordless Mouse 
Receiver
Bus 001 Device 001: ID 0000:0000


Ich möchte das Gerät
"Bus 001 Device 005: ID 0403:6001 Future Technology Devices 
International, Ltd FT232 USB-Serial (UART) IC"

einer VM bereitstellen.

Aufbau des Systems:

Host ist Ubuntu 8.04
Gast ist XP pro
Benutzt wird VMWare-Server

Wie mach ich das?

Danke für eure Hilfe

Autor: wegdamit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Will mir keiner helfen oder muss ich die Frage umformulieren?

Autor: ozo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nutze eine ähnliche Konstellation - gentoo als Host, XP oder andere 
als Gast. Allerdings hab ich auf meinem Rechner nur den freien vmplayer. 
Der zeigt die USB Geräte unter der Titelleiste der laufenden VM an, 
draufklicken und schon kann das Gastsystem drauf zugreifen.
Unter vmserver sollte es ähnlich gehen, wobei - guckst du hier:
http://forum.ubuntuusers.de/topic/keine-usb-geraet...

Autor: wegdamit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geil, es funktioniert.

Danke für den Link.

Thread geschlossen

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche VMware-Server-Version benutzt du denn?

Unter 2.0 wählst du im VMware Infrastructure Web Access die betreffende 
Maschine aus und klickst dann Add Hardware. Dort kannst du dann den 
USB-Controller zufügen, falls der noch fehlt und ein CD-Laufwerk.

Ob du allerdings aus der VM heraus auch auf den Recorder schreiben 
kannst, weiß ich nicht. VirtualPC z.B. kann es nicht, während es von 
VMware Workstation 5 und 6 unterstützt wird.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der "USB-Brenner" ist in diesem Falle ein USB-Programmiergerät, kein 
CD-Brenner an einer USB-IDE-Bridge. Aber auch solche Geräte können unter 
VMWare genutzt werden. Problematisch werden nur Geräte, die isochrone 
Datenübertragung nutzen, Videokameras und dergleichen.

Autor: wegdamit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jepp, das hast Du richtig gesehen.
Es ist ein USB-Programmiergerät.

Ich verwende VMWare-Server 1.7

Wenn ich folgende zwei Zeilen eingebe funktioniert es:

-->sudo mount -t usbfs none /proc/bus/usb
-->sudo /etc/init.d/vmware restart

Allerdings, wenn ich den Rechner neu starte muss ich die Zeilen erneut 
eingeben.

Kann ich das irgendwie bei jedem Start automatisch machen lassen?

Was mach ich mit denn Zeilen überhaupt?

Ich weis für euch werden die Fragen recht simpel klingen, ich aber bin 
ein echter Neuling was Ubuntu und überhaupt Linux angeht.
Bin erst seit drei Wochen nüchtern was Windows angeht. :-)

Danke für eure Geduld und Antworten.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wegdamit wrote:
> -->sudo mount -t usbfs none /proc/bus/usb

Montiert usbfs auf /proc/bus/usb

> -->sudo /etc/init.d/vmware restart

Startet den VMware Server neu

sudo führt den folgenden Befehl mit root-Privilegien aus.

usbfs ist ein virtuelles Dateisystem, das den usb-Bus repräsentiert. 
Näheres z.B. hier: http://de.wikipedia.org/wiki/Dateisystem und dann 
nach usbfs suchen.

Du kannst die Kommandos auch automatisch ausführen lassen, indem du sie 
in /etc/rc.local einträgst.

/etc/rc.local mußt du mit root-Privilegien editieren. Das geht z.B., 
indem du in einem Konsolfenster

   sudo vim /etc/rc.local

aufrufst. (Du kannst auch ganz auf root wechseln, indem du sudo ohne 
Parameter aufrufst. Nach der Paßwortabfrage bist du root.)

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
Wenn du die beiden Befehle in /etc/rc.local einträgst, kannst du das 
sudo weglassen. /etc/rc.local wird als root ausgeführt.

Autor: Sweet Home Alabama (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Besser wäre es, wenn du das in deine /etc/fstab einträgst:

none /proc/bus/usb usbfs 
auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0
(in einer Zeile)
(busgid und devgid eventuell anpassen)

Dann kannst du dir auch das vmware restart sparen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.