www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit PCF8591: immer Wert 128


Autor: Philipp __ (sand)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem mit PCF8591

Wir haben einen PCF8591 wie folg beschaltet (XXX_I2C sind die Pins vom 
I2C-Bus):
AIN1 für Testzwecke auf verschiedene Spannungen von 0-5V
AIN0,AIN2,AIN3 nicht verbunden
A0=A1=A2=VSS=AGND=GND_I2C
SCL=SCL_I2C
SDA=SDA_I2C
VDD=VREF=5V (gegen VSS und damit auch gegen AGND! [siehe oben])

leider liefert der Baustein immer den Wert 128, egal welche Spannung an 
welchem der analogen Pins angelegt wurde.

Vielen Dank!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.