www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik WheatstoneBrücke mit Instrumentenverstärker Kalibrierung


Autor: Michael (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Wie im Anhang zu sehen habe ich eine WheatstoneBrücke an einen 
Instrumentenverstärker gehängt.
Wobei die Wheatstonebrücke aus 4 Dehnmessstreifen besteht, welche auf 
einem Rohr mal längs (Rx) mal quer (R4) aufgeklebt sind.

Nun verhält sich das ganze nicht ganz so, wie ich mir das vorgestellt 
habe.
Und zwar kommt für Ua bei einem unberührten Stab schon -0,8V raus.
Wie kann ich die Schaltung nun am Besten kalibrieren...

Ich hatte da an eine Veränderung von R5 gegenüber R6 gedacht. (Beide 
sind eigentlich gleich groß)


Ist das Pfusch bzw. gibt es eine andere/bessere Lösung des Problems?



Gruß
Michael

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder einfach vor Ue1 n Poti hängen?

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Op mit geringerer Offset-Spannung läßt die Sache besser aussehen.

Steck mal was pinkomptibles (z.B. OP227), dann ist Ua wesnlich geringer 
im unbelasteten DMS-Fall.

Ansonsten hilft nur Null-Abgleich Poti, wie es Du es ja selber auch 
schon vorschlägst.


hth,
Andrew

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andrew,

Ich glaube nicht, dass es am Offset der OPAmps liegt.
Denn wenn ich Ue1 mit Ue2 verbinde kommt nur sowas um die 0,03 V raus.

Ich glaube eher, dass es an nicht parallel aufgeklebten DM-Streifen 
liegt, die diese Differenz von -0,8 V hervorrufen.

Deshalb die Frage, wie ich diesen Fehler korrigieren kann.



Gruß
Michael

Autor: fast so (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Satz DMS muss nicht unbelastet ein Nullsignal liefern, denn die 4 
Streifen sind eh nicht identisch, noch identisch aufgeklebt. Heisst man 
muss eine einstellbare Spannung subtrahieren.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
und wie stell ich das an?

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

> und wie stell ich das an?

die einfachste Möglichkeit besteht darin, daß Du diesen Wert einfach 
abziehst. Entweder mit einem µC (die einfachste Möglichkeit) oder mit 
einem OPV als Subtrahierer (Potentiometer statt Widerstand verwenden).

Ansonsten kannst Du auch mal die Application Notes durchgehen:
http://www.maxim-ic.com/appnotes.cfm/an_pk/3426


Gruß,
  Michael

Autor: Unwissender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael!

Der Abgleich erfolgt bei den unteren R3. Schau dazu diesen Link: 
http://www.elektronik-kompendium.de/public/schaere...

Das du bei keiner Berührung eine Ausgangsspannung bekommst liegt daran 
das nicht alle Widerstände gleich groß sind. Deshalb musst du einen 
Abgleich machen und das passiert bei R3.

LG
Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.