www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kann es sein, dass ich mir den ADC zerschossen habe?


Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab  gerade meine ersten Versuche mit dem ADC meines ATmega32 
gemacht.

Ich hab den Poti wie in der Basisschaltung in

http://www.mikrocontroller.net/articles/AVR-Tutorial:_ADC

angeschlossen, AREF ist gleich VCC.

Abgesehen davon, dass ich nicht gesehen habe, dass ich einen Kurzschluss 
erzeuge wenn ich den Poti in der einen Endstellung habe, habe ich 
Anfangs tatsächlich unterschiedliche Werte so zwischen 1002 und 860, 
aber nie darunter bekommen, dann ist zu viel Strom direkt über den Poti 
abgeflossen und damit ist die Betriebsspannung zusammengebrochen.

Als ich dass ganze noch mal probiert habe mit Poti (10k) so eingestellt, 
dass nur wenig Strom am Von VCC nach GND floss, habe ich auf einmal nur 
noch 0 Als Ergebnis des ADCs zurückbekommen.

Frage:

1. Kann ich dabei den ADC zerschossen haben?
2. Muss ich den Poti um den Kurzschluss zu vermeiden als Spannungsteiler 
anschließen, bzw. einfach noch nen Widerstand in Reihe schalten??

Sorry wenn das wieder mal ne typische Anfängerfrage ist.

Grüße

Tom

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> dass ich einen Kurzschluss erzeuge wenn ich den
> Poti in der einen Endstellung habe

Dann ist das Poti falsch angeschlossen.....

Der Schleifer kommt an den ADC-Eingang

Otto

Autor: Klaus2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Sorry wenn das wieder mal ne typische Anfängerfrage ist."

Das ist noch mehr als das!

Welche Spg sieht der ADC bei dir "maximal"?

-> Widerstandsteiler: Ja, was denn sonst? Andernfalls raucht das Poti 
ab.

Klaus.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Maximal sieht er 5V.

Anfänger ja, hab die Meiste Zeit bisher CPUs nur von innen gesehen.

Hmm, ja der Poti hat geraucht.

Gruß
Tom

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auweia.

Wenn das stimmt
>Ich hab den Poti wie in der Basisschaltung in
>http://www.mikrocontroller.net/articles/AVR-Tutorial:_ADC
>angeschlossen, AREF ist gleich VCC.

dann solltest Du gar keine (wesentliche) Veränderung des Stromes 
feststellen. Der sollte eigentlich relativ konstant sein.
Kontrolliere noch mal die Schaltung ganz genau. Wieviel Ohm hat das 
Poti?

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spinne wrote:
> dann solltest Du gar keine (wesentliche) Veränderung des Stromes
> feststellen. Der sollte eigentlich relativ konstant sein.
auch keine unwesentliche! und nicht relativ konstant, sondern konstant. 
der strom in den adc ist im vergleich zum strom durch den poti dermaßen 
klein, dass man ihn ohne jegliche einbußen völlig vernachlässigen kann.

@Thomas Burkhart:
du hast ganz einfach den poti falsch angeschlossen und damit deine 
versogrunggsspannung kurzgeschlossen.
mein tipp ist, dass der adc heile ist und dein poti nicht mehr brauchbar 
ist. mal ein multimeter angeschlossen?
oder hast du etwa den poti irgendwo etwas andres als deine 
betriebsspannung angeschlossen?


Spinne wrote:
> Wieviel Ohm hat das
> Poti?

Thomas Burkhart wrote:
> Als ich dass ganze noch mal probiert habe mit Poti (10k) so eingestellt,

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ :  Michael H* (-holli-)

Also jetzt mal ganz ruhig. Das ist doch wohl nicht Dein Ernst, oder?

>> dann solltest Du gar keine (wesentliche) Veränderung des Stromes
>> feststellen. Der sollte eigentlich relativ konstant sein.
>auch keine unwesentliche! und nicht relativ konstant, sondern konstant.
>der strom in den adc ist im vergleich zum strom durch den poti dermaßen
>klein, dass man ihn ohne jegliche einbußen völlig vernachlässigen kann.

Das ist, mit Verlaub, "blodes Gequatsche".

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ :  Michael H* (-holli-)

>Spinne wrote:
>> Wieviel Ohm hat das
>> Poti?

>Thomas Burkhart wrote:
>> Als ich dass ganze noch mal probiert habe mit Poti (10k) so eingestellt,

Und da sollte man nochmal lesen, denn "noch mal probiert" setzt voraus, 
das es vorher mindestens einmal probiert wurde. Und mit welchem 
Widerstand? Wo steht, das es derselbe war?

Und nochmal, mit Verlaub: Blödes Gequatsche.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dann würde mich folgendes interessieren: wo kommt denn der verlaub her?
ich muss dir widersprechen... mit was? mit recht.

aus dem datenblatt:
IACLK   Analog Comparator Input Leakage Current   min: -50 max: 50 nA

den part mit R=U/I beim poti überlass ich jetz dir.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spinne wrote:
> Und da sollte man nochmal lesen, denn "noch mal probiert" setzt voraus,
> das es vorher mindestens einmal probiert wurde. Und mit welchem
> Widerstand? Wo steht, das es derselbe war?
nachdem er schon mal sinnvolle werte gemessen hat, kann der poti nicht 
allzuverkehrt gewesen sein. klar wirds auch mit nem 10 ohm poti klappen, 
erklärt aber nicht den fehler.

hast du was persönlich gegen mich, dass du kategorisch widersprichst? 
das könnte man per pm wesentlich besser klären.

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Michael H* (-holli-)

Die Gelegenheit mich, wenn schon so harsch, privatim zu kritisieren, 
hättest Du zuerst ergreifen müssen. Nun aber, da Du, in der von Dir 
gewählten Weise öffentlich an mich geschrieben hast, wirst Du die 
Antwort auch öffentlich entgegen zu nehmen haben. Nun, zumindest jetzt 
noch, soweit ich sie nicht schon gegeben habe.


>wo kommt denn der verlaub her?

Wird eine Äußerung mit "mit Verlaub" begonnen, so wird damit 
gleichzeitig um die Erlaubnis nachgesucht und diese für bereits gegeben 
gehalten.


Und, mit Verlaub, bei Leuten, die in dem selben Satz, genau die 
Behauptung als Begründung verwenden, der sie widersprechen wollen, setze 
ich noch ganz andere Sachen voraus.


Damit betrachte ich die Sache als erledigt.

Autor: Weingut Pfalz (weinbauer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wenn das poti einen gesamtwiderstand
über die bahn von mehr als 10 ohm hat kanns
beim runter drehen, egal welche schleiferstellung,
und spannung von 5v oder kleiner definiv nicht
rauchen, es sei denn der experimentator drückt
seine kippe drauf aus.
demnach ist offensichtlich das poti falsch beschaltet
und das problem liegt nicht am adc sondern im
grundlagenwissen des experimentators, das demnach
noch lückig ist.

ich verweise daher auf:
http://de.wikipedia.org/wiki/Potentiometer

Autor: Robin Tönniges (rotoe) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fhutdhb Ufzjjuz wrote:
> also wenn das poti einen gesamtwiderstand
> über die bahn von mehr als 10 ohm hat kanns
> beim runter drehen, egal welche schleiferstellung,
> und spannung von 5v oder kleiner definiv nicht
> rauchen

Das sind bei 5V = 500mA was wiederum 2,5W wären. Ein normales Poti löst 
sich dabei auf.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, hab den Poti wohl doch falsch angschlossen, weil bis jetzt noch 
nicht ganz kapiert :-(

Jetzt hab ich verstanden!

D.h. Ihr denkt, dass wohl eher mein Poti kaputt ist und ich daher keine 
Spannung mehr am AVR hatte und daher nichts mehr messen konnte?

Dann werde ich morgen mal nen neuen Poti nehmen.

Welcher Anschluss am Poti ist denn welcher? Wie Ihr schon erkannt habt 
ist alles was nicht Digital ist immer noch Neuland für mich.

Gruß

Tom

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ist es an der Mechanik erkennbar. Manche sind nicht 
vollkokmmen gekapselt.
Oder, am besten, ein Datenblatt vom Poti besorgen. Da steht es.

Falls das nicht möglich ist, dann messen.

1. Messe zwischen zwei beliebigen Anschlüssen und drehe dabei an der 
Achse.
1.a. Ändert sich der Wert, dann haben wir den Abgriff erwischt. Aber 
welcher von beiden ist es?
1.b. Bleibt der Wert, dann haben wir ihn noch nicht.

2. Einen Anschluss wechseln und wieder drehen.
2.a. Der Wert hat sich vorher geändert, jetzt ändert er sich nicht: Der 
Anschluss von dem Du weggegangen bist, ist der Abgriff.
2.b. Der Wert hat sich vorher geändert, jetzt ändert er sich auch: Der 
Anschluss, den Du nicht gewechselt hast, ist der Abgriff.
2.c. Der Wert blieb vorher gleich, jetzt ändert er sich: Du hast zu 
dem Abgriff gewechselt.

;-) Der Wert bleibt beide Male konstant: Poti defekt.

Falls mal die Sudokus alle gemacht sind. ;-)
Keine Sorge: Ist ganz einfach und logisch, wenn man mal in Ruhe drüber 
nachdenkt.

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke vielmals Spinne, werde es so machen!!

Tom

Autor: Spinne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitteschön. Gern geschehen.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spinne wrote:
> Die Gelegenheit mich, wenn schon so harsch, privatim zu kritisieren,
hab ich wo bitte?
deine antwort war halt falsch, das muss man richtig stellen. das hat nix 
damit zu tun, von wem sie kommt...

> hättest Du zuerst ergreifen müssen. Nun aber, da Du, in der von Dir
wieso denn bitte? mir gehts um kein persönliches gekeife.

> gewählten Weise öffentlich an mich geschrieben hast, wirst Du die
> Antwort auch öffentlich entgegen zu nehmen haben. Nun, zumindest jetzt
ich hab dich nirgends persönlich angegangen. meine frage, warum du 
gleich so aggressiv auf eine richtigstellung reagierst, war eine direkte 
anrede, aber doch keinerlei ein agriff.

>>wo kommt denn der verlaub her?
>
> Wird eine Äußerung mit "mit Verlaub" begonnen, so wird damit
> gleichzeitig um die Erlaubnis nachgesucht und diese für bereits gegeben
> gehalten.
ja, das is mir schon klar =)
ich wollt nur wissen, wo du den grund zur erlaubnis hernimmst. den gibts 
nämlich wirklich nicht. schon gar nicht für persönliche angriffe.

> Damit betrachte ich die Sache als erledigt.
ahja...


nur so als kleine häme, die ich mir herausnehme =)
Thomas Burkhart worte:
> Ok, hab den Poti wohl doch falsch angschlossen
damit lag ich also mit meiner ersten vermutung richtig.

Autor: ohno (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stell das Poti auf mittelstellung Die Pins zwischen denen du 10kOhm hast 
sind nicht der Abgriff (welcher in fast jedem fall der mittlere sein 
wird).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.