www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Oszi zeigt Ausschlag nicht an


Autor: Bernd Schuster (mms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab gerade ein paar Schwierigkeiten mit dem Oszilloskop Voltcraft 6100s 
(100MHz).

Wenn ich eine LED einmal blinken lasse, wird mir am Oszi nichts 
angezeigt. Läuft das Programm (Blinken der LED) innerhalb einer while 
Schleife ab, wird es angezeigt. Lasse ich das Programm in einer 
for-Schleife ablaufen, welche von 0 bis 10 geht, sehe ich ebenfalls 
nichts, erst wenn diese mehrere Male durchlaufen wird (sprich 50x etc.) 
wird mir was angezeigt.

while(1)
{
   LED aus
   wait()
   LED ein
   wait()
}

Es wäre super, wenn mir das jmd erklären könnte. Hab bereits die 
Default-Einstellungen am Oszilloskop eingestellt, messe mit einem 
Tastkopf 1:1 (gleiches passiert auch bei 1:10)

Gruß
Bernd

Autor: Bernd Schuster (mms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab folgenden Satz in einem anderen Forum gefunden

"Nachteil ist, dass es ein 'Sampler' ist, d.h. es funktioniert nur bei 
periodischen Signalen gut, bei Einzelschuessen oder Stoerungen haste 
halt nur die 100MBits, d.h. 10MHz bei 10Punkten pro Periode"

wenn ich das richtig interpretiere, würde das heißen, dass das Oszi ein 
einzelnen Impuls (LED einschalten) nicht wahrnehmen kann, da die 
Anstiegszeit des Impulses bei 5ns liegt.... oder müsste das Oszi es 
trotzdem aufzeichnen können, da die LED ja mehrere µs angeschaltet 
bleibt.


Bernd

Autor: micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
micha wrote:
> schau mal hier: http://www.progforum.com/archive/index.php/t-6878.htm

Da kommt wieder mal Tektronix Analog sehr gut drin weg. Was ich nur 
bestätigen kann.

@OP: Die niedrige Samplerate des 6100s rächt sich zwar, aber Du solltest 
per passend eingestellter Triggerung zumindest eine Auslösung der 
Erfassung hinkriegen.
Geht das bei Dir?


hth,
Andrew

Autor: Bernd Schuster (mms)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wenn ich trigger, dann seh ich zwar, dass das Signal von High auf 
Low gesprungen ist, aber die Flanke wird nicht angzeigt. Sprich die 
Triggerung erfolgt bis jetzt immer erst einige Zeit danach.

Ohne Triggerung seh ich gar nichts (wie ich oben beschrieben habe)

Bernd

Autor: Tyler Durdan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Flanke siehst Du auch bei nem analogen nicht, schon gar nicht bei 
einem analogen!

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tyler Durdan wrote:
> Die Flanke siehst Du auch bei nem analogen nicht, schon gar nicht bei
> einem analogen!

Nö Tyler, das was Du schreibst ist schlicht Falsch.
Die Flanke haben analoge Scopes schon vor 30 Jahren anzeigen können.
Eben wenn diese Scopes von Tektronix sind war Verzögerungsleitung schon 
damals das Stichwort. Andere Hersteller hatten das auch drin ,-)

@Bernd: Tja, dann sampelt Dein Scope zwar mit 10MS/s; aber das übrige 
Design paßt nicht. Da wirst Du nötigenfalls wohl das Scope wechseln 
müssen .(


Andrew

Autor: Joeee (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Flanke haben analoge Scopes schon vor 30 Jahren anzeigen können.
Eine richtig steile Flanke kann ein Analog Oszi nicht anzeigen. Sobald 
du sie siehst, ist sie verschliffen

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joeee wrote:
>> Die Flanke haben analoge Scopes schon vor 30 Jahren anzeigen können.
> Eine richtig steile Flanke kann ein Analog Oszi nicht anzeigen. Sobald
> du sie siehst, ist sie verschliffen

Bitte definiere: richtig steil.


Alles was 1.5 Nanosekunden oder langsamer anteigt, kann mein 7104 
richtig anzeigen.

Jetzt kommst Du.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.