www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Uart/RS232 Problem - Kein Zeichenempfang


Autor: Marcel P. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Leute,

ich stehe vor einem Problem bezüglich der RS232-Schnittstelle.
Ich habe mir vor kurzen bei der Bucht einen GPS-Empfänger gekauft und 
wollte diesen nun per RS232 an den PC anschließen um das Protokoll 
auszulesen. Allerdings erhalte ich mit Hyperterminal keinerlei Zeichen. 
Ich habe beide einstellbaren COM-Ports probiert, aber auch nichts. Mit 
dem in Bascom integrierten Terminal-Emulator erziele ich auch keine 
Erfolge. Auch schaffe ich es nicht einen Atmega so kommunizieren zu 
lassen. Hierbei kann es sich beim µC nicht um einen Softwarefehler 
handeln, da ich 2 Atmegas bereits üder UART verbunden habe.
Im Anhang befindet sich der Schaltplan meines MAX232-Moduls.

Hat jemand eine Idee wo der Fehler liegen könnte?

Achja noch was, ich verwende kein Null-Modem-Kabel.

Vielen Dank schon mal vorweg

Marcel P.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Marcel P. (Gast)

>Dateianhang: RS232.png (11,2 KB, 1 Downloads)

Schalte den Layer Pins im Schaltplan aus, den braucht kein Mensch, er 
macht den Schaltplan nur sehr unleserlich.

AVR-Tutorial: UART
http://www.mikrocontroller.net/articles/AVR_Checkl...

Mfg
Falk

Autor: Marcel P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh stimmt hab ich noch vergessen auszumachen.

okay aber der Link erklärt vielleicht das Problem mit dem µC, aber nicht 
mit dem GPS-Empfänger, oder doch?

Autor: Marcel P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
trotz richtiger Baudrate kein Ergebnis

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Arbeite die Chekliste GRÜNDLICH durch und du wirst Erfolg haben.

Autor: Marcel P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich gebs auf... Mein MAX232 hats vermutlich gegrillt Dank dir trzdm

Autor: A. F. (artur-f) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung scheint richtig zu sein.

Autor: Marcel P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
okay immerhin allerdings selbst bei kurzschließen von R1OUT und T1IN 
habe ich kein ergebnis...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.