www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RS232 mit Atmega32 (FastLoad) zum laufen bringen.


Autor: der_eine (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich habe auf meinem ATMega32 FastLoad installiert, aber schaffe es 
nicht ihn über RS232 zu Programmieren.

meine RS232 schnittstelle hängt an den Pins 14 und 15 (PD0, PD1) des 
megas.
konfiguriert habe ich den FastLoad so:

;----------------------------------------------------------------------- 
--
.equ    STX_PORT        = PORTD
.equ    STX_DDR         = DDRD
.equ    STX             = PD1

.equ    SRX_PIN         = PIND
.equ    SRX_PORT        = PORTD
.equ    SRX             = PD0
;----------------------------------------------------------------------- 
--

sollte also gehen.

bzw. kann es sein das ich was vergessen/nicht beachtet habe? bin relativ 
neu auf dem atmega gebiet.


mfg,
der_eine

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.