www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probem beim senden Daten über uart


Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
über eine  serielle Schnittstelle  sende ich die Daten von dem 
Mikrocontroller zum einem PC. Der PC erwartet ein '\n' um zu wissen, 
dass alle Daten angekommen sind.

Meine sende-Routine  sieht so aus:


void UART0_Transmit(char string){

  int len = strlen(string);
  strcpy(temp,string);

  /* wait for empty transmit buffer */
  while(!(UCSR0A & (1<<UDRE0))){
  }

  /* put the data into the buffer */
  for(int i=0;i<len;i++)
  {
    UDR0 = temp[i];


  }
}

In main ich initialisiere temp [255]= '\n';
es scheint als die Line fine nicht gesendet wird.
Kann jemanden mir sagen wo das Problem liegt?

danke euch

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> In main ich initialisiere temp [255]= '\n';

temp ist hoffentlich kein unsigned char, oder?

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anregungen:
* loop_until_bit_is_set
* Zeiger
* stdint.h
* stdio.h
* Peter Fleury
* Quarz

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gast (Gast)

>Kann jemanden mir sagen wo das Problem liegt?

Dir fehlt grundlegendes Wissen über Strings in C. Kauf dir eine Buch und 
lerne.

>void UART0_Transmit(char string){

Deine Varianble string ist keine String! sie ist eine einzelnes Zeichen!

>  int len = strlen(string);
>  strcpy(temp,string);

Unsinn, braucht kein Mensch.

>  /* put the data into the buffer */
>  for(int i=0;i<len;i++)
>  {
>    UDR0 = temp[i];
>  }

Kann man manchen, istz aber unnötig. Weil . .

>In main ich initialisiere temp [255]= '\n';

Was schon mal falsch ist. Strings werden in C immer mit '\0' 
abgeschlossen.

MFG
Falk

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

unabhängig von den vorhergehenden Antworten:

  /* wait for empty transmit buffer */
  while(!(UCSR0A & (1<<UDRE0))){
  }

Du hast gewartet, bis UDR0 leer ist.

  /* put the data into the buffer */
  for(int i=0;i<len;i++)
  {
    UDR0 = temp[i];


  }

Und dann schiebst Du in einer Schleife diverse Zeichen in UDR0.

Das ist aber das Senderegister und das will erstmal in Ruhe die Daten 
senden bevor es mit dem nächsten Zeichen beschrieben wird...

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.