www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LED-Pin high setzen


Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe die Schaltung aus dem Anhang aufgebaut und funktioniert soweit 
auch, wenn ich die 5V an die Transistoren "händisch" anlege. Setze ich 
dagegen einen ATMega8 ein, der in der Programmierschaltung 5V am 
entsprechenden Pin anliegen hat, so hat dieser in der Schaltung nun 
plötzlich 0V... Ich habe keine Ahnung, woran das liegt, weiss jemand 
Rat?

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anhang?


Hat dein Mikrocontroller auch Spannungsversorgung, Quarz, etc.?

Autor: El Jefe (bastihh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schaltplan und evtll source wären hilfreich ;)

Autor: El Jefe (bastihh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
2late ^^

Autor: Anfänger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ups, dachte der Anhang wäre da... Stromquelle ist dran, messe auch am 5V 
am M8.
Noch etwas Source:
int main(void)
{
 PORTC = 0xFF;
 DDRC=0xFF;
 TCCR0 = ( 1 << CS02 ); // Teiler: 256
 TIMSK = ( 1 << TOIE0 );  // Overflow Interrupt einschalten
 sei();
 PORTC |= (1<<PC2);

 while(1) {};

} 

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf deim Schaltplan sind einige unbelgte PINs zu sehen, was den 
Controller stören könnte, außerdem seh ich nirgens dass Masse 
angeschlossen ist

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Masse ist angeschlossen... lag daran dass in der einen SChaltung ein µC 
mit Quarz verwendet wurde und hier nicht.

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Masse mit dem Controller verbunden ist und der Controller 5V 
ausgibt, dann miss z.B. an R1 die Spannung und rechne den Strom aus. so 
ab einigen 100µA sollte die LED leuchten

Welchen Wert haben überhaupt die Widerstände?

Nachtrag: IRFD9210 ist ein P-Kanal und funktioniert hier nicht!!

Grüße, Peter

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ist ein IRFD024 drin, Schaltplan stimmt in der Hinsicht nicht. Jetzt 
gehen, Rot und Blau, Gelb leider nicht, hoffe die ist nciht hinüber

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.