www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Port forwarding für AVR-NET-IO


Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soo, da ich die Diskussionen im Thread "AVR für wenig Geld im LAN" nicht 
stören wollte, habe ich mich dazu entschlossen, diesen neuen zu öffnen.

Ich habe auch ein AVR-NET-IO mit der modifizierten Software von U. Radig 
am laufen, aber auf den Server möchte ich natürlich auch von auserhalb 
zugreifen. Hab mir schon ne DynDNS besorgt und eingestellt. Mir fehlt 
nur noch eine Info die ich bisher nirgends finden konnte: Den Port am 
Webserver, auf den ich das Port-forwarding einstellen soll. Wäre net 
wenn mir jemand helfen könnte

Gruß

Jochen

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wenn's um HTTP geht, dann währe wohl Port 80 das richtige.

Sascha

Autor: Jochen R. (josch90)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Also langsam fang ich an zu verzweifeln,
Anhang hab ich mal n creenshot von meiner konfiguration.
Ich habe eine D-Link DI-524, kann mir irgendjemand helfen?

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn 192.168.0.99 dein AVR Board ist, dann ist das so richtig.

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja dann sag doch woran du verzweifelst?!

Wenn du im Browser auf dem PC der im selben LAN hängt dein AVR Board 
nicht unter der öffentlichen Adresse erreichen kannst, dann trage in 
deinem Browser mal einen öffentlichen Proxyserver ein. Bei meinem 
Teledat 631 z.B. wird eine Anfrage aus dem LAN, die an die WAN-IP 
gerichtet ist auch nicht korrekt weitergeleitet!

Sascha

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn ich auf das board im Lan unter 192.186.0.99 zugreifen, gibt es 
keine Probleme, gebe ich allerdings meine öffentliche IP im browser ein, 
kommt immer Seiten Ladefehler...
Daran verzweifel ich :P
An der Router firewall kann es auch nicht liegen, da diese automatisch 
den eintrag des virtuellen servers übernimmt und freigibt.

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sascha hat die warscheinlichste Ursache schon genannt. Der Router mappt 
vermutlich den internen Zugriff  auf die Externe Adresse wieder auf die 
Interne Adresse, und da wird nicht geforwarded.
Versuch es mit nem Proxy-Server, oder greif mal von nem anderen 
Internet-Zugang aus drauf zu.

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, habs sowohl mit verschiedenen Proxys, als auch mit nem anderen 
Internetzugang probiert. Leider beide male ohne erfolg...

Hier meine aktuelle IP, zum nochmal testen 78.42.190.18

Habt ihr sonst noch ideen was es sein könnte?

Gruß

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zu erreichen ist da leider nix. Bist du sicher, das das Portforwarding 
aktiviert hast? Unter der IP ist jedenfalls nix zu erreichen, das könnte 
auch noch für irgendeine Firewall-Konig im Router sprechen die da noch 
querschießt.

Autor: DirkG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche mal im Router 192.168.0.99 Port 50290 auf 80

Der Aufruf sollte dann von außen sein : 78.42.190.18:50290

Die 80 wird für den generellen http-port an deinem PC (z.b.) benutzt.

Gruß DirkG

Autor: Jochen R. (josch90)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, im Anhang habe ich mal meine Firewall regel, diese hat mein Router 
automatisch erstellt, funktionieren will die Sache auch mit den 
Einstellungen von DirkG nicht....

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab hier noch was gefunden:

Sonntag December 07, 2008 13:15:36 Unrecognized attempt blocked from 
91.89.85.206:48761 to 91.89.32.203 TCP:135
Sonntag December 07, 2008 13:16:16 Unrecognized attempt blocked from 
91.89.14.134:55558 to 91.89.32.203 TCP:135
Sonntag December 07, 2008 13:16:23 Unrecognized attempt blocked from 
91.89.237.0:49762 to 91.89.32.203 TCP:135

Das stand im Log meines Routers, er scheint also meine Anfragen zu 
Blocken. Die Zeiten stimmen auch mit meinen Zugriffsversuchen überein

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Log-Einträge bedeuten nicht das deine HTTP Verbindung geblockt 
wurde, denn die Anfrage von außen ging ja an Port 135 (NetBios).

Hast du im Router noch andere Firewallregeln, oder MAC-Adress-Filterung 
aktiv?


Sascha

Autor: Aike T. (biertrinker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich würde als erstes mal die Firewall im Router deaktivieren. Die nützt 
bei einer Standard-DSL Konfiguration sowieso nix.

Autor: Jochen R. (josch90)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen dank Sascha, ich habe nicht mehr an die MACadress-filterung 
gedacht, habe das board nun eingetragen und diehe da, es geht!! Mich 
wundert es allerdings, dass ich über LAN darauf zugreifen konnte, da die 
filterung ja normalerweise eine nicht eingetragene MAC generell nicht 
ins netzwer lässt...
Naja, ist ja auch egal...

Vielen Dank natürlich auch an die anderen, die versucht haben, mir bei 
dem Problem zu helfen

Gruß

Edit:

http://roesch.hobby-site.org/

benutzer: admin
pass: jochen


jetzt kann ich ja mit dem programmieren loslegen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.