www.mikrocontroller.net

Forum: Compiler & IDEs Mein gcc mag den mega103 nimmer...


Autor: Sascha Weitkunat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab grad das neuste Release vom AVR-GCC übergebügelt und nun mag er den 
atmega103 nichtmehr. Ich gebe den MCU ganz normal in der Makefile an 
("MCU = atmega103")... Er compiliert auch ohne jegliche Fehlermeldung, 
nur das Programm selber ist regelrecht kaputt, es wird auch nichtmehr 
richtig geflasht. Am Anfang des Programms stehen zig sinnlose Hexfolgen.

Ich konnte das Problem lokalisieren indem ich einfach als MCU einen 
anderen angegeben habe; ein relativ funktionsloses Programm (LED und 
Tasterspielerei) habe ich damit kompiliert und in den mega103 geladen, 
siehe da, es funktioniert! Die Hexfile schaut auch ganz normal aus...

Ist natürlich kein Zustand, aber woran kanns liegen?

Autor: Sascha Weitkunat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mh, Fehler gefunden...

Aus irgend einen unerfindlichen Grund war die iom103.h fehlerhaft, dh. 
im Editor garnicht ansehbar. AVR-GCC nochmal runtergeladen und 
installiert und alles ging wieder.

Danke für die rege Hilfe ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.