www.mikrocontroller.net

Forum: PC Hard- und Software wie IP-Adresse bei Auto-IP heraus finden?


Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen embedded WLAN-Webserver, dem ich bei der Inbetriebnahme 
folgende feste IP-Adresse mit einer speziellen PC-Software vergeben 
habe:

169.254.210.8

Nach der Inbetriebnahme konnte ich noch auf die Konfigurationssoftware 
auf dem Webserver mittels folgendem Link zugreifen:

http://169.254.210.8/secure/ltx_conf.htm

Als ich eine neue WLAN-Verbundung zwischen PC und Webserver hergestellt 
habe, war kein Zugriff mehr möglich. Nun habe ich herausgefunden, daß 
169.254.xxx.xxx für Auto-IP vergeben ist. Ich vermute, daß ich daher 
keinen Zugriff mehr auf den Webserver habe.

Wie kann ich herausfinden, welche automatisch erzeugte IP-Adresse mein 
Webserver nach dem WLAN-Connecten hat? Ich muß wieder auf die 
Konfigurationssoftware zugreifen können, um die feste IP-Adresse des 
Webservers zu ändern. Geht das eventuell über die MAC-Adresse?

Hinweis:
Webserver und PC sind direkt (ohne Router) mittels WLAN verbunden. Das 
ist bei dem Webserver der Auslieferzustand.

Gruß Martin

Autor: Frank L. (hermastersvoice)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lass doch einfach mal einen Netsniffer über die betreffenden 
Netzsegmente rennen, Der sagt dir dann schon welche Adressen antworten.

bye

Frank

Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist ne gute Idee. Du meinst wireshark oder so?

Autor: H. G. (thankyoufordancing)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Falls Du Windows verwendest, kommst Du evtl. auch mit arp -a zum 
gewünschten Ergebnis. Viel Erfolg.

Gruß, Hendrik

Autor: hownottobeseen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Martin,

mit Wireshark kannst du es versuchen, dann siehst du, wenn der Server 
z.b. einen DHCP-Request aussendet.
Allerdings geht das nur im gleichen Subnetz!
Ich hab die einzelnen Netzbereiche nicht im Kopf, aber 169. sieht mir 
fast nach Class-C aus.

Was du probieren kannst (ist aber "illegal" ;)):

Ändere die Subnetzmaske am PC auf 255.0.0.0, dann kannst du alles imm 
169-Netz erreichen.

Es gibt diverse Tools um IP-Ranges abzusuchen.
Bekanntestes dürfte das (in .de jetzt leider illegale) Programm, das 
nach der in Genesis 4,1-24 erwähnten Brüder benannt wurde ;)

Mehr darf man ja leider nicht mehr sagen... :(

Autor: Lehrer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, namentlich nennen darfst du es schon. Das wäre ja auch noch 
schöner. Du darfst nur keinen Link setzen oder öffentlich zur Benutzung 
aufrufen.

Autor: Martin M. (martin69)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So, nun habe ich es 1 Mal hinbekommen, auf die Konfigurationssoftware 
auf dem Webserver zuzugreifen. Ich wollte ihn auf den Auslieferzustand 
bringen, ging aber nicht. Dann habe ich zumindest die feste IP-Adresse 
auf folgende geändert:

192.168.178.30

Müßte ja eigentlich OK sein. Aber nun kann ich wieder nicht auf den 
Webserver zugreifen. Die WLAN-Karte im PC zeigt an, daß ich mit dem 
Webserver verbunden bin, aber ich kann mit dem Internetexplorer mit 
"http://192.168.178.30/" nicht zugreifen. Irgend etwas scheint nicht zu 
stimmen.

Anbei ein Bild von den Wireshark-Aufzeichnungen. Ich interpretiere es 
so, daß der Webserver ein Request setzt (mit roten Pfeilen markiert), 
aber nicht beantwortet wird. An was könnte das nun liegen?

Gruß
Martin

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da stimmt ne Menge nicht -- krumme IP-Adressen, wirre Netzklassen und 
alles schön vermischt. Stell dein 'Auto-IP' (was auch immer das sein 
soll -- Modename für DHCP vielleicht?) ab und/oder setz deinem Server 
von Hand eine eindeutige IP -- fertig.

Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eine eindeutige Server-IP habe ich ja vergeben: 192.168.178.30
Oder ist das nicht eindeutig? Welche IP-Adresse soll ich verwenden?

Das Dumme ist, daß ich erst wieder eine andere IP-Adresse vergeben kann, 
wenn ich auf die Konfigurationssoftware zugreifen kann. Und das geht ja 
gerade nicht mehr... Das Ding bringt mich noch zum Verzweifeln....

Autor: njaa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für ne IP hat den dein Rechner?

Haste auch geguckt das die im gleichen Subnetz liegen?

Also beide 192.168.178.XXX beim Subnetz 255.255.255.0



Gruß

Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe nen Webserver mit LAN mit der IP 192.168.178.21. Der geht 
problemlos. Hab für den WLAN-Weberver 192.168.178.30 verwendet. Der 
müßte dann doch auch gehen, oder?

Welche IP mein PC hat, weiß ich nicht. Ich habe mit der IP-Sache bisher 
keine große Erfahrung...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.