www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Frage zu LM2676 als Inverter


Autor: Sören (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

ich habe mir ein +/- 12V Netzteil mit zwei LM2676-12 gebaut. Die
Eingangsspannung beträgt 24V. Mittlerweile tut das Ding auch
wie es soll aber ich kann mir ein Phänomen nicht erklären.

Die Schaltung des invertierenden Reglers entspricht der im Anhang.
Das ist soweit nichts Besonderes und das habe ich mit einem LM2576
schon des öfteren gemacht. Das Teil das ich mir nun aufgebaut habe
liefert nach dem Einschalten aber zunächst nur ca. -8V. Innerhalb
von vielleicht zwei Minuten klettert die Ausgangsspannung auf
die gewünschten -12V. Offenbar ist das Temperaturabhängig denn
wenn ich das Gerät ausschalte, die Teile mit Kältespray bearbeite
und wieder einschalte, geht das Spiel von Vorne los.

Da ich nun ein Spielkind bin habe ich alles mögliche ausprobiert
und hatte letztlich Erfolg: Ich habe einen 470pF Kerko parallel
zu der Schottky Diode gelötet. Seitdem läuft der Regler Problemlos
an.

Kann mich vielleicht jemand Erleuchten?

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NB: Sind die 24V geregelt? Bei Vout=-12V gilt Vin(max)=+28V.

Autor: Sören (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, mehr als 24V liegen nicht an. Für den Testaufbau habe ich
ein 30V/5A Labornetzteil (linear) auf 24V eingestellt. Später
kommt die Schaltung an ein 24V/6A SNT. Beim anderen Geräten mit
ungeregelten Netzteilen habe ich sonst den LM2576HVT (60V)
benutzt.
Aber Danke für den Hinweis. Solche Grenzen sind leicht zu
übersehen.

Ich habe mit einem Scope gemessen ob da vielleicht
irgendetwas wild rumschwingt. Tut es nicht. Der Ausgang des
2676 sieht im Gegenteil sogar sehr sauber aus. Beim 2576 sehe
ich jede Menge gedämpfte Schwingungen. Hier ist es ein schönes
Rechtecksignal - also auch ohne Kerko und mit Fehler.

Der Regler sitzt übrigens auf einer zweilagigen Platine (alles,
aber wirklich alles SMD) - also kein wilder Verhau. Die
Kondensatoren sind low-ESR Tantals (Digikey) gemäß Datenblatt.

Autor: Der Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hätte so eine kleine Idee und zwar sind Tantal nicht mit hohen 
Stromstpitzen belastbar da diese dann einen Internen Schluss bekommen
bzw. kaput gehen [ so kenne ich das nur von Tantalkondis ]

Ichg könnte mir noch erklären das der Kerko für schnelle Schaltspitzen 
an
der Diode sorgt wie es auf bei HF - Transistorstufen Parrallel zum
Basisvorwiderstand geschaltet sind.

Ansonsten hätte ich jetzt mal auf die Schnelle keine Idee
woran das liegen könnte.

Ein Oszi und dann mal auf Untersuchung gehen :)

Wenn du was neues dazu herausgefunden hast würde ich darum
bitten das du dein Ergebnis hier veröffentlichen würdest.

Autor: Sören (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich fürchte der Oszi hat mir alles gesagt was er weiß.
Aber die Sache mit den Tantals sehe ich mir mal genauer
an. Die sind zwar für Schaltregler gedacht und ich habe
wie von National vorgeschlagen 2x33µF/20V parallel
geschaltet (Kemet T495). Aber die Drossel ist nicht die
von Coilcraft bzw. Pulse, sondern von Würth. Wenn die
kleinere Verluste hat als die anderen, steigt die Belastung
der Elkos. Der 470pF Kerko wird vielleicht die Anstiegszeit
der Spannung etwas verringern. Andererseits kommt erst danach
die Drossel...

Im Augenblick sehe ich jedenfalls drei Möglichkeiten für
weitere Untersuchungen:
1. Einen dritten Tantal-Elko hinter die Drossel.
2. Einen größeren Kerko (2,2µF) parallel zu den Elkos.
3. Einen Widerstand (z.B. 0,1 Ohm) in Reihe zur Drossel.

Morgen (bzw. Heute) habe ich keine Zeit für Experimente.
Vielleicht am Montag.

Danke für den Tipp!

PS: Der Wirkungsgrad liegt bei 86% (Iout=1,5A).

Autor: Sören (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe jetzt weiter experimentiert. Der +12V
und ein bislang noch nicht erwähnter +5V Regler funktionieren
ohne Kerko über der Diode auch nicht vernünftig.
Die Ausgangsspannungen der beiden sind zwar stabil aber
bei zunehmender Belastung (ca. 0,5A/12V u+ 1,2A/5V) fangen
die Drosseln an zu pfeifen. Je größer der Strom desto größer
muß der Kerko sein. Bei 5V/3A muß es 1nF sein. Die
Schaltfrequenz beträgt beim 5V Regler etwa 268kHz. Wenn
die Drossel pfeift scheint mir der "Träger" frequenzmoduliert
zu sein. An der Amplitude sehe ich keine Veränderung.

Zurück zum -12V Teil:
Die Drossel pfeift auch bei maximal vorgesehendem Strom
(1,5A) nicht. Doch auch hier hängt es von der Last ab wie
groß der Kerko sein muß um auf anhieb -12V zu erhalten.
Bei 0,3A reicht bereits der Tastkopf des Scopes an der
Kathode, unter Vollast müssen es schon die besagten 470pF sein.
Es ist das IC das temperaturabhängig ist. Ein wenig Kältespray
genügt um die ohne Kerko nach einiger Zeit erreichten -12V
auf ca. -10V abfallen zu lassen. Das IC wird bei 0,3A nicht
einmal lauwarm.

Mit den weiter oben beschriebenen Maßnahmen (2,2µ Kerkos,
Reihenwiderstand, weitere Tantals an Ein- und Ausgang)
bin ich durch. Das macht überhaupt keinen Unterschied.

Ich tausche jetzt noch die Dioden gegen MBRS340. Was da
jetzt verbaut ist weiß ich nicht genau. Nur das es 3A
Schottky Dioden sind, die am LM2576 anstandslos funktionieren.

Autor: Sören (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fall ist geklärt. Ich habe mich heute Nachmittag
von einem E-Techniker aufklären lassen.

Mit dem Kondensator habe ich einen Snubber in die Schaltung
eingebaut. Eigentlich gehört da noch ein Widerstand zu, den
man in leichteren Fällen aber auch weglassen kann. Leiterbahn
und Lötstellen übernehmen dann diese Aufgabe. Ich sollte
aber besser 3,3 oder 4,7 Ohm in Reihe zum Kerko schalten.

Offenbar werden die Regler durch die Spannungsspitzen beim
Umschalten gestört. Vielleicht sind einige Leiterbahnen zu lang
oder ungünstig verlegt.
Die LM2576 betreibe ich mit Eisenpulverkernen, und nicht
mit Ferritkernen wie die LM2676. Eisenpulver ist wegen
der größeren Verluste gutmütiger als Ferrit.
Warum der -12V Regler Temperaturabhängig ist konnte mir der
Kollege nicht erklären. Er vermutet das das Teil ohne
Snubber einfach am Stabilitätsrand arbeitet.

Ich habe jetzt also jeweils eine Reihenschaltung aus
1nF + 4,7Ohm parallel zu den Dioden gelötet. Das funktioniert
genauso wie der Kondensator alleine.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.