www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Zu dumm zu?: ATTiny13 mit JTAGICE MKII und AVR-Studio debuggen


Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich benötige einmal eine kleine Starthilfe - scheinbar stelle ich mich 
zu glatt an:

Ich möchte ein Miniprojekt für den Attiny13 debuggen - habe vorzuliegen 
ein JTAGICE MKII, nen STK500 und AVRStudio 4.12 Build 490 SP3.

Letzteres ist sicher nicht das neuste - doch die CD lag bei und ich gehe 
erstmal davon aus, daß es grundsätlich funktionieren sollte.

Zum eigentlichen Problem:

Ich komme via ISP und serieller STK500 Verbinudung (also ohne MKII) rauf 
- kann Fuses setzen und Programm reinspielen.

Da ich aber wissen will, was mein ADC wirkclih mach, würde ich gern 
debuggen - zumal das MKII ja vorhanden ist - und es grundsätlich 
funktionieren sollte.

OK, also:
1. Das Debug-Wire Fuse gesetzt
2. MKII mit 10 auf 6 Adapter auf SPROG1
...und los gehts?

Scheinbar ja nicht... was muß ich denn beachten?

Ich komme mit MKII weder im ISP Modus (also solange das DebugWire-Fuse 
noch nicht gesetzt ist) ran - noch funktioniert scheinbar DebugWire.

Was mache ich falsch?
Gruß Manfred

Autor: Henry (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist bei dem STK500 die Reset Leitung des Attiny13 freigeschaltet? Wenn 
da ein Kondensator dran hängt geht das nicht.

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der Attiny sitzt bislang völlig allein drin - keiner der Ports oder 
Leitungen mit irgendwelchen Quellen oder Zielen verschaltet.

Auf dem STK habe ich gemäß der Doku allerdings die RST=>PB5 und XT1 => 
PB3 Verbindunen gesteckt.
Habe es aber auch schon ohne probiert - scheint auch nicht zu 
funktionieren.
Gruß Manfred

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube, ich kann nun endlich nach langem Suchen meine Frage selbst 
beantworten:

1. natürlich das DebugWire Fuse setzen
2. klappt das scheinbar nicht mit jedem Exemplar (und dem STK500?)
3. muß der RESET-Jumper weg - sonst kommen sich scheinbar STK500 und 
JTAGICE MKII auf der so wichtigen Leitung ins Gehege.

Nun gibt er erste Lebenszeichen von sich.
Danke sagt...
Manfred

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.