www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega16 Problem


Autor: Jan (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

hab mich letzte Woche mal an den Mega16 rangewagt(hab bis jetzt nur
Erfahrung mit dem 2313).
Hab alles wie im Bild angeschlossen und benutze BASCOM,sollte doch
eigentlich funktionieren oder?(beim 2313 gings super)
Problem: Bascom identifiziert den Mega16 nicht,ich kann die
Fuse\Lockbits nicht lesen\schreiben,den Flash schreiben\lesen
natürlich auch nicht.Bekomme immer die Fehlermeldung"

Could not identify chip with ID:FFFFFF"

Was mich jetzt arg verwunderlich stimmt ist,das wenn ich Vcc auf
4,4V-4,6V runterschraube mir Bascom auf einmal ID's anzeigt(schön und
gut...)natürlich bei jedem aktualisieren ne andere.und manchmal!! auch
die vom Mega16.Bei den Fuse\Lockbits genau das gleiche Elend so alle
5-10 Versuche klappts mal dann wieder nicht.

Hat irgend jemand ne Idee oder n Tipp was ich falsch mache...?
Dankeim voraus...

Autor: Fritz Ganter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du einen Stützkondensator zw. VCC und GND am Mega16?

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, oder ersetz die Wiederstände durch kleinere(z.b. 150 Ohm), damit
hats bei mir immer geklappt, ich benutze nämlich genau die selbe
Schaltung, eben einfach mit anderen Wiederständen.

MFG Nik

p.s. auf welchen programmer hast du bascom eingestellt?

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also zwischen Vcc ung GND ist noch kein stützkondi,werd ich aber mal
probieren.Werd auch mal andre Wiederstandswerte durchtesten,hoffe das
bringt was...ach ja,in Bascom hab ich als Programmer Universal MCS
Interface gewählt und Parallel Port...
Gruß Jan

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich hab Bascom auf den Sample Electronics Programmer
eingestellt...funzt suppi so.

Gruss Nik

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab's grad mal mit zusätzlichem Kondi und andren Widerständen
probiert,no effect,geht immer noch nicht...:(
Könnt eventuell die Prog.Schaltung mit dem 74HC244 was bringen????

Autor: Nik Bamert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Villeicht hilft es im Bios den LPT Mode auf ECP oder EPP einzustellen.


Nik

Autor: Dieter B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jan

Ich verstehe nicht wirklich, wieso Ihr euch am Anfang so was antut.

Kauft Euch doch eine ISP Pro. bei E Bay und in einem anderen Shop Eurer
Wahl.

Ist jetzt nicht böse gemeint, aber so kann man doch gerade am Anfang
die grössten Probleme aus der Welt schaffen. Gerade am Anfang, wenn gar
nichts klappt, weiß man als Anfänger doch gar nicht, wo man Anfangen
soll mit suchen und der Frust ist schnell da.

So, das mußte ich jetzt mal los werden.

Klar, kann man nachher die Dinger selbst bauen, aber da hat man ja auch
mehr Erfahrung und hat genug Teile zum tauschen.

Das selbe Thema ist doch mit den LCD Display. Erste Programm
geschrieben und schon muß so ein Teil daran. Klar verstehe ich ja auch,
aber man sieht ja auch in den Threads, das es doch nicht so ganz
einfach ist am Anfang. Kaufen alle Teile die sie brauchen und ein LCD
Display und sparen dann am ISP Prog.

Nicht böse sein, wird schon klappen

MFG
Dieter

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Dieter

wenn der Programmer beim AT90S2313 einwandfrei funktioniert hat und es
beim ATMega16 auf einmal nicht mehr tut ist das schon a weng komisch
oder...?Warscheinlich ist es wirklich besser ich kauf mir so'n
Programmer...aber woher soll dann die Erfahrung kommen...:)
Nebenbei liefen 90% aller LCDisplays die ich probiert habe am 2313, auf
Anhieb und letztendlich alle....

Gruß Jan

p.s.:ist auch nicht böse gemeint ;)

Autor: Axel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute!
Ich weiß nicht ob dass hier her passt, aber ich hab ne frage zum
AT90S2313! Ich bräuchte bitte dringend eine Schaltung, um ein Diplay
(wm-c2004p) anzusteuern!
Hoffe auf baldige Hilfe!
mfg. Axl

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir einfach mal im AVR-Tutorial das Thema "LCDisplay" an,laut
Datenblatt wird dein WM-C2004P genauso angesteuert.

1 - GND (0V)
2 - Vdd (5V +/-5%)
3 - VO  (contrast adjustment)Poti 10k-20k zw.GND-Vdd,Abgriff auf VO)
4 - RS  (Register Select signal)
5 - R/W (Read/Write selection)
6 - E   (Enable signal)
7 - DB0 \
8 - DB1 |
9 - DB2 |
10- DB3 |DATA BUS
11- DB4 |
12- DB5 |
13- DB6 |
14- DB7 /
15-\LED's der
16-/Hintergrundbeleuchtung

Hoffe es klappt,
Gruß Jan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.