www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMEGA32 funktioniert nicht mit ATMEL EvaluationBoard 2.0


Autor: Renato P. (renato)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Folgende Problemstellung:
ATMEGA32 funktioniert NICHT auf meinem ATMEL Evaluationboard 2.0.
ATMEGA32 funktioniert jedoch auf meinem STK500.
ATMEGA8 funktioniert auf beiden Boards(ATMEL Evaluationboard 2.0 und 
STK500).

-> Woran kann es liegen, dass mein ATMEGA32 auf dem Evaluationboard 
nicht funktioniert?
ps: wie gesagt, der ATMEGA8 funktioniert aber.

Vielen dank für eure hoffentlich hilfreichen Antworten!

Renato

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pinbelegung?

Otto

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schlechte lötstelle am dil40-sockel?
leiterbahnunterbrechung?
was funktioniert eigentlich nicht??

Autor: Renato P. (renato)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Otto wrote:
> Pinbelegung?
>
> Otto

Pinbelegung is ok.



Helmut wrote:
> schlechte lötstelle am dil40-sockel?
Hab die Lötstellen gründlich durchgesehen. Daran sollte es nicht liegen.
> leiterbahnunterbrechung?
Hab jetzt 10 mal nachgesehen. Ne denk nicht.
> was funktioniert eigentlich nicht??
Oh sorry, da hab ich mich natürlich zu ungenau ausgedrückt.
1)Ich kann den ATMEGA32 weder programmieren,
2)noch kann ich ihn in Betrieb nehmen, wenn ich ihn mit meinem STK500 
vorprogrammiert und anschließend an das ATMEL Evaluationboard 2.0 
anschließe.
also zusammenfassend) Der ATMEGA32 funktioniert gar nicht.
...Auf dem STK500 läuft der ATMEGA32 aber einwandfrei(Programmierung und 
Inbetriebnahme).

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Justus Skorps (jussa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Renato Panic wrote:

> also zusammenfassend) Der ATMEGA32 funktioniert gar nicht.
> ...Auf dem STK500 läuft der ATMEGA32 aber einwandfrei(Programmierung und
> Inbetriebnahme).

sowas hatte ich diese Woche auch, aber mit einer selber designten 
Platine...da war der Grund, dass am Quarz zwei 22nF statt 22pF 
Kondensatoren hingen...da schwang natürlich nichts an..

Autor: icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Setz doch mal mit dem STK die Fuses auf internen Oszillator
wenns dann auf dem pollin Läuft...

http://www.mikrocontroller.net/articles/AVR_Checkliste

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm... das ATMEL EvaluationBoard 2.0 kann jedenfalls ursächlich nix 
dafür. Erfolgreich getestete Knöpfe (MEGA8 geht auch):
ATMEGA8515
ATMEGA16
ATMEGA32
ATMEGA644

Ich vermute auch, daß entweder am 40-Pin-Sockel der Wurm drin ist oder 
aber in Deiner Quartzbeschaltung evtl. ein Fehler vorliegt, kannst ja 
mal stattdessen 'nen Takt in OSC1 einfüttern (PIN13).

mfg

Autor: Hannes Lux (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hmmm... das ATMEL EvaluationBoard 2.0 kann jedenfalls ursächlich nix
> dafür. Erfolgreich getestete Knöpfe (MEGA8 geht auch):
> ATMEGA8515
> ATMEGA16
> ATMEGA32
> ATMEGA644

Das glaube ich Dir nicht!!!
Zumindest nicht den Mega8515, der ist trotz seiner 40 Pins nicht zum 
Sockel des Mega 16/32/644/8535 kompatibel... ;-)

...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.