www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik GAL Programmer


Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir den GAL Blaster gebaut, doch leider funktioniert er nicht
so ganz...
http://www.geocities.com/ResearchTriangle/Forum/80...

Ich bekomme immer die Fehlermeldung "Unknown or illegal PES", also
das Programm kann den GAL nicht auslesen.
Einmal ging es kurz, aber beim Schreiben blieben alle Bits auf 1...

Lassen sich wirklich alle GAL16V8 löschen und neu beschreiben ?
Ich habe hier mehrere aus einem Compaq Mainboard, und ich kann nicht
glauben, dass in der Massenproduktion solche wiederprogrammierbaren
Bauteile verwendet werden...

Autor: STEVE (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

auf einem Mainboard werden nur PAL's eingesetzt und diese kann man nur
einmal beschreiben.


Steve

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem Compaq Board das ich hatte waren nur GALs drauf, alle von
Lattice. Die meisten sind GAL16V8A, einige auch GAL20V8A, insgesamt
etwa 20 Stück...
Alle haben den normalen Lattice Aufdruck und darüber (c) COMPAQ 1990

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Bei mir hat alles sauber hingehauen. Teste mal deine HW ob alles da
ankommt wo es hingehört.

MFG Uwe

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die HW mindestens schon 10x überprüft, passt alles.
Verwendest du die Minimum effort Version oder die Platinenversion ?

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für eine Software verwendest du, wie schnell ist dein PC (laut der
Beschreibung ist das Timing sehr kritisch, und die Software sehr alt,
deshalb vermute ich Timingprobleme bei schnellen PCs...)

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Timing wäre noch eine Möglichkeit. Bei mir ist es auf einem uralten
Schlepptop gelaufen und der hat nur 75MHz. Verwendet wurde nur die
Minimalversion mit externer Spannungseinstellung. Allerdings die mit
7417 gepufferte Variante.
Mehr kann ich jetzt auch nicht sagen.

Viel Erfolg Uwe

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, das könnte weiterhelfen. Ich probiers mal an einem 486er mit
66MHz aus. Gut wenn man noch die alten Dinger rumliegen hat...

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es lag am Timing...
Mit einem 100MHz Laptop ging es einwandfrei...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.