www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Digitaltacho spinnt!


Autor: Drifter ... (drifter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin Moin,

ich habe an meinem Moped ein Digitaltacho verbaut. Ich habe diesen an 
den original Tachogeber angeschlossen. Nun spinnt der aber rum, springt 
immer von 20 auf 40 oder auch mal bis zur 60 km/h.

Der Anschluss erfolgt über 3 Leitungen, eine hat Masse, eine hat im 
Ruhezustand 5V und eine 0V; beim Betrieb sinkt die eine Spannung unter 
5V und eie andere steigt.

Ich denke, dass die geringe Spannung schwankt und er deshalb ausschlägt. 
Wie bekomme ich die glatt? Kondensator? Gegebenenfalls wie groß?

Gruß

Autor: EGS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erste Frage die sich stellt ist folgende:

entscheidend ist woher der Tacho sein Signal bekommen muss. da gäbe es 
verschiedene Varianten. Manche bekommen Ihr Signal von einem Taktgeber 
auf einer Welle und messen die Impulse und Addieren die zu einer festen 
Zeiteinheit.

Und dann sollte deine Bordnetzspannung auch noch zu der des tachos 
passen.

Desweiteren ist es wichtig dem Tacho eine stabile Spannungsreferenz zu 
geben. Viele Digital Tachos vergleichen die Werte mit einer Festspannung 
und ermitteln daraus die Anzeige (vergleichbar eines Spannungsmesser in 
digitaler Form).

Es könnte also an einer stark schwankenden VErsorgungsspannung liegen.

Autor: EGS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Kondensator bringt dir aber auch nix, wenn die Spannung stabil 
bleiben soll. Der Kondensator glättet dir die hochfrequenten 
Schwingungen heraus, die längeren bleiben aber. Dadurch kann es 
passieren, das du dein Tachosignal filters (hochfrequentes Taksignal).

Du musst deine Spannungsreferens aus einer anderen Quelle als der 
Bordspannung gewinnen.

Autor: Drifter ... (drifter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antwort.

Das Digitaltacho ist für den Kfz-Betrieb bestimmt, der Anschluss an das 
Bordnetz ist mithin vorgesehen.

Die 5V kommen aus dem Tacho und gehen zum "Geber" am Ritzel. Dann kommt 
eine kleine Spannung zum Tacho zurück, welche wohl für den 
Zeigerausschlag verantwortlich ist. Ich denke, die hat Spannungsspitzen, 
denn der Zeiger zuckt ja immer nur. Ich möchte mithin die 
Spannungsspitzen weghaben, dann sollte auch das Zucken weg sein oder?

Gruß

Autor: Drifter ... (drifter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, hat keiner nen Plan, wie groß der Kondensator sein sollte?

Autor: Skua (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was fün Moped ist das denn 50ccm 1 Gang Automatik oder 2000ccm mit 100 
PS.
Da liegen auch Bordnetztechnisch Welten dazwischen.

Autor: Drifter ... (drifter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
weit über 50ccm mit über 100 PS! Das Bordnetz ist aber egal, es geht ja 
um die Spannung vom Drehzahlgeber!

Autor: Der wohl ahnungslose (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist der Tacho für dieses Gefährt überhaupt gedacht?
Also ist der Tacho kompatibel zu den Sensor-Signalen?
Vll ist auch bei der Beschreibung zu dem Tacho ein Umsetzer für Dein 
Fahrzeug/Sensor erwähnt.

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...ich will da so ein ding in das gerät mit dem stromkabel einbauen. was 
muss ich'n da beachten?... weiss denn da keiner was 'drüber?...

Bitte mehr Informationen wie z.B. Typ des Tachoneters, Art der 
Wegstreckenerfassung u.s.w. - Dann kann Dir mit Sicherheit auch geholfen 
werden!

Gruß

Autor: Karl Dietmann (karlmonster)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ein Kondensator bringt dir absolut nichts. Eines hab ich noch nicht ganz
kapiert - kommt aus deinem "Geber" ein Taktsignal (0 oder 5V für low /
high) oder ein Analogsignal (0-5V je nach Geschwindigkeit). Ist
natürlich wichtig, dass Geber und Tacho zusamnmenpassen. Beim Messen
wäre ich vorsichtig - du brauchst einen Oszilloskop
(http://de.wikipedia.org/wiki/Oszilloskop) dafür - mit einen normalen
Multimeter kann man das NICHT unterscheiden ! Ne einfachere Möglichkeit
wäre einfach ne LED an Masse - Signal. Dann am Rad LANGSAM drehen - beim
Taktsignal darf die LED nur einmal kurz pro Umdrehung aufblitzen.
Wenn wir wissen, welche "Messart" benutzt wird, können wir über
Maßnahmen nachdenken.
Ich persönlich vermute ja, dass einfach Geber und Tacho nicht
zusammenpassen... aber mal schaun


gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.