www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Transistorschaltung vor Relaismodul


Autor: Marco B. (marcob)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

um mit einer Schaltuhr mit einer Schaltausgangsspannung von 1,2V ein 
Relaismodul (http://www.kemo-electronic.com/de/bausaetze/b197/index.htm) 
anzusteuern, habe ich mir eine Transistorschaltung ausgedacht, mit 
LTspice simuliert und zusammengelötet.

Leider weichen die gemessenen Werte von den simulierten ab und das 
Ergebnis ist nicht wie erwartet.

Jetzt erhoffe ich mir Hilfe von hier.

Auf dem Bild sieht man meine Schaltung zwischen EINGANG und AUSGANG.
Links davon ist eine externe Spannungsquelle und der Schaltausgang der 
Schaltuhr, simuliert als Spannungsquelle mit Rechteckimpuls. Rechts 
davon ist grob die Schaltung des Relaismoduls, was man so von aussen 
sieht.

Hier noch die gemessenen/simulierten Spannungen gegen Masse:
U1: Spannung am Schaltausgang der Schaltuhr
U2: Spannung an der Basis des Transistor T1
U3: Spannung am Kollektor des Transistor T1
U4: Spannung an der Basis des Transistor T2
U5: Spannung am Kollektor des Transistor T2
U6: Spannung am AUSGANG meiner Schaltung
U7: Spannung auf der "12V-Leitung"

Ux_ein: Bei ON am Schaltausgang der Schaltuhr
Ux_aus: Bei OFF am Schaltausgang der Schaltuhr

Der erste Wert ist der gemessene, der zweite Wert der entsprechend 
simulierte:
(Alle Spannungen in [V])
U1_ein: 1,2 ... 1,2
U2_ein: 0,6 ... 0,65
U3_ein: 4,6 ...0,0
U4_ein: 12,0 ... 11,3
U5_ein: 3,6 ... 12,0
U6_ein: 3,6 ... 3,7
U7_ein: 12,5 ... 12,0

U1_aus: 0,0 ... 0,0
U2_aus: 0,6 ... 0,0
U3_aus: 9,3 ... 12,0
U4_aus: 12,0 ... 12,0
U5_aus: 2,5 ... 0,0
U6_aus: 2,5 ... 0,0
U7_aus: 12,0 ... 12,0

Das Relais schaltet so leider auch dann, wenn der Schaltausgang der 
Schaltuhr im AUS-Zustand ist, und das Relais ebenfalls nicht aktiv sein 
sollte.

Ich würde mich freuen, wenn jemandem der/die Fehler in der Schaltung 
oder bei den Größen der Bauelemente auffallen würde und/oder mir 
erklären könnte, weshalb dieses (unerwünschte) Ergebnis auftritt.

Gruß und Dank im Voraus
Marco

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zwischen der Basis von T2 und +12V solltest Du einen Pull-Up-Widerstand 
von 22-33k einfügen, dann sollte es funktionieren.

Otto

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich würde den ganzen Kram löschen.
Dann sieh mal nach unter dem Thema "Relais ansteuern".

Nimm einen BC547, lege das Schaltsignal über einen 4,7k-Ohm-Widerstand 
an die Basis, den Kollektor an die Spule und den Emitter an Masse.
Die Freilaufdiode über die Spule hast Du sicher nur vergessen.

Miß lieber mal, welche Spannungen aus dem Schaltsignal kommen. Wird da 
wirklich auf 0V geschaltet ?

Autor: Marco B. (marcob)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, und danke erstmal für die Antworten.

@Otto:
Werde ich probieren, sobald ich einen entsprechenden Widerstand 
aufgetrieben habe. Dann melde ich mich nochmal mit den erhaltenen 
Ergebnissen und hoffentlich der Erfolgsmeldung :).

@Bernd Rüter:
Wie im einleitenden Beitrag geschrieben ist das Relaismodul eine fertige 
(gekaufte) Schaltung, die ich nur ungern ändern möchte. Deshalb musste 
ich, als Krücke sozusagen, die beschriebene Schaltung basteln.
Zum zweiten sollte ich die Spannung aus dem Schaltsignal messen. Die 
entspricht der Spannung U1_aus aus meinem oberen Beitrag, wurde gemessen 
und beträgt da 0,0V.

Gruß
Marco

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wenn U1 wirklich auf 0V runtergeht beim ausschalten, und trotzdem 
ist U2_aus=U2_ein (also BAsis von T1), dann ist wohl mit T1 irgendwas 
faul - tausche den mal, bzw. prüfe mal die Anschlußbelegung.
Da man aber solch eine Spannungslage mit Falscheinbau kaum hinbekommen 
wird, denke ich eher an sanften Collector-Basis-Schluß im T1.
An irgendwelchen R's sollte es erstmal nicht liegen ...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.