www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ENC28J60-Schaltung: wie debuggen?


Autor: Ronald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo...

Ich habe mir eine Schaltung gebastelt, aehnlich dem Webmodul von Ulrich 
Radig. Also Atmega644, serielle Schnittstelle, SD-Kartenleser und ein 
ENC28J60 mit MagJack fuer das Netzwerk. Das Problem ist: die tut's 
nicht. Also der Controller geht, serielle Konsole auch. Mit der FW von 
Ulrichs Seite habe ich eine Kommandozeile auf der seriellen, da kann ich 
unter anderem die Revision des 28J60 auslesen. Kommunikation mit dem 
scheint also auch zu gehen.

Nur Netzwerk nicht.

Ich habe alles mehrfach geprueft. Der Schaltplan entspricht dem was ich 
in mehreren anderen Schaltungen gefunden habe, auf der Platine messe ich 
auch keine unerwarteten Kurzschluesse oder sowas. Aufgebaut habe ich das 
uebrigens mit SMD-Teilen auf einer einlagigen Platine.

An dem MagJack gehen nicht mal Lampen an. Weder mit noch ohne 
Kabelverbindung. Sollten die nicht leuchten?

Irgendwo habe ich gelesen dass man unter Umstaenden die Kondensatoren an 
dem 25MHz-Quarz 'anpassen' muss wenn es nicht funktioniert. Aber erstens 
habe ich da auch keine wirklich langen Leiterbahnen dran, und zweitens: 
was heisst 'anpassen'?

Ich bin ratlos wie ich da jetzt weiter machen kann. Hier habe ich schon 
viele hilfreiche Sachen gelesen, vielleicht hat jemand einen Tip fuer 
mich? Danke schon mal!


Ciao,
Ronald.

Autor: chester (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schaltung ist wo?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Irgendwo habe ich gelesen dass man unter Umstaenden die Kondensatoren an
>dem 25MHz-Quarz 'anpassen' muss wenn es nicht funktioniert. Aber erstens
>habe ich da auch keine wirklich langen Leiterbahnen dran, und zweitens:
>was heisst 'anpassen'?

'Anpassen' heißt weglassen meine ich mal gelesen
zu haben. Evtl. ist es auch der falsche Quarz.
Möglicherweise schwingt der auf der falschen Frequenz.
Brauchte man da jetzt einen Grundton oder Oberton
Quarz? Parallel Cut steht im Datenblatt.

Autor: Ronald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@chester: Die Schaltung habe ich gerade nicht greifbar, da bin ich mir 
aber auch ziemlich sicher dass die korrekt ist. Der ENC-Teil ist ja 
ueberall in etwa gleich, das ist bei mir genau so. Mir geht es um das 
Fehlerfinden an der aufgebauten Schaltung.

@holger: Weglassen kann ich mal versuchen. In der Hoffnung, da nichts 
mit kaputt zu machen. Ich habe den einzigen SMD-Quarz mit 25MHz bestellt 
den man bei CSD kriegen kann (Best.-Nr. 14-4S25,000MHZ), da die auch den 
ENC haben dachte ich blauaeugig dass das so passen muesste.


Unabhaengig davon: sollten die LEDs in dem MagJack schon leuchten wenn 
ich die Schaltung in Betrieb nehme? Oder erst wenn ich ein Kabel 
reinstecke? Oder erst wenn ein Link da ist?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.