www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik fuse bits, jetzt keine funktion


Autor: Tom R. (t0m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo, ich habe meinen mega2560 auf den internen 128kHz takt gestellt. 
nun gibt der chip keinen ton mehr von sich.
mit nem zweiten mega2560 habe ich mir ein 5V 10kHz clock generiert und 
an xtal1 angelegt. xtal2 liegt auf masse. leider tut sich nun auch nix. 
hab das clock signal mit dem oszi gemessen, ist ok.

wäre nett wenn mir jemand helfen würde!?

gruß tom

Autor: Steven () (ovular) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die Xtal-Eingänge offen?

Autor: Tom R. (t0m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie meinst du offen? die pins liegen außen!

Autor: Steven () (ovular) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weder ein Potential noch irgend ein quarz daran anschließen.
Einfach nichts daran anschließen.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Offen = unbeschaltet.

Du hast ja auch beachtet, dass der ISP Programmiertakt immer nur 1/4 des 
Prozessortakt sein darf? Also würde ich an deiner Stelle maximal 30kHz 
ISP Takt einstellen.

Autor: Tom R. (t0m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steven W.: sieh beitrag. xtal1 externer oszillator und xtal2 masse

Simon K.: einfacher wird es sein den externen takt um zustellen (zweiter 
µC), denn wie ich bei meinem programmer die frwuenz umstllen kann weiß 
ich nicht.

Autor: MWS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann hast Du ein Problem.

Wenn auf internen Clock gestellt ist, kannst Du extern soviel Clock 
draufgeben bis Du schwarz bist. Das hilft nix. ISP Frequenz muss runter.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> denn wie ich bei meinem programmer die frwuenz umstllen kann weiß
> ich nicht.

Du stellst die Frequenz nicht im Programmer ein, sondern in deinem 
Brennprogramm.

Autor: Tom R. (t0m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe des öffteren gelesen, dass fehlerhaften einstellungen ein takt 
angenommen wird. aber gut ich probiert mal mit dem isp takt.

nutze avrdude mit AVR-Burn-O-Mat als GUI. Wo gibt es die Einstellung 
dort? Habe nicht gefunden.

Autor: Tom R. (t0m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe nun mit der avrdude option "-i <num>" das programmieren von 10 bis 
100 getestet. leider gibt es ist keine programmiereung möglich.
habt ihr noch eine idee?

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tom R. wrote:
> habe nun mit der avrdude option "-i <num>" das programmieren von 10 bis
> 100 getestet. leider gibt es ist keine programmiereung möglich.
> habt ihr noch eine idee?

Probiere mal die Option -B50. Die Bitclock des ISP hat so eine 
Periodendauer von 50µs, was einer 20kHz Clock entspricht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.