www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Triac für Heizungsmischer


Autor: Michael Müller (moonuser)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich weiss es gibt viele Einträge zu diesem Thema, allerdings hat mich 
hie noch nichts zur Lösung gebracht. (Habe einiges probiert)
Also ich möchte einen Mischer über einen uc steuern.
Die Schaltung im Anhang habe ich verwendet. Einziger Unterschied: der 
Triac ist ein BT 138-600 oder 800.
Am Anfang sah es ganz gut aus, bis der Mischer plötzlich während der 
Fahrt komisch brummte, sich aber bewegt hat.
Irgendwann fuhr er auf (War so gewollt) aber beim abschalten sofort 
wieder zu (Triac aber nicht gesteuert).
Dann habe ich jedem Mischer 40 W Glühobst parallel dazu geschalten- 
Problem weg, allerdings ist der Mischer sehr laut (schnarren).
Also er lässt sich nun mit dem Glühobst auf und zu fahren und bleibt 
auch stehen.
War dann hier im Forum und habe eine Lösung gesucht:
Varistor- dachte mir ist logisch und habe einen mit 385 V zwischen T1 
und T2 gelegt. Glühobst raus- funktioniert nicht.
Dachte mir dann, das du/dt evtl zu groß ist also zusätzliche Drossel vor 
jede Wicklung. - Kein Erfolg, Schaltung geht nur mit zusätzlichem 
Glühobst.
Oszi dran- sehr gewundert... Bei meiner Messung zwischen T1 und T2 habe 
ich 675 V ss ????? woher kommen diese?
Wäre jemand so nett und könnte mir mal bitte sagen, wo der Fehler sein 
könnte?
Ach ja ohne Glühobst gibt es beim ausschalten der anderen Richtung einen 
kurzen Einbruch in der Spannung der entgegengesetzten. Bedeutet, er 
zündet wohl- aber warum? und warum nicht mir glühobst?
Vielen Dank!

: Verschoben durch Admin
Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das einzig kritische Teil in Deiner Zeichnung fehlt: Die Spule des 
Mischers, die
1.beim Abschalten die lästige induktive Abschaltspannung erzeugt.
2.Phasenverschiebung hat womit der Triac zur falschen Zeit zündet oder 
nicht gelöscht wird.

Daurch die Parallelschaltung Deiner Glühlampe überwiegt wahrscheinlich 
der ohmsche Anteil und der Triac arbeitet wieder normal.

zur besseren Vorstellung 
http://de.wikipedia.org/wiki/Phasenanschnittsteuerung

Autor: Michael Müller (moonuser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja richtig, eine Induktivität.
Daher auch der VDR. Aber wie bekomme ich das Problem behoben? Weil 
Grundsätzlich kann man ja Induktive Lasten schalten.
Ach eins noch wohl eher nicht so erheblich... Der Moc ist ein 3043.

Grüße

Autor: Michael Müller (moonuser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Nachtrag noch,

kann es sein, das das Gate vom BT 138 zu hochohmig ist und ich mir 
einfach nur einen Störimpuls einfange?

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael Müller schrieb:
> Ein Nachtrag noch,
>
> kann es sein, das das Gate vom BT 138 zu hochohmig ist und ich mir
> einfach nur einen Störimpuls einfange?


Durchaus möglich.
Widerstand 1k 0.25W vom Gate gegen N kann helfen.

Autor: Michael W. (retikulum)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Fairchild Datenblatt ist der Triactreiber ohne Vorwiderstand am Gate 
angeschlossen. Dafür aber vom Gate zu A1 noch 1 kOhm.
Michael

Autor: Michael Müller (moonuser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Michael,
werde es nachher direkt mal testen.

Michael

Autor: Michael Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
der Testbrachte keine Besserung. Der Motor ist wohl wie folgt aufgebaut:
 Hauptwicklung in jeder Phase und eine Hilfswicklung für beide 
Richtungen im N. Bedeutet der Triac bekommt von hinten Spannung. Wie 
kann ich ihn unter diesen Umständen sicher sperren?

Grüße Michael

Autor: Einhart Pape (einhart)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

zwar kenne ich deinen Mischer nicht, aber wenn er ähnlich ist wie die in 
meiner Heizungsanlage, dann reicht ein einfacher Koppler wie MOC3043 mit 
Varistor als Überspannungsschutz aus. Ich betreibe damit meine Mischer 
seit 15 Jahren. Bei der geringen Stromaufnahme der Motörchen ist keine 
Leistungsstufe notwendig.

Gruß
Einhart

Autor: peter-neu-ulm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kenne zwar die Daten des BT138 nicht genau, aber bei so kleinen 
Motorleistungen wie bei einem Stellventil reicht der Strom oft nicht 
aus, um das Triac leitend zu halten. Erst die zugeschaltete Lampe erhöht 
den Strom über den Mindest-Haltewert des Triacstroms. Also: anderes 
Triac verwenden, das kleineren Mindest-Haltestrom hat oder ganz auf das 
Triac verzichten und nur das Opt-Triac verwenden.

Autor: Michael Müller (moonuser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
und vielen Dank für die Antworten.
Ich glaube ich habe die Lösung für das Problem gefunden:

Die großen Triacs habe ich entfernt und das ganze nur mit dem RC 
betrieben.
Die Probleme waren nicht weg. Dann habe ich das RC Glied deaktiviert und 
siehe da auf einmal läuft alles. Der Mischer ist schön ruhig. Bisher 
hatte ich 47 Ohm und 100nF drin. Ich werde es noch mal mit 1 k 
versuchen, da die Ströme offensichtlich hier viel zu groß waren.

Grüße Michael

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst einen wesentlich kleineren C als 100 nF. Noch besser: Gar 
keinen und statt dessen einen Varistor. Dein Übergang auf 1k wird zwar 
auch helfen, aber die URSACHE ist eine andere für Dein Mischerproblem.

Denn der Innenaufbau Deines Mischermotors ist von der Kontruktion so 
ausgelegt, das er NICHT gleichzeitg an Vor/Rück eine Wechselspannung 
erwartet.

Genau diese legst Du aber an, wenn Du Dein RC-Glied dran hast. Diese ist 
zwar gering, aber das die Leistungen der Mischermotoren relativ winzig 
sind: Reicht aus und führt zur Fehlfunktion.

DAS ist die eigentliche Ursache Deines Problems.
Hat bisher wohl noch keiner der anderen Schreiber hier erkannt.

Einzig Einhart Pape hatte es indirekt beschrieben, indem er eine Lösung 
zur Funktion vorstellte.

Autor: Michael Müller (moonuser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Andrew,

dann werde ich es raus lassen.

Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.